aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-18 20:40:18 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-18 20:40:18 +0000
commite276c33eabd09e97196da53eed6d05f22b012775 (patch)
tree57177b4a52e5aa7e25116d971c6498301cb6e581 /devel
parent05e2e6dbaffe2ff4a8f2d64f948f9c5830b5cc82 (diff)
downloadports-e276c33eabd09e97196da53eed6d05f22b012775.tar.gz
ports-e276c33eabd09e97196da53eed6d05f22b012775.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/kprof/Makefile28
-rw-r--r--devel/kprof/distinfo1
-rw-r--r--devel/kprof/pkg-comment1
-rw-r--r--devel/kprof/pkg-descr12
-rw-r--r--devel/kprof/pkg-plist10
6 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7585704e26cf..f040c8c3b273 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -237,6 +237,7 @@
SUBDIR += kimwitu
SUBDIR += kimwitu++
SUBDIR += korelib
+ SUBDIR += kprof
SUBDIR += lbpp
SUBDIR += lemon
SUBDIR += leoarg
diff --git a/devel/kprof/Makefile b/devel/kprof/Makefile
new file mode 100644
index 000000000000..319383454a67
--- /dev/null
+++ b/devel/kprof/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: kprof
+# Date Created: 24 December 2001
+# Whom: Paul Marquis <pmarquis@pobox.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kprof
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pmarquis@pobox.com
+
+USE_KDELIBS_VER= 2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= KDEDIR=${PREFIX} MOC=moc2 LIBQT=-lqt2
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-extra-includes=${PREFIX}/include \
+ --with-extra-libs=${PREFIX}/lib \
+ --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib
+USE_GMAKE= yes
+MAKE_ENV= ${CONFIGURE_ENV}
+
+.include <bsd.port.mk>
diff --git a/devel/kprof/distinfo b/devel/kprof/distinfo
new file mode 100644
index 000000000000..c0f2146d3791
--- /dev/null
+++ b/devel/kprof/distinfo
@@ -0,0 +1 @@
+MD5 (kprof-1.3.tar.gz) = bb20a4b9ccd750235d2cc3ec055d79f9
diff --git a/devel/kprof/pkg-comment b/devel/kprof/pkg-comment
new file mode 100644
index 000000000000..393dfb4dbf3e
--- /dev/null
+++ b/devel/kprof/pkg-comment
@@ -0,0 +1 @@
+A profiling tool for KDE.
diff --git a/devel/kprof/pkg-descr b/devel/kprof/pkg-descr
new file mode 100644
index 000000000000..66cad6e74160
--- /dev/null
+++ b/devel/kprof/pkg-descr
@@ -0,0 +1,12 @@
+KProf is a visual tool for developers, which displays the execution
+profiling output generated by code profilers. The output of
+profilers
+being usually difficult to read (beyond the flat profile
+information),
+KProf presents the information in list- or tree-views that make the
+information very easy to understand.
+
+WWW: http://kprof.sourceforge.net/
+
+- Paul Marquis
+pmarquis@pobox.com
diff --git a/devel/kprof/pkg-plist b/devel/kprof/pkg-plist
new file mode 100644
index 000000000000..f1ef4165f7f1
--- /dev/null
+++ b/devel/kprof/pkg-plist
@@ -0,0 +1,10 @@
+bin/kprof
+share/applnk/Development/kprof.desktop
+share/apps/kprof/kprofui.rc
+share/doc/HTML/en/kprof/common
+share/doc/HTML/en/kprof/index.docbook
+share/doc/HTML/en/kprof/redo.png
+share/icons/locolor/16x16/apps/kprof.png
+share/icons/locolor/32x32/apps/kprof.png
+@dirrm share/doc/HTML/en/kprof
+@dirrm share/apps/kprof