aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-20 20:15:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-20 20:15:30 +0000
commit1db411919bd87c5e5af5a29da2b7dcea502cf752 (patch)
tree8b34b476a3e4508159238a8b8e276ba91638d52d /devel
parentf76c5d0e5ec93b487a573e2cbfd3894f17ff9d00 (diff)
downloadports-1db411919bd87c5e5af5a29da2b7dcea502cf752.tar.gz
ports-1db411919bd87c5e5af5a29da2b7dcea502cf752.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-protected_attributes/Makefile22
-rw-r--r--devel/rubygem-protected_attributes/distinfo2
-rw-r--r--devel/rubygem-protected_attributes/pkg-descr8
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2c26a62c83ff..46bad11232bb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4840,6 +4840,7 @@
SUBDIR += rubygem-power_assert
SUBDIR += rubygem-powerbar
SUBDIR += rubygem-progressbar
+ SUBDIR += rubygem-protected_attributes
SUBDIR += rubygem-prototype-rails
SUBDIR += rubygem-pry
SUBDIR += rubygem-pry-rails
diff --git a/devel/rubygem-protected_attributes/Makefile b/devel/rubygem-protected_attributes/Makefile
new file mode 100644
index 000000000000..8db1bf9044bd
--- /dev/null
+++ b/devel/rubygem-protected_attributes/Makefile
@@ -0,0 +1,22 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= protected_attributes
+PORTVERSION= 1.1.3
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Protect attributes from mass assignment
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-activemodel4>=4.0.1:${PORTSDIR}/databases/rubygem-activemodel4
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-protected_attributes/distinfo b/devel/rubygem-protected_attributes/distinfo
new file mode 100644
index 000000000000..433954e39886
--- /dev/null
+++ b/devel/rubygem-protected_attributes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/protected_attributes-1.1.3.gem) = e3bf636ae271a55005271a6bfa1b5aca884d7448d56a638f8ea28241a5bef7bd
+SIZE (rubygem/protected_attributes-1.1.3.gem) = 15360
diff --git a/devel/rubygem-protected_attributes/pkg-descr b/devel/rubygem-protected_attributes/pkg-descr
new file mode 100644
index 000000000000..657bda4bacbb
--- /dev/null
+++ b/devel/rubygem-protected_attributes/pkg-descr
@@ -0,0 +1,8 @@
+Protect attributes from mass-assignment in Active Record models.
+
+This plugin adds the class methods attr_accessible and attr_protected to your
+models to be able to declare white or black lists of attributes.
+
+Note: This plugin will be officially supported until the release of Rails 5.0.
+
+WWW: https://github.com/rails/protected_attributes