aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-12 22:52:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-12 22:52:41 +0000
commit40f02f1dbe59aa1dc821af926429d4bd6a475148 (patch)
tree87a5516de7e11e7f3de2e5c0142c77b93e61811c /devel
parent7a5942d62c14b50be1f14033b410639303083b36 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/ocaml-camomile/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index 952872226baa..e618963b91ba 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -8,6 +8,7 @@
PORTNAME= camomile
PORTVERSION= 0.6.6
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,6 +22,7 @@ USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
USE_OCAML_LDCONFIG=yes
+USE_OCAML_WASH= yes
GNU_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
@@ -39,4 +41,14 @@ post-extract:
"s,([[:space:]]*)cp[[:space:]]*-f,\1\$${BSD_INSTALL_DATA}," \
${WRKSRC}/Makefile.in
+post-install:
+ @${FIND} ${DATADIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
.include <bsd.port.post.mk>