aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-14 21:27:48 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-14 21:27:48 +0000
commit61f31f975fc792fbf2e500da95c7472798adc07b (patch)
tree0a1561a63b74a48921115d2e3d1d13e26a4a136b /devel
parent7bd549895575fceb930cfed653cf6b3287a93923 (diff)
USE_LIBTOOL instead of local patch
Notes
Notes: svn path=/head/; revision=133364
Diffstat (limited to 'devel')
-rw-r--r--devel/korelib/Makefile1
-rw-r--r--devel/korelib/files/patch-ltmain.sh25
-rw-r--r--devel/libpeak/Makefile1
-rw-r--r--devel/libpeak/files/patch-ltmain.sh15
4 files changed, 2 insertions, 40 deletions
diff --git a/devel/korelib/Makefile b/devel/korelib/Makefile
index 4ad89eedae94..8d428d27fb2f 100644
--- a/devel/korelib/Makefile
+++ b/devel/korelib/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= http://www.smga3000.com/thekompany/Korelib/
MAINTAINER= ports@FreeBSD.org
COMMENT= A cross-platform C++ library for developing modular applications
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOMAKE_VER=14
diff --git a/devel/korelib/files/patch-ltmain.sh b/devel/korelib/files/patch-ltmain.sh
deleted file mode 100644
index 49aa4848e21b..000000000000
--- a/devel/korelib/files/patch-ltmain.sh
+++ /dev/null
@@ -1,25 +0,0 @@
---- ltmain.sh.orig Wed Jul 4 18:17:51 2001
-+++ ltmain.sh Sun May 16 23:46:08 2004
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libpeak/Makefile b/devel/libpeak/Makefile
index dc5435ec296b..dc4d4a3f23ee 100644
--- a/devel/libpeak/Makefile
+++ b/devel/libpeak/Makefile
@@ -15,6 +15,7 @@ MASTER_SITE_SUBDIR= peak
MAINTAINER= ports@FreeBSD.org
COMMENT= Parallel Events and Asynchronous tasKing Library
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/devel/libpeak/files/patch-ltmain.sh b/devel/libpeak/files/patch-ltmain.sh
deleted file mode 100644
index 2cfdee5e6d32..000000000000
--- a/devel/libpeak/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Fri Mar 18 10:55:56 2005
-+++ ltmain.sh Fri Mar 18 10:56:06 2005
-@@ -5580,10 +5580,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"