aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2014-03-17 03:11:51 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2014-03-17 03:11:51 +0000
commit865cd6b8fcaba7362e89c86708c5a1d530d670eb (patch)
tree19fff2176cc592bf1a26df4b9422e824a7860043 /devel
parentd6f8c6d5b401356b6aaa956ed68a75390e3d11ec (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/giggle/Makefile38
-rw-r--r--devel/giggle/distinfo4
-rw-r--r--devel/giggle/pkg-descr2
-rw-r--r--devel/giggle/pkg-plist164
4 files changed, 152 insertions, 56 deletions
diff --git a/devel/giggle/Makefile b/devel/giggle/Makefile
index 07b4fc4562ae..f2e2e0b6f504 100644
--- a/devel/giggle/Makefile
+++ b/devel/giggle/Makefile
@@ -2,42 +2,44 @@
# $FreeBSD$
PORTNAME= giggle
-PORTVERSION= 0.5
-PORTREVISION= 4
+PORTVERSION= 0.7
CATEGORIES= devel
MASTER_SITES= GNOME
MAINTAINER= ashish@FreeBSD.org
COMMENT= GTK+ frontend for git version control system
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= git:${PORTSDIR}/devel/git \
- p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ itstool:${PORTSDIR}/textproc/itstool
RUN_DEPENDS= git:${PORTSDIR}/devel/git
-OPTIONS_DEFINE= VTE
-OPTIONS_DEFAULT= VTE
+OPTIONS_DEFINE= VTE NLS
+OPTIONS_DEFAULT= VTE NLS
VTE_DESC= Terminal Widget
GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USE_GNOME= glib20 gtk20 gtksourceview2 libglade2
-USES= gettext gmake pkgconfig
+USE_XZ= yes
+USE_GNOME= glib20 gtk30 libglade2 gtksourceview3 gdkpixbuf2
+USES= gmake pkgconfig
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lintl `pkg-config -libs gmodule-2.0`
+LDFLAGS+= -L${LOCALBASE}/lib -lintl `${LOCALBASE}/bin/pkg-config -libs gmodule-2.0`
INSTALL_TARGET= install-strip
PLIST_SUB+= GIGGLE_VER=${PORTVERSION}
-CONFIGURE_ARGS+= --disable-evolution-data-server
+CONFIGURE_ARGS+= --disable-evolution-data-server \
+ --with-git-command=${LOCALBASE}/bin/git
+
+OPTIONS_SUB= VTE
-.include <bsd.port.options.mk>
+VTE_USE= GNOME=vte3
+VTE_CONFIGURE_ENABLE= terminal
-.if ${PORT_OPTIONS:MVTE}
-USE_GNOME+= vte
-PLIST_SUB+= VTE=""
-.else
-CONFIGURE_ARGS+= --disable-terminal
-PLIST_SUB+= VTE="@comment "
-.endif
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
.include <bsd.port.mk>
diff --git a/devel/giggle/distinfo b/devel/giggle/distinfo
index 503e23e3af71..be06b8611578 100644
--- a/devel/giggle/distinfo
+++ b/devel/giggle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (giggle-0.5.tar.bz2) = 2e2c70d25159d31c87d155c9f799e0f1feb30fe26fc8aaf207ca6b3bd9b2b259
-SIZE (giggle-0.5.tar.bz2) = 486406
+SHA256 (giggle-0.7.tar.xz) = ae2e2237fa0d0999d99d0a0ee9b7ec147e80bd2472d59a045b2b01eb02261f59
+SIZE (giggle-0.7.tar.xz) = 2042304
diff --git a/devel/giggle/pkg-descr b/devel/giggle/pkg-descr
index a17216ad734d..2ae3c0d0ade8 100644
--- a/devel/giggle/pkg-descr
+++ b/devel/giggle/pkg-descr
@@ -1,4 +1,4 @@
Giggle is a graphical frontend for the git
directory tracker (think of gitk on GTK+).
-WWW: http://live.gnome.org/giggle
+WWW: http://live.gnome.org/giggle
diff --git a/devel/giggle/pkg-plist b/devel/giggle/pkg-plist
index b031908a4363..a9554d594f4d 100644
--- a/devel/giggle/pkg-plist
+++ b/devel/giggle/pkg-plist
@@ -1,27 +1,93 @@
bin/giggle
-include/giggle/libgiggle-git/giggle-git-add-ref.h
-include/giggle/libgiggle-git/giggle-git-add.h
+share/help/sl/giggle/browse-view.page
+share/help/sl/giggle/license.page
+share/help/sl/giggle/index.page
+share/help/sl/giggle/opening-repositories.page
+share/help/sl/giggle/tagging-commits.page
+share/help/sl/giggle/history-view.page
+share/help/sl/giggle/introduction.page
+share/help/ro/giggle/opening-repositories.page
+share/help/ro/giggle/introduction.page
+share/help/ro/giggle/license.page
+share/help/ro/giggle/browse-view.page
+share/help/ro/giggle/tagging-commits.page
+share/help/ro/giggle/index.page
+share/help/ro/giggle/history-view.page
+share/help/ro/giggle/figures/giggle-history_view_sections.png
+share/help/ro/giggle/figures/giggle-browse_view_sections.png
+share/help/C/giggle/history-view.page
+share/help/C/giggle/index.page
+share/help/C/giggle/browse-view.page
+share/help/C/giggle/license.page
+share/help/C/giggle/tagging-commits.page
+share/help/C/giggle/introduction.page
+share/help/C/giggle/opening-repositories.page
+share/help/C/giggle/figures/giggle-browse_view_sections.png
+share/help/C/giggle/figures/giggle-history_view_sections.png
+share/help/de/giggle/index.page
+share/help/de/giggle/figures/giggle-history_view_sections.png
+share/help/de/giggle/figures/giggle-browse_view_sections.png
+share/help/de/giggle/browse-view.page
+share/help/de/giggle/history-view.page
+share/help/de/giggle/license.page
+share/help/de/giggle/opening-repositories.page
+share/help/de/giggle/tagging-commits.page
+share/help/de/giggle/introduction.page
+share/help/cs/giggle/browse-view.page
+share/help/cs/giggle/history-view.page
+share/help/cs/giggle/opening-repositories.page
+share/help/cs/giggle/tagging-commits.page
+share/help/cs/giggle/index.page
+share/help/cs/giggle/figures/giggle-history_view_sections.png
+share/help/cs/giggle/figures/giggle-browse_view_sections.png
+share/help/cs/giggle/introduction.page
+share/help/cs/giggle/license.page
+share/help/fr/giggle/introduction.page
+share/help/fr/giggle/tagging-commits.page
+share/help/fr/giggle/browse-view.page
+share/help/fr/giggle/history-view.page
+share/help/fr/giggle/index.page
+share/help/fr/giggle/opening-repositories.page
+share/help/fr/giggle/license.page
+share/help/fr/giggle/figures/giggle-history_view_sections.png
+share/help/fr/giggle/figures/giggle-browse_view_sections.png
+share/help/pl/giggle/opening-repositories.page
+share/help/pl/giggle/tagging-commits.page
+share/help/pl/giggle/introduction.page
+share/help/pl/giggle/browse-view.page
+share/help/pl/giggle/license.page
+share/help/pl/giggle/index.page
+share/help/pl/giggle/history-view.page
+share/help/es/giggle/history-view.page
+share/help/es/giggle/browse-view.page
+share/help/es/giggle/introduction.page
+share/help/es/giggle/license.page
+share/help/es/giggle/opening-repositories.page
+share/help/es/giggle/tagging-commits.page
+share/help/es/giggle/index.page
+include/giggle/libgiggle-git/giggle-git-list-tree.h
+include/giggle/libgiggle-git/giggle-git-revisions.h
include/giggle/libgiggle-git/giggle-git-authors.h
-include/giggle/libgiggle-git/giggle-git-blame.h
-include/giggle/libgiggle-git/giggle-git-cat-file.h
-include/giggle/libgiggle-git/giggle-git-commit.h
-include/giggle/libgiggle-git/giggle-git-config-read.h
-include/giggle/libgiggle-git/giggle-git-config-write.h
-include/giggle/libgiggle-git/giggle-git-config.h
-include/giggle/libgiggle-git/giggle-git-delete-ref.h
-include/giggle/libgiggle-git/giggle-git-diff-tree.h
+include/giggle/libgiggle-git/giggle-git-refs.h
+include/giggle/libgiggle-git/giggle-git-ignore.h
+include/giggle/libgiggle-git/giggle-git-add-ref.h
include/giggle/libgiggle-git/giggle-git-diff.h
include/giggle/libgiggle-git/giggle-git-enums.h
-include/giggle/libgiggle-git/giggle-git-ignore.h
-include/giggle/libgiggle-git/giggle-git-list-files.h
-include/giggle/libgiggle-git/giggle-git-list-tree.h
-include/giggle/libgiggle-git/giggle-git-log.h
-include/giggle/libgiggle-git/giggle-git-refs.h
-include/giggle/libgiggle-git/giggle-git-remote-list.h
-include/giggle/libgiggle-git/giggle-git-revisions.h
+include/giggle/libgiggle-git/giggle-git-commit.h
+include/giggle/libgiggle-git/giggle-git-clone.h
+include/giggle/libgiggle-git/giggle-git-blame.h
include/giggle/libgiggle-git/giggle-git.h
+include/giggle/libgiggle-git/giggle-git-remote-list.h
+include/giggle/libgiggle-git/giggle-git-diff-tree.h
+include/giggle/libgiggle-git/giggle-git-log.h
+include/giggle/libgiggle-git/giggle-git-delete-ref.h
+include/giggle/libgiggle-git/giggle-git-add.h
+include/giggle/libgiggle-git/giggle-git-config.h
+include/giggle/libgiggle-git/giggle-git-list-files.h
+include/giggle/libgiggle-git/giggle-git-cat-file.h
+include/giggle/libgiggle-git/giggle-git-config-write.h
+include/giggle/libgiggle-git/giggle-git-config-read.h
include/giggle/libgiggle/giggle-enums.h
-include/giggle/libgiggle/giggle-marshal.h
lib/giggle/plugins/%%GIGGLE_VER%%/libpersonal-details.la
lib/giggle/plugins/%%GIGGLE_VER%%/libpersonal-details.so
%%VTE%%lib/giggle/plugins/%%GIGGLE_VER%%/libterminal-view.la
@@ -36,40 +102,46 @@ lib/libgiggle.so
lib/libgiggle.so.0
share/applications/giggle.desktop
%%DATADIR%%/glade/main-window.ui
-share/icons/hicolor/16x16/apps/giggle-branch.png
-share/icons/hicolor/16x16/apps/giggle-history-view.png
-share/icons/hicolor/16x16/apps/giggle-remote.png
-share/icons/hicolor/16x16/apps/giggle-scm-git.png
-share/icons/hicolor/16x16/apps/giggle-scm-svn.png
share/icons/hicolor/16x16/apps/giggle-tag.png
+share/icons/hicolor/16x16/apps/giggle-scm-git.png
share/icons/hicolor/16x16/apps/giggle.png
+share/icons/hicolor/16x16/apps/giggle-scm-svn.png
+share/icons/hicolor/16x16/apps/giggle-remote.png
+share/icons/hicolor/16x16/apps/giggle-history-view.png
+share/icons/hicolor/16x16/apps/giggle-branch.png
+share/icons/hicolor/32x32/apps/giggle.png
+share/icons/hicolor/32x32/apps/giggle-history-view.png
share/icons/hicolor/22x22/apps/giggle-history-view.png
share/icons/hicolor/22x22/apps/giggle.png
+share/icons/hicolor/scalable/apps/giggle.svg
share/icons/hicolor/24x24/apps/giggle-diff-view.png
share/icons/hicolor/24x24/apps/giggle-history-view.png
share/icons/hicolor/24x24/apps/giggle.png
-share/icons/hicolor/32x32/apps/giggle-history-view.png
-share/icons/hicolor/32x32/apps/giggle.png
share/icons/hicolor/48x48/apps/giggle-scm-svn.png
share/icons/hicolor/48x48/apps/giggle.png
-share/icons/hicolor/scalable/apps/giggle.svg
-share/locale/ca/LC_MESSAGES/giggle.mo
-share/locale/cs/LC_MESSAGES/giggle.mo
-share/locale/de/LC_MESSAGES/giggle.mo
+share/locale/pl/LC_MESSAGES/giggle.mo
share/locale/en_GB/LC_MESSAGES/giggle.mo
share/locale/es/LC_MESSAGES/giggle.mo
-share/locale/fr/LC_MESSAGES/giggle.mo
-share/locale/gl/LC_MESSAGES/giggle.mo
share/locale/hu/LC_MESSAGES/giggle.mo
-share/locale/ja/LC_MESSAGES/giggle.mo
+share/locale/gl/LC_MESSAGES/giggle.mo
share/locale/nb/LC_MESSAGES/giggle.mo
share/locale/pa/LC_MESSAGES/giggle.mo
-share/locale/pl/LC_MESSAGES/giggle.mo
-share/locale/ru/LC_MESSAGES/giggle.mo
-share/locale/sl/LC_MESSAGES/giggle.mo
+share/locale/fr/LC_MESSAGES/giggle.mo
+share/locale/pt_BR/LC_MESSAGES/giggle.mo
+share/locale/ca@valencia/LC_MESSAGES/giggle.mo
+share/locale/cs/LC_MESSAGES/giggle.mo
share/locale/sv/LC_MESSAGES/giggle.mo
+share/locale/ru/LC_MESSAGES/giggle.mo
+share/locale/id/LC_MESSAGES/giggle.mo
share/locale/vi/LC_MESSAGES/giggle.mo
+share/locale/de/LC_MESSAGES/giggle.mo
+share/locale/ja/LC_MESSAGES/giggle.mo
+share/locale/uk/LC_MESSAGES/giggle.mo
+share/locale/da/LC_MESSAGES/giggle.mo
+share/locale/ca/LC_MESSAGES/giggle.mo
+share/locale/ro/LC_MESSAGES/giggle.mo
share/locale/zh_CN/LC_MESSAGES/giggle.mo
+share/locale/sl/LC_MESSAGES/giggle.mo
@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
@dirrm lib/giggle/plugins/%%GIGGLE_VER%%
@@ -78,3 +150,25 @@ share/locale/zh_CN/LC_MESSAGES/giggle.mo
@dirrm include/giggle/libgiggle-git
@dirrm include/giggle/libgiggle
@dirrm include/giggle
+@dirrm share/help/sl/giggle
+@dirrm share/help/sl
+@dirrm share/help/ro/giggle/figures
+@dirrm share/help/ro/giggle
+@dirrm share/help/ro
+@dirrm share/help/pl/giggle
+@dirrm share/help/pl
+@dirrm share/help/fr/giggle/figures
+@dirrm share/help/fr/giggle
+@dirrm share/help/fr
+@dirrm share/help/es/giggle
+@dirrm share/help/es
+@dirrm share/help/de/giggle/figures
+@dirrm share/help/de/giggle
+@dirrm share/help/de
+@dirrm share/help/cs/giggle/figures
+@dirrm share/help/cs/giggle
+@dirrm share/help/cs
+@dirrm share/help/C/giggle/figures
+@dirrm share/help/C/giggle
+@dirrm share/help/C
+@dirrm share/help