aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-05-09 01:20:36 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-05-09 01:20:36 +0000
commit867c78fefae915594921b48e37ea703f28bd7ebf (patch)
treeeb8e7b2ff0574d096f1cd22b3751395437e950e4 /devel
parent0d7fc5659e067ef6b9b4622f3ce4afe3b65b33d7 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Date-ICal/Makefile13
-rw-r--r--devel/p5-File-Cache/Makefile16
-rw-r--r--devel/p5-IPC-Cache/Makefile13
3 files changed, 27 insertions, 15 deletions
diff --git a/devel/p5-Date-ICal/Makefile b/devel/p5-Date-ICal/Makefile
index fb023a0ca142..941045817ac0 100644
--- a/devel/p5-Date-ICal/Makefile
+++ b/devel/p5-Date-ICal/Makefile
@@ -15,13 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl extension for ICalendar date objects
-BUILD_DEPENDS= ${SITE_PERL}/Date/Leapyear.pm:${PORTSDIR}/devel/p5-Date-Leapyear \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${SITE_PERL}/Date/Leapyear.pm:${PORTSDIR}/devel/p5-Date-Leapyear
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Date::ICal.3 Date::ICal::Duration.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Cache/Makefile b/devel/p5-File-Cache/Makefile
index 2b75987885b5..ffb2b78c1feb 100644
--- a/devel/p5-File-Cache/Makefile
+++ b/devel/p5-File-Cache/Makefile
@@ -15,14 +15,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module implementing a persistent object store
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= File::Cache.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IPC-Cache/Makefile b/devel/p5-IPC-Cache/Makefile
index ebb212c91648..69edf60a352b 100644
--- a/devel/p5-IPC-Cache/Makefile
+++ b/devel/p5-IPC-Cache/Makefile
@@ -15,13 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Persist data across processes via shared memory
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= IPC::Cache.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>