aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-12 18:52:10 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-12 18:52:10 +0000
commita93fc26011894c823d258244bd633398288ebf79 (patch)
treea4260201884e46e7e8d5795cf3ef7b96c2debb61 /devel
parente1bb21269378e21fe1b04bfb35bf4af835516bda (diff)
downloadports-a93fc26011894c823d258244bd633398288ebf79.tar.gz
ports-a93fc26011894c823d258244bd633398288ebf79.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Format-ISO8601/Makefile25
-rw-r--r--devel/p5-DateTime-Format-ISO8601/distinfo1
-rw-r--r--devel/p5-DateTime-Format-ISO8601/pkg-descr4
-rw-r--r--devel/p5-DateTime-Format-ISO8601/pkg-plist4
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index db50fc1342a8..eba6cc40993b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -565,6 +565,7 @@
SUBDIR += p5-DateTime-Format-Epoch
SUBDIR += p5-DateTime-Format-Excel
SUBDIR += p5-DateTime-Format-ICal
+ SUBDIR += p5-DateTime-Format-ISO8601
SUBDIR += p5-DateTime-Format-Mail
SUBDIR += p5-DateTime-Format-MySQL
SUBDIR += p5-DateTime-Format-Pg
diff --git a/devel/p5-DateTime-Format-ISO8601/Makefile b/devel/p5-DateTime-Format-ISO8601/Makefile
new file mode 100644
index 000000000000..4dc28a5606c8
--- /dev/null
+++ b/devel/p5-DateTime-Format-ISO8601/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-DateTime-Format-ISO8601
+# Date created: 7 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-ISO8601
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Parse ISO8601 formats
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Format/Builder.pm:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-ISO8601/distinfo b/devel/p5-DateTime-Format-ISO8601/distinfo
new file mode 100644
index 000000000000..efae74986d29
--- /dev/null
+++ b/devel/p5-DateTime-Format-ISO8601/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-ISO8601-0.03.tar.gz) = 6de667549dc56f65978b53fd2fff84a2
diff --git a/devel/p5-DateTime-Format-ISO8601/pkg-descr b/devel/p5-DateTime-Format-ISO8601/pkg-descr
new file mode 100644
index 000000000000..79f783cbeac1
--- /dev/null
+++ b/devel/p5-DateTime-Format-ISO8601/pkg-descr
@@ -0,0 +1,4 @@
+Parses almost all ISO 8601:2000(E) date and time formats. ISO 8601:2000(E)
+time-intervals will be supported in a later release.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-ISO8601/pkg-plist b/devel/p5-DateTime-Format-ISO8601/pkg-plist
new file mode 100644
index 000000000000..1f679b9cc41f
--- /dev/null
+++ b/devel/p5-DateTime-Format-ISO8601/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/DateTime/Format/ISO8601.pm
+%%SITE_PERL%%/DateTime/Format/ISO8601.pod
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true