aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2012-10-10 01:47:02 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2012-10-10 01:47:02 +0000
commitbf635b9acdbfe9688a116369ca7c4f2201dff585 (patch)
tree63f497e9caae9100118077cb43b07612d4f951c6 /devel
parent1dbd21cc50700b2db8611b2fe37386e0cf9c7e44 (diff)
- Added search path for libexecinfo to prevent configure error [1]
- Mark port BROKEN for versions of FreeBSD that don't include POSIX spawn(). It may be possible to convert the spawn() code back to fork()/exec() for FreeBSD 7.x, and I'll look into that and unbreak once it's ready. [2] Reported by: ports ML [1] Reported by: bdrewery [2]
Notes
Notes: svn path=/head/; revision=305626
Diffstat (limited to 'devel')
-rw-r--r--devel/gearmand/Makefile7
-rw-r--r--devel/gearmand/files/extra-patch-libtest__test.cc14
2 files changed, 4 insertions, 17 deletions
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 25703398a5b2..6e5607a337d5 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -44,7 +44,8 @@ SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS}
CONFIGURE_ARGS+=--with-lib-prefix=${LOCALBASE} --with-boost=${LOCALBASE} \
--localstatedir=/var/db/${PORTNAME} --enable-static
-LDFLAGS+= -lexecinfo
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
OPTIONS_DEFINE= DRIZZLE MEMCACHED PGSQL SQLITE MYSQL HIREDIS TOKYOCAB
OPTIONS_DEFAULT=SQLITE
@@ -216,8 +217,8 @@ MAN8= gearmand.8
# Workaround for missing sigignore that wasn't introduced until
# FreeBSD 8.0
-.if ${OSVERSION} < 800500
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libtest__test.cc
+.if ${OSVERSION} < 800041
+BROKEN= Does not compile without POSIX spawn() support
.endif
.if ${PORT_OPTIONS:MDRIZZLE}
diff --git a/devel/gearmand/files/extra-patch-libtest__test.cc b/devel/gearmand/files/extra-patch-libtest__test.cc
deleted file mode 100644
index c4098399716e..000000000000
--- a/devel/gearmand/files/extra-patch-libtest__test.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./libtest/test.cc.orig 2012-01-27 17:12:33.000000000 -0500
-+++ ./libtest/test.cc 2012-01-27 17:14:02.000000000 -0500
-@@ -113,7 +113,10 @@
- return EXIT_FAILURE;
- }
-
-- assert(sigignore(SIGPIPE) == 0);
-+ struct sigaction ignore_action;
-+ ignore_action.sa_handler = SIG_IGN;
-+ ignore_action.sa_flags = SA_RESTART;
-+ assert(sigaction(SIGPIPE, &ignore_action, NULL) == 0);
-
- libtest::SignalThread signal;
- if (not signal.setup())