aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
commitf5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa (patch)
tree343e91600b9cf81ffb94bf71017b43a88bfcbf45 /devel
parente9e0ba8df0a817712eab81d4a962e79cae35dca1 (diff)
downloadports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.tar.gz
ports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/avarice/Makefile9
-rw-r--r--devel/avrdude/Makefile10
-rw-r--r--devel/libccid/Makefile7
-rw-r--r--devel/libccid/files/patch-src_ccid_usb.c11
-rw-r--r--devel/libccid/files/patch-src_parse.c10
-rw-r--r--devel/libftdi/Makefile18
-rw-r--r--devel/libftdi/files/extra-patch-configure.in34
-rw-r--r--devel/libftdi/files/patch-examples_find_all.c10
-rw-r--r--devel/libftdi/files/patch-examples_simple.c10
-rw-r--r--devel/libgamepad/Makefile8
-rw-r--r--devel/libgamepad/files/extra-patch-gamepad_usbhid.c10
-rw-r--r--devel/libhid/Makefile11
-rw-r--r--devel/libhid/files/extra-patch-usb12
-rw-r--r--devel/libhid/files/patch-src_hid_initialisation.c10
-rw-r--r--devel/libhid/files/patch-src_hid_opening.c9
-rw-r--r--devel/libhid/files/patch-src_hid_parsing.c9
-rw-r--r--devel/libhid/files/patch-test_lshid.c10
-rw-r--r--devel/libhid/files/patch-test_test_libhid.c9
-rw-r--r--devel/libnxt/Makefile9
-rw-r--r--devel/libusb/Makefile4
-rw-r--r--devel/p5-Device-USB/Makefile9
-rw-r--r--devel/p5-usb/Makefile9
-rw-r--r--devel/pcsc-lite/Makefile8
-rw-r--r--devel/piklab/Makefile8
-rw-r--r--devel/py-usb/Makefile9
-rw-r--r--devel/roboctl/Makefile11
-rw-r--r--devel/urjtag/Makefile4
-rw-r--r--devel/urjtag/files/extra-patch-usb14
28 files changed, 267 insertions, 25 deletions
diff --git a/devel/avarice/Makefile b/devel/avarice/Makefile
index 76d285807a3d..defbb5ea50df 100644
--- a/devel/avarice/Makefile
+++ b/devel/avarice/Makefile
@@ -16,7 +16,6 @@ COMMENT= Atmel AVR JTAG programmer and debugging interface for avr-gdb
BUILD_DEPENDS= ${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd \
${LOCALBASE}/lib/libiberty.a:${PORTSDIR}/devel/gnulibiberty
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
USE_BZIP2= yes
USE_PERL5= yes
@@ -26,4 +25,10 @@ CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
MAN1= avarice.1 ice-gdb.1 ice-insight.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/avrdude/Makefile b/devel/avrdude/Makefile
index 08f4371e5b47..157d24df6af6 100644
--- a/devel/avrdude/Makefile
+++ b/devel/avrdude/Makefile
@@ -15,12 +15,16 @@ MASTER_SITE_SUBDIR= avrdude
MAINTAINER= joerg@FreeBSD.org
COMMENT= Program for programming the on-chip memory of Atmel AVR CPUs
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
MAN1= avrdude.1
MANCOMPRESSED= no
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libccid/Makefile b/devel/libccid/Makefile
index 0f2b2455b28f..21b4ea0772a1 100644
--- a/devel/libccid/Makefile
+++ b/devel/libccid/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= http://alioth.debian.org/frs/download.php/2656/
MAINTAINER= arved@FreeBSD.org
COMMENT= Generic USB CCID (Chip/Smart Card Interface Devices) driver
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
- pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -32,6 +31,10 @@ MAN8= Kobil_mIDentity_switch.8
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s,use warnings;,," ${WRKSRC}/src/create_Info_plist.pl
${REINPLACE_CMD} -e "s,ndef __APPLE__, !(__APPLE__ || __FreeBSD__)," ${WRKSRC}/contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.c
diff --git a/devel/libccid/files/patch-src_ccid_usb.c b/devel/libccid/files/patch-src_ccid_usb.c
new file mode 100644
index 000000000000..58e515f48f8f
--- /dev/null
+++ b/devel/libccid/files/patch-src_ccid_usb.c
@@ -0,0 +1,11 @@
+--- src/ccid_usb.c.orig 2009-03-07 20:05:04.000000000 +0300
++++ src/ccid_usb.c 2009-03-07 20:09:14.000000000 +0300
+@@ -56,6 +56,8 @@
+
+ #define BUS_DEVICE_STRSIZE 32
+
++EXTERNAL struct usb_interface * get_ccid_usb_interface(struct usb_device *dev);
++
+ typedef struct
+ {
+ usb_dev_handle *handle;
diff --git a/devel/libccid/files/patch-src_parse.c b/devel/libccid/files/patch-src_parse.c
new file mode 100644
index 000000000000..76ec2e613f89
--- /dev/null
+++ b/devel/libccid/files/patch-src_parse.c
@@ -0,0 +1,10 @@
+--- src/parse.c.orig 2009-03-07 20:07:07.000000000 +0300
++++ src/parse.c 2009-03-07 20:09:07.000000000 +0300
+@@ -46,6 +46,7 @@
+
+ static int ccid_parse_interface_descriptor(usb_dev_handle *handle,
+ struct usb_device *dev);
++struct usb_interface * get_ccid_usb_interface(struct usb_device *dev);
+
+
+ /*****************************************************************************
diff --git a/devel/libftdi/Makefile b/devel/libftdi/Makefile
index 3ce3cd6edbcb..76f9b4d0fe3f 100644
--- a/devel/libftdi/Makefile
+++ b/devel/libftdi/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= http://www.intra2net.com/de/produkte/opensource/ftdi/TGZ/
MAINTAINER= o.davydenko@gmail.com
COMMENT= A library (using libusb) to talk to FTDI chips
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
@@ -23,10 +21,24 @@ USE_GNOME= pkgconfig gnomehack
PORTDOCS= COPYING.LIB ChangeLog README
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
+USE_AUTOTOOLS+= autoconf:262
+.endif
+
+post-patch:
+.if ${OSVERSION} >= 800069
+ ${RM} -f ${WRKSRC}/configure
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libftdi/files/extra-patch-configure.in b/devel/libftdi/files/extra-patch-configure.in
new file mode 100644
index 000000000000..d3a8a6f6635c
--- /dev/null
+++ b/devel/libftdi/files/extra-patch-configure.in
@@ -0,0 +1,34 @@
+--- configure.in.orig 2009-03-07 20:14:41.000000000 +0300
++++ configure.in 2009-03-07 20:15:29.000000000 +0300
+@@ -7,30 +7,7 @@
+ AC_PROG_CC
+ AM_PROG_LIBTOOL
+
+-dnl check for libusb-config
+-AC_PATH_PROG(HAVELIBUSB, libusb-config, $PATH)
+-
+-if test ! -z "$HAVELIBUSB"; then
+- LIBUSB_CFLAGS=`$HAVELIBUSB --cflags`
+- LIBUSB_LIBS=`$HAVELIBUSB --libs`
+-
+- CFLAGS="$CFLAGS $LIBUSB_CFLAGS"
+- LIBS="$LIBS $LIBUSB_LIBS"
+-else
+- AC_MSG_ERROR([*** libusb-config not found. You need a working libusb installation.])
+-fi
+-
+-dnl check for version of libusb
+-AC_MSG_CHECKING([if libusb version is >= 0.1.7])
+-libusb_version_needed="1007"
+-libusb_version=`$HAVELIBUSB --version | sed -e "s/libusb //" | awk 'BEGIN { FS = "."; } { printf "%d", ($''1 * 1000 + $''2) * 1000 + $''3;}'`
+-
+-if test $libusb_version -lt $libusb_version_needed; then
+- AC_MSG_RESULT(no)
+- AC_MSG_ERROR([*** libusb is too old ($libusb_version). You need a libusb installation newer or equal to 0.1.7.])
+-else
+- AC_MSG_RESULT(yes)
+-fi
++LIBS="$LIBS -lusb"
+
+ ENABLE_ASYNC_MODE=0
+ AC_ARG_WITH(async-mode,
diff --git a/devel/libftdi/files/patch-examples_find_all.c b/devel/libftdi/files/patch-examples_find_all.c
new file mode 100644
index 000000000000..f4a15772d49e
--- /dev/null
+++ b/devel/libftdi/files/patch-examples_find_all.c
@@ -0,0 +1,10 @@
+--- examples/find_all.c.orig 2009-03-07 20:18:06.000000000 +0300
++++ examples/find_all.c 2009-03-07 20:18:52.000000000 +0300
+@@ -6,6 +6,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ftdi.h>
+
+ int main(int argc, char **argv)
diff --git a/devel/libftdi/files/patch-examples_simple.c b/devel/libftdi/files/patch-examples_simple.c
new file mode 100644
index 000000000000..8aaf9e4a075e
--- /dev/null
+++ b/devel/libftdi/files/patch-examples_simple.c
@@ -0,0 +1,10 @@
+--- examples/simple.c.orig 2009-03-07 20:12:44.000000000 +0300
++++ examples/simple.c 2009-03-07 20:14:10.000000000 +0300
+@@ -6,6 +6,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ftdi.h>
+
+ int main(int argc, char **argv)
diff --git a/devel/libgamepad/Makefile b/devel/libgamepad/Makefile
index d935f197c4fc..9342adec1781 100644
--- a/devel/libgamepad/Makefile
+++ b/devel/libgamepad/Makefile
@@ -19,4 +19,10 @@ pre-build:
MAN3= libgamepad.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800069
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-gamepad_usbhid.c
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libgamepad/files/extra-patch-gamepad_usbhid.c b/devel/libgamepad/files/extra-patch-gamepad_usbhid.c
new file mode 100644
index 000000000000..57de0a000c15
--- /dev/null
+++ b/devel/libgamepad/files/extra-patch-gamepad_usbhid.c
@@ -0,0 +1,10 @@
+--- gamepad_usbhid.c.orig 2009-03-08 12:35:35.000000000 +0300
++++ gamepad_usbhid.c 2009-03-08 12:35:44.000000000 +0300
+@@ -3,6 +3,7 @@
+ #include <string.h>
+ #include <sys/ioctl.h>
+ #include <dev/usb/usb.h>
++#include <dev/usb/usb_ioctl.h>
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>
diff --git a/devel/libhid/Makefile b/devel/libhid/Makefile
index 43568e1d1d7f..e9b915dca0ef 100644
--- a/devel/libhid/Makefile
+++ b/devel/libhid/Makefile
@@ -20,7 +20,6 @@ USE_LDCONFIG= yes
USE_GMAKE= yes
USE_PYTHON= yes
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/html:${PORTSDIR}/textproc/docbook-xsl \
${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
@@ -28,4 +27,12 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man --without-doxygen
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-usb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libhid/files/extra-patch-usb b/devel/libhid/files/extra-patch-usb
new file mode 100644
index 000000000000..af78de7e0e45
--- /dev/null
+++ b/devel/libhid/files/extra-patch-usb
@@ -0,0 +1,12 @@
+--- configure.orig 2007-04-26 04:25:25.000000000 +0400
++++ configure 2009-03-07 20:26:02.000000000 +0300
+@@ -4846,8 +4846,8 @@
+ done
+
+
+- LIBUSB_CFLAGS="`libusb-config --cflags`"
+- LIBUSB_LIBS="`libusb-config --libs`"
++ LIBUSB_CFLAGS=""
++ LIBUSB_LIBS="-lusb"
+
+
diff --git a/devel/libhid/files/patch-src_hid_initialisation.c b/devel/libhid/files/patch-src_hid_initialisation.c
new file mode 100644
index 000000000000..014adf4987dd
--- /dev/null
+++ b/devel/libhid/files/patch-src_hid_initialisation.c
@@ -0,0 +1,10 @@
+--- src/hid_initialisation.c.orig 2009-03-07 20:27:43.000000000 +0300
++++ src/hid_initialisation.c 2009-03-07 20:29:25.000000000 +0300
+@@ -4,6 +4,7 @@
+ #define HID_INTERNAL
+
+ #include "config.h"
++#include <stdlib.h>
+ #include <hid.h>
+ #include <hid_helpers.h>
+
diff --git a/devel/libhid/files/patch-src_hid_opening.c b/devel/libhid/files/patch-src_hid_opening.c
new file mode 100644
index 000000000000..19b080d901ee
--- /dev/null
+++ b/devel/libhid/files/patch-src_hid_opening.c
@@ -0,0 +1,9 @@
+--- src/hid_opening.c.orig 2009-03-07 20:28:09.000000000 +0300
++++ src/hid_opening.c 2009-03-07 20:29:17.000000000 +0300
+@@ -1,5 +1,6 @@
+ #define HID_INTERNAL
+
++#include <stdlib.h>
+ #include <hid.h>
+ #include <hid_helpers.h>
+ #include <os.h>
diff --git a/devel/libhid/files/patch-src_hid_parsing.c b/devel/libhid/files/patch-src_hid_parsing.c
new file mode 100644
index 000000000000..3eccd4b712e1
--- /dev/null
+++ b/devel/libhid/files/patch-src_hid_parsing.c
@@ -0,0 +1,9 @@
+--- src/hid_parsing.c.orig 2009-03-07 20:29:35.000000000 +0300
++++ src/hid_parsing.c 2009-03-07 20:29:43.000000000 +0300
+@@ -1,5 +1,6 @@
+ #define HID_INTERNAL
+
++#include <stdlib.h>
+ #include <hid.h>
+ #include <hid_helpers.h>
+
diff --git a/devel/libhid/files/patch-test_lshid.c b/devel/libhid/files/patch-test_lshid.c
new file mode 100644
index 000000000000..2b107ca7b9a1
--- /dev/null
+++ b/devel/libhid/files/patch-test_lshid.c
@@ -0,0 +1,10 @@
+--- test/lshid.c.orig 2009-03-07 20:30:14.000000000 +0300
++++ test/lshid.c 2009-03-07 20:30:20.000000000 +0300
+@@ -23,6 +23,7 @@
+
+ #include <hid.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ char *hid_id[32]; /* FIXME: 32 devices MAX */
diff --git a/devel/libhid/files/patch-test_test_libhid.c b/devel/libhid/files/patch-test_test_libhid.c
new file mode 100644
index 000000000000..dbb18830a719
--- /dev/null
+++ b/devel/libhid/files/patch-test_test_libhid.c
@@ -0,0 +1,9 @@
+--- test/test_libhid.c.orig 2009-03-07 20:29:59.000000000 +0300
++++ test/test_libhid.c 2009-03-07 20:30:05.000000000 +0300
+@@ -1,5 +1,6 @@
+ #include <hid.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ bool match_serial_number(struct usb_dev_handle* usbdev, void* custom, unsigned int len)
diff --git a/devel/libnxt/Makefile b/devel/libnxt/Makefile
index 72f977d39857..216e33d9acf4 100644
--- a/devel/libnxt/Makefile
+++ b/devel/libnxt/Makefile
@@ -14,13 +14,18 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
MAINTAINER= bacon@smithers.neuro.mcw.edu
COMMENT= Lego NXT library
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons \
python:${PORTSDIR}/lang/python
SUB_FILES= pkg-message
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
do-build:
(cd ${WRKSRC}; scons)
@@ -37,4 +42,4 @@ do-install:
post-install:
@${CAT} ${WRKDIR}/pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libusb/Makefile b/devel/libusb/Makefile
index dedc0dfb72e1..fef64e7d2fb4 100644
--- a/devel/libusb/Makefile
+++ b/devel/libusb/Makefile
@@ -19,6 +19,10 @@ OPTIONS= SGML "Install developer guide from SGML" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 800069
+IGNORE= has been already included into base system
+.endif
+
.if defined(WITH_SGML)
BUILD_DEPENDS+= ${LOCALBASE}/share/sgml/jade/catalog:${PORTSDIR}/textproc/jade \
${LOCALBASE}/share/sgml/docbook/dsssl/modular/catalog:${PORTSDIR}/textproc/dsssl-docbook-modular \
diff --git a/devel/p5-Device-USB/Makefile b/devel/p5-Device-USB/Makefile
index 739116a227fa..085052a259b8 100644
--- a/devel/p5-Device-USB/Makefile
+++ b/devel/p5-Device-USB/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= jwbacon@tds.net
COMMENT= Perl wrapper for libusb
BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
WRKSRC= ${WRKDIR}/Device-USB-0.21
PERL_CONFIGURE= yes
@@ -31,4 +30,10 @@ MAN3= Device::USB.3 \
Device::USB::FAQ.3 \
Device::dump_usb.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-usb/Makefile b/devel/p5-usb/Makefile
index 739116a227fa..085052a259b8 100644
--- a/devel/p5-usb/Makefile
+++ b/devel/p5-usb/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= jwbacon@tds.net
COMMENT= Perl wrapper for libusb
BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
WRKSRC= ${WRKDIR}/Device-USB-0.21
PERL_CONFIGURE= yes
@@ -31,4 +30,10 @@ MAN3= Device::USB.3 \
Device::USB::FAQ.3 \
Device::dump_usb.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pcsc-lite/Makefile b/devel/pcsc-lite/Makefile
index a3f548df0cef..325002415630 100644
--- a/devel/pcsc-lite/Makefile
+++ b/devel/pcsc-lite/Makefile
@@ -38,8 +38,14 @@ MAN5= reader.conf.5
MAN8= pcscd.8 update-reader.conf.8
.if !defined(WITHOUT_USB)
+. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-CONFIGURE_ARGS+=--enable-libusb=${LOCALBASE} \
+USBBASE= ${LOCALBASE}
+. else
+USBBASE= /usr
+CONFIGURE_ENV+= LIBUSB_LIBS="-lusb"
+. endif
+CONFIGURE_ARGS+=--enable-libusb=${USBBASE} \
--disable-libhal
.else
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
diff --git a/devel/piklab/Makefile b/devel/piklab/Makefile
index 9cc48f92f066..ceb47d490fe6 100644
--- a/devel/piklab/Makefile
+++ b/devel/piklab/Makefile
@@ -15,8 +15,6 @@ MASTER_SITE_SUBDIR=piklab
MAINTAINER= bms@FreeBSD.org
COMMENT= KDE IDE for microcontroller development
-LIB_DEPENDS= usb:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -31,4 +29,10 @@ MAN1= piklab-hex.1 piklab-prog.1 piklab.1x
BROKEN= Does not compile on sparc64
.endif
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+. else
+CONFIGURE_ENV+= LIBUSB_LIBS="-lusb"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/py-usb/Makefile b/devel/py-usb/Makefile
index 6b0925f5eaba..bc867a8b425a 100644
--- a/devel/py-usb/Makefile
+++ b/devel/py-usb/Makefile
@@ -16,11 +16,16 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= R.Mahmatkhanov@SKYLINK.ru
COMMENT= Python wrapper around libusb
-BUILD_DEPENDS= ${LOCALBASE}/lib/libusb.so:${PORTSDIR}/devel/libusb
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_FILES= %%PYTHON_SITELIBDIR%%/usb.so
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= ${LOCALBASE}/lib/libusb.so:${PORTSDIR}/devel/libusb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/roboctl/Makefile b/devel/roboctl/Makefile
index cf65cc08653b..5cb3cfe947db 100644
--- a/devel/roboctl/Makefile
+++ b/devel/roboctl/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
MAINTAINER= jwbacon@tds.net
COMMENT= API for communications with Lego and Vex robot controllers
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
BUILD_DEPENDS= ${LOCALBASE}/lib/libgamepad.a:${PORTSDIR}/devel/libgamepad
OPTIONS= CUTECOM "Install cutecom for Vex debugging" On
@@ -24,10 +23,20 @@ MAN3= roboctl.3
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.endif
+
.if defined(WITH_CUTECOM)
RUN_DEPENDS+= cutecom:${PORTSDIR}/comms/cutecom
.endif
+post-patch:
+.if ${OSVERSION} >= 800069
+ @${REINPLACE_CMD} -E -e 's,/usr/local/include/usb.h,/usr/include/usb.h,g' \
+ ${WRKSRC}/Libs/C/Makefile.depend
+.endif
+
post-install:
(cd ${WRKSRC}/Commands/NXTRemote; ${MAKE})
${INSTALL_PROGRAM} ${WRKSRC}/Commands/NXTRemote/nxtremote ${PREFIX}/bin
diff --git a/devel/urjtag/Makefile b/devel/urjtag/Makefile
index 9ae946fa74a4..cff04993927c 100644
--- a/devel/urjtag/Makefile
+++ b/devel/urjtag/Makefile
@@ -39,7 +39,11 @@ CONFIGURE_ARGS+= --enable-jedec
.if !defined(WITHOUT_USB)
CONFIGURE_ARGS+= --with-libusb
+.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-usb
+. endif
.endif
.if !defined(WITHOUT_FTDI)
diff --git a/devel/urjtag/files/extra-patch-usb b/devel/urjtag/files/extra-patch-usb
new file mode 100644
index 000000000000..995df925a764
--- /dev/null
+++ b/devel/urjtag/files/extra-patch-usb
@@ -0,0 +1,14 @@
+--- configure.orig 2008-09-14 14:51:22.000000000 +0400
++++ configure 2009-03-07 20:52:56.000000000 +0300
+@@ -8604,6 +8604,10 @@
+ USBLIBS="-L$with_libusb/lib/gcc -lusb"
+ USBCLAGS="-I$with_libusb/include"
+ ;;
++ *-*-freebsd*)
++ USBLIBS="-lusb"
++ USBCLAGS=""
++ ;;
+ *)
+ USBLIBS="-Lwith_libusb -lusb"
+ USBCFLAGS="-I$with_libusb"
+ # check for lex/flex