aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-29 06:35:27 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-29 06:35:27 +0000
commitf84ed2e9420ef20786a8f9ebbd609252cd70eb3b (patch)
tree1939ef24d555ee35d0363a3a4dea2dbfcb86360e /devel
parent04121036a61b1e49ed2ee5dd4997f6664746d274 (diff)
downloadports-f84ed2e9420ef20786a8f9ebbd609252cd70eb3b.tar.gz
ports-f84ed2e9420ef20786a8f9ebbd609252cd70eb3b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/bison/Makefile8
-rw-r--r--devel/bison/pkg-plist26
-rw-r--r--devel/bison175/Makefile8
-rw-r--r--devel/bison175/pkg-plist26
4 files changed, 42 insertions, 26 deletions
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index 01d9bf25754a..ce587faafd7e 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -16,12 +16,20 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+.if !defined(WITHOUT_NLS)
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+PLIST_SUB= NLS=""
+.else
+PLIST_SUB= NLS="@comment "
+.endif
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS= --disable-nls
+.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
diff --git a/devel/bison/pkg-plist b/devel/bison/pkg-plist
index 40c58142784a..53c5d22a1325 100644
--- a/devel/bison/pkg-plist
+++ b/devel/bison/pkg-plist
@@ -9,18 +9,18 @@ share/bison/lalr1.cc
share/bison/m4sugar/m4sugar.m4
share/bison/m4sugar/version.m4
share/bison/yacc.c
-share/locale/de/LC_MESSAGES/bison.mo
-share/locale/es/LC_MESSAGES/bison.mo
-share/locale/et/LC_MESSAGES/bison.mo
-share/locale/fr/LC_MESSAGES/bison.mo
-share/locale/hr/LC_MESSAGES/bison.mo
-share/locale/id/LC_MESSAGES/bison.mo
-share/locale/it/LC_MESSAGES/bison.mo
-share/locale/ja/LC_MESSAGES/bison.mo
-share/locale/nl/LC_MESSAGES/bison.mo
-share/locale/pt_BR/LC_MESSAGES/bison.mo
-share/locale/ru/LC_MESSAGES/bison.mo
-share/locale/sv/LC_MESSAGES/bison.mo
-share/locale/tr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/de/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/es/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/et/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/id/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/it/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/bison.mo
@dirrm share/bison/m4sugar
@dirrm share/bison
diff --git a/devel/bison175/Makefile b/devel/bison175/Makefile
index 01d9bf25754a..ce587faafd7e 100644
--- a/devel/bison175/Makefile
+++ b/devel/bison175/Makefile
@@ -16,12 +16,20 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+.if !defined(WITHOUT_NLS)
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+PLIST_SUB= NLS=""
+.else
+PLIST_SUB= NLS="@comment "
+.endif
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS= --disable-nls
+.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
diff --git a/devel/bison175/pkg-plist b/devel/bison175/pkg-plist
index 40c58142784a..53c5d22a1325 100644
--- a/devel/bison175/pkg-plist
+++ b/devel/bison175/pkg-plist
@@ -9,18 +9,18 @@ share/bison/lalr1.cc
share/bison/m4sugar/m4sugar.m4
share/bison/m4sugar/version.m4
share/bison/yacc.c
-share/locale/de/LC_MESSAGES/bison.mo
-share/locale/es/LC_MESSAGES/bison.mo
-share/locale/et/LC_MESSAGES/bison.mo
-share/locale/fr/LC_MESSAGES/bison.mo
-share/locale/hr/LC_MESSAGES/bison.mo
-share/locale/id/LC_MESSAGES/bison.mo
-share/locale/it/LC_MESSAGES/bison.mo
-share/locale/ja/LC_MESSAGES/bison.mo
-share/locale/nl/LC_MESSAGES/bison.mo
-share/locale/pt_BR/LC_MESSAGES/bison.mo
-share/locale/ru/LC_MESSAGES/bison.mo
-share/locale/sv/LC_MESSAGES/bison.mo
-share/locale/tr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/de/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/es/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/et/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/id/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/it/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/bison.mo
@dirrm share/bison/m4sugar
@dirrm share/bison