aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2004-07-07 13:20:11 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2004-07-07 13:20:11 +0000
commit5614a2d8257afaeeb4fbb1d125c87c7ba339a948 (patch)
treee4aa483efd53fecb65c61ab5e610958d992c1a0b /devel
parent6fc31271beb408b200e396f7928d705b0ff4184e (diff)
downloadports-5614a2d8257afaeeb4fbb1d125c87c7ba339a948.tar.gz
ports-5614a2d8257afaeeb4fbb1d125c87c7ba339a948.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tree-Simple/Makefile22
-rw-r--r--devel/p5-Tree-Simple/distinfo2
-rw-r--r--devel/p5-Tree-Simple/pkg-descr6
-rw-r--r--devel/p5-Tree-Simple/pkg-plist4
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c12bd985bfd0..1e3c4c9bc845 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -966,6 +966,7 @@
SUBDIR += p5-TimeDate
SUBDIR += p5-TraceFuncs
SUBDIR += p5-Tree-DAG_Node
+ SUBDIR += p5-Tree-Simple
SUBDIR += p5-UNIVERSAL-exports
SUBDIR += p5-UNIVERSAL-moniker
SUBDIR += p5-Unix-Statgrab
diff --git a/devel/p5-Tree-Simple/Makefile b/devel/p5-Tree-Simple/Makefile
new file mode 100644
index 000000000000..d958307627ef
--- /dev/null
+++ b/devel/p5-Tree-Simple/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Tree::Simple
+# Date created: 7 July 2004
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tree-Simple
+PORTVERSION= 1.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tree
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A simple tree object
+
+PERL_CONFIGURE= yes
+
+MAN3= Tree::Simple.3 Tree::Simple::Visitor.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Tree-Simple/distinfo b/devel/p5-Tree-Simple/distinfo
new file mode 100644
index 000000000000..a78bfc5a7355
--- /dev/null
+++ b/devel/p5-Tree-Simple/distinfo
@@ -0,0 +1,2 @@
+MD5 (Tree-Simple-1.06.tar.gz) = 0d39b93b643e1aa7b6b7c57c40ebf41b
+SIZE (Tree-Simple-1.06.tar.gz) = 23019
diff --git a/devel/p5-Tree-Simple/pkg-descr b/devel/p5-Tree-Simple/pkg-descr
new file mode 100644
index 000000000000..b8f1f952d3d7
--- /dev/null
+++ b/devel/p5-Tree-Simple/pkg-descr
@@ -0,0 +1,6 @@
+This module in an fully object-oriented implementation of a simple n-
+ary tree. It is built upon the concept of parent-child relationships,
+so therefore every Tree::Simple object has both a parent and a set of
+children (who themselves may have children, and so on). Every
+Tree::Simple object also has siblings, as they are just the children of
+their immediate parent.
diff --git a/devel/p5-Tree-Simple/pkg-plist b/devel/p5-Tree-Simple/pkg-plist
new file mode 100644
index 000000000000..9f8214d9d2cc
--- /dev/null
+++ b/devel/p5-Tree-Simple/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Tree/Simple.pm
+%%SITE_PERL%%/Tree/Simple/Visitor.pm
+@dirrm %%SITE_PERL%%/Tree/Simple
+@unexec rmdir %D/%%SITE_PERL%%/Tree 2>/dev/null || true