aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-10-23 12:26:07 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2017-10-23 12:26:07 +0000
commit6a9f5934e11aa66e3159ca7c684b950848cd379c (patch)
tree3a1773e1f790e194973278f0bc58f931a340f45e /devel
parent76e24a0d056dc2f73cfb1c30d2185d6ce91d4dcf (diff)
downloadports-6a9f5934e11aa66e3159ca7c684b950848cd379c.tar.gz
ports-6a9f5934e11aa66e3159ca7c684b950848cd379c.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/bazel/Makefile18
-rw-r--r--devel/bazel/distinfo6
-rw-r--r--devel/bazel/files/extra-i386_src_BUILD21
-rw-r--r--devel/bazel/files/patch-scripts_bootstrap_bootstrap.sh9
4 files changed, 16 insertions, 38 deletions
diff --git a/devel/bazel/Makefile b/devel/bazel/Makefile
index 81b00d29433c..ce16d0c5b3da 100644
--- a/devel/bazel/Makefile
+++ b/devel/bazel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bazel
-PORTVERSION= 0.5.3
+PORTVERSION= 0.7.0
CATEGORIES= devel java
MASTER_SITES= https://storage.googleapis.com/bazel/${PORTVERSION}/rc${FINALRC}/
DISTNAME= bazel-${PORTVERSION}rc${FINALRC}-dist
@@ -21,9 +21,9 @@ BUILD_DEPENDS= bash:shells/bash \
# In bazel, a release is always code-wise identical to the final release candidate.
# Hence we can also download that one and so have a simple way to also test earlier release
# candidates.
-FINALRC= 4
+FINALRC= 2
-USES= shebangfix zip
+USES= shebangfix zip:infozip python
SHEBANG_REGEX= .*(sh|txt|_stub|stub_.*|bazel|get_workspace_status|protobuf_support|_so)
USE_JAVA= yes
JAVA_VENDOR= openjdk
@@ -55,7 +55,14 @@ post-patch:
@${REINPLACE_CMD} \
-e "s|\"/etc/bazel.bazelrc\"|\"${ETCDIR}/bazel.bazelrc\"|" \
${WRKSRC}/src/main/cpp/blaze_util_posix.cc
- @${ECHO_CMD} build --strategy=Javac=standalone >> ${WRKSRC}/scripts/packages/debian/bazel.bazelrc
+ @${ECHO_CMD} build --strategy=Javac=standalone >> ${WRKSRC}/scripts/packages/bazel.bazelrc
+ @${ECHO_CMD} build --python_path=${PYTHON_CMD} >> ${WRKSRC}/scripts/packages/bazel.bazelrc
+ @${REINPLACE_CMD} \
+ -e 's|\$$command|$$command --python_path=${PYTHON_CMD}|' \
+ ${WRKSRC}/scripts/bootstrap/bootstrap.sh
+ @${REINPLACE_CMD} \
+ -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
+ ${WRKSRC}/src/main/java/com/google/devtools/build/lib/bazel/rules/python/BazelPythonSemantics.java
post-patch-CLANG38-on:
@${REINPLACE_CMD} -e 's=/usr/lib/clang=${LOCALBASE}/llvm38/lib/clang=' \
@@ -71,12 +78,13 @@ do-build:
${SETENV} BAZEL_SH=${LOCALBASE}/bin/bash \
TMPDIR=${WRKDIR}/bazel_tmp \
EMBED_LABEL='${PORTVERSION}' \
+ PATH=${LOCALBASE}/bin:$$PATH \
SOURCE_DATE_EPOCH=$${SOURCE_DATE_EPOCH} \
${LOCALBASE}/bin/bash ./compile.sh)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/output/bazel ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/scripts/packages/debian/bazel.bazelrc ${STAGEDIR}${ETCDIR}/bazel.bazelrc.sample
+ ${INSTALL_DATA} ${WRKSRC}/scripts/packages/bazel.bazelrc ${STAGEDIR}${ETCDIR}/bazel.bazelrc.sample
.include <bsd.port.post.mk>
diff --git a/devel/bazel/distinfo b/devel/bazel/distinfo
index e6f7264b6da3..cfcc912a86e9 100644
--- a/devel/bazel/distinfo
+++ b/devel/bazel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501141783
-SHA256 (bazel-0.5.3rc4-dist.zip) = 41d70a98366256a20ddf0b0f2aab826913cd332d90c4f245b2c2e83a66f3d846
-SIZE (bazel-0.5.3rc4-dist.zip) = 100445883
+TIMESTAMP = 1507581916
+SHA256 (bazel-0.7.0rc2-dist.zip) = 5302847e0988ae7839d5efd7cbdff64caa8880af5d9860bc88a665aacc4aa380
+SIZE (bazel-0.7.0rc2-dist.zip) = 84668691
diff --git a/devel/bazel/files/extra-i386_src_BUILD b/devel/bazel/files/extra-i386_src_BUILD
index a49ae5e5838f..bdfd7c877986 100644
--- a/devel/bazel/files/extra-i386_src_BUILD
+++ b/devel/bazel/files/extra-i386_src_BUILD
@@ -9,24 +9,3 @@
],
}) + select({
"//tools/jdk:jdk7": [],
---- src/main/cpp/blaze_util_posix.cc.orig
-+++ src/main/cpp/blaze_util_posix.cc
-@@ -29,6 +29,7 @@
- #include <sys/resource.h>
- #include <sys/wait.h>
- #include <unistd.h>
-+#include <time.h>
-
- #include <cassert>
- #include <cinttypes>
-@@ -648,8 +649,8 @@
- }
-
- void TrySleep(unsigned int milliseconds) {
-- unsigned int seconds_part = milliseconds / 1000;
-- unsigned int nanoseconds_part = (milliseconds % 1000) * 1000 * 1000;
-+ time_t seconds_part = (time_t) (milliseconds / 1000);
-+ long nanoseconds_part = ((long)(milliseconds % 1000)) * 1000 * 1000;
- struct timespec sleeptime = {seconds_part, nanoseconds_part};
- nanosleep(&sleeptime, NULL);
- }
diff --git a/devel/bazel/files/patch-scripts_bootstrap_bootstrap.sh b/devel/bazel/files/patch-scripts_bootstrap_bootstrap.sh
index d42070dc48d8..0382fdddaa0e 100644
--- a/devel/bazel/files/patch-scripts_bootstrap_bootstrap.sh
+++ b/devel/bazel/files/patch-scripts_bootstrap_bootstrap.sh
@@ -9,12 +9,3 @@
--compilation_mode=opt \
${EXTRA_BAZEL_ARGS:-}"
fi
-@@ -96,7 +96,7 @@ function bootstrap_test() {
- local BAZEL_BIN=$1
- local BAZEL_SUM=$2
- local BAZEL_TARGET=${3:-src:bazel}
-- local STRATEGY="--strategy=Javac=worker --worker_quit_after_build"
-+ local STRATEGY="--strategy=Javac=standalone"
- if [ "${JAVA_VERSION}" = "1.7" ]; then
- STRATEGY=
- fi