aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-04-10 01:21:10 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-04-10 01:21:10 +0000
commit812d84ac17d995053790361ef536b3360e5acdc2 (patch)
tree3a83824b916f99de29a1d26154caa0ff00eb5295 /devel
parent87501d76ac7ee389c36ff1f3a698c2e51bd8cee5 (diff)
downloadports-812d84ac17d995053790361ef536b3360e5acdc2.tar.gz
ports-812d84ac17d995053790361ef536b3360e5acdc2.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p4api/Makefile51
-rw-r--r--devel/p4api/distinfo2
-rw-r--r--devel/p4api/pkg-descr5
-rw-r--r--devel/p4api/pkg-plist37
5 files changed, 96 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0f53037bf98c..6fa3828f228e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -425,6 +425,7 @@
SUBDIR += ossp-val
SUBDIR += ossp-var
SUBDIR += p4.el
+ SUBDIR += p4api
SUBDIR += p4db
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Diff
diff --git a/devel/p4api/Makefile b/devel/p4api/Makefile
new file mode 100644
index 000000000000..5bf98b990605
--- /dev/null
+++ b/devel/p4api/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: p4api
+# Date created: 27 Mar 2003
+# Whom: kuriyama@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= p4api
+PORTVERSION= ${VERSION}
+PORTREVISION= ${REVISION}
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/bin.${PLATFORM}/:tar \
+ http://www.perforce.com/perforce/doc.${DOCVER}/user/:txt
+EXTRACT_SUFX=
+DISTFILES= ${TAR_FILES}:tar p4api.txt:txt
+DIST_SUBDIR= perforce/${VERSION}/${ARCH}
+EXTRACT_ONLY= ${TAR_FILES}
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perforce API (static libraries and header files)
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == i386
+VERSION= 02.2
+REVISION= 0
+PLATFORM= freebsd4
+TAR_FILES= p4api.tar
+.else
+IGNORE= "Unsupported platform, sorry."
+.endif
+
+DOCVER= ${VERSION:S/.//}
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/perforce
+ ${MKDIR} ${PREFIX}/lib/perforce
+ cd ${WRKSRC}; \
+ for i in *.h; \
+ do ${INSTALL_DATA} $${i} ${PREFIX}/include/perforce; \
+ done
+ cd ${WRKSRC}; \
+ for i in lib*.a; \
+ do ${INSTALL_DATA} $${i} ${PREFIX}/lib/perforce; \
+ done
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/p4api.txt ${PREFIX}/include/perforce
+
+.include <bsd.port.post.mk>
diff --git a/devel/p4api/distinfo b/devel/p4api/distinfo
new file mode 100644
index 000000000000..e5df9fad2dd6
--- /dev/null
+++ b/devel/p4api/distinfo
@@ -0,0 +1,2 @@
+MD5 (perforce/02.2/i386/p4api.tar) = 4cb713172cea616eee58b4147a2cc76a
+MD5 (perforce/02.2/i386/p4api.txt) = 71c7879b2e412d80b7ed64bedd6c769e
diff --git a/devel/p4api/pkg-descr b/devel/p4api/pkg-descr
new file mode 100644
index 000000000000..d21f514568ad
--- /dev/null
+++ b/devel/p4api/pkg-descr
@@ -0,0 +1,5 @@
+The Perforce Client API is a simple beast which packages up the
+command invocation, sends it to the server, and then acts on
+instructions from the server to carry out the actual command.
+
+WWW: http://www.perforce.com/perforce/loadsupp.html
diff --git a/devel/p4api/pkg-plist b/devel/p4api/pkg-plist
new file mode 100644
index 000000000000..7469e4930a27
--- /dev/null
+++ b/devel/p4api/pkg-plist
@@ -0,0 +1,37 @@
+include/perforce/clientapi.h
+include/perforce/clientmerge.h
+include/perforce/clientuser.h
+include/perforce/datetime.h
+include/perforce/debug.h
+include/perforce/diff.h
+include/perforce/echoctl.h
+include/perforce/enviro.h
+include/perforce/error.h
+include/perforce/errorlog.h
+include/perforce/errornum.h
+include/perforce/filesys.h
+include/perforce/handler.h
+include/perforce/hostenv.h
+include/perforce/ident.h
+include/perforce/keepalive.h
+include/perforce/msgclient.h
+include/perforce/netconnect.h
+include/perforce/ntservice.h
+include/perforce/options.h
+include/perforce/p4api.txt
+include/perforce/p4tags.h
+include/perforce/pathsys.h
+include/perforce/signaler.h
+include/perforce/spec.h
+include/perforce/stdhdrs.h
+include/perforce/strbuf.h
+include/perforce/strdict.h
+include/perforce/strops.h
+include/perforce/strtable.h
+include/perforce/threading.h
+include/perforce/vararray.h
+lib/perforce/libclient.a
+lib/perforce/librpc.a
+lib/perforce/libsupp.a
+@dirrm include/perforce
+@dirrm lib/perforce