aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-04-30 04:53:09 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-04-30 04:53:09 +0000
commita8f001fae56fda5ae4baf6d046364b763bd96f62 (patch)
tree0cdd7044b9be612a8c5dc9a1983352aad2c0658e /devel
parent27f86a62122f4eeb712939bca4d357f715cadffa (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-memoize/Makefile41
-rw-r--r--devel/ruby-memoize/distinfo2
-rw-r--r--devel/ruby-memoize/pkg-descr3
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b99e11a819af..5bb5bbc9b14f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3144,6 +3144,7 @@
SUBDIR += ruby-libglade2
SUBDIR += ruby-locale
SUBDIR += ruby-locale2
+ SUBDIR += ruby-memoize
SUBDIR += ruby-metaruby
SUBDIR += ruby-mmap
SUBDIR += ruby-multi
diff --git a/devel/ruby-memoize/Makefile b/devel/ruby-memoize/Makefile
new file mode 100644
index 000000000000..e1b12925536e
--- /dev/null
+++ b/devel/ruby-memoize/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ruby-memoize
+# Date created: 2011-04-23
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= memoize
+PORTVERSION= 1.3.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/61790/ \
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/memoize|}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ${RUBY_PKGNAMEPREFIX:S|${RUBY_SUFFIX}-||}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= A method that speeds methods up at the cost of memory
+
+USE_RUBY= yes
+FETCH_ARGS= -Fpr
+
+USE_RUBY= yes
+USE_RAKE= yes
+NO_BUILD= yes
+
+PLIST_FILES= %%RUBY_SITELIBDIR%%/memoize.rb
+
+PORTEXAMPLES= example_fibonacci.rb \
+ example_memoize.rb
+EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/memoize.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${f} ${RUBY_MODEXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-memoize/distinfo b/devel/ruby-memoize/distinfo
new file mode 100644
index 000000000000..25dd8f609418
--- /dev/null
+++ b/devel/ruby-memoize/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ruby/memoize-1.3.1.tar.gz) = 4bb6e2e9e2a8d7d99a08f82b961b73f6a0431fde5606433b32171e62169d2376
+SIZE (ruby/memoize-1.3.1.tar.gz) = 4492
diff --git a/devel/ruby-memoize/pkg-descr b/devel/ruby-memoize/pkg-descr
new file mode 100644
index 000000000000..4a09ba750f26
--- /dev/null
+++ b/devel/ruby-memoize/pkg-descr
@@ -0,0 +1,3 @@
+A method that speeds methods up at the cost of memory (or disk space).
+
+WWW: http://www.rubyforge.org/projects/shards