aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-04 10:55:23 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2013-03-04 10:55:23 +0000
commit5aa43c1aba1579d88f80fc6f75f5b1fcb3df4b66 (patch)
tree8252139e7b614c53058f1ef8f9b3f7ef729f31c0 /devel
parent243c0ad4d0252af27fdabdff1c8e04581608e044 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/buildbot/Makefile10
-rw-r--r--devel/bzr-git/Makefile8
-rw-r--r--devel/eric4/Makefile2
-rw-r--r--devel/subversion/Makefile2
4 files changed, 7 insertions, 15 deletions
diff --git a/devel/buildbot/Makefile b/devel/buildbot/Makefile
index 40e24b3890a1..017880ea09ad 100644
--- a/devel/buildbot/Makefile
+++ b/devel/buildbot/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: buildbot
-# Date created: 27 Sep 2005
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= buildbot
PORTVERSION= 0.8.6p1
@@ -14,11 +10,11 @@ MAINTAINER= tj@FreeBSD.org
COMMENT= Automated system from compile/test cycle to validate code changes
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.1:${PORTSDIR}/devel/py-Jinja2 \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.7:${PORTSDIR}/databases/py-sqlalchemy \
${PYTHON_PKGNAMEPREFIX}migrate>=0.7:${PORTSDIR}/databases/py-migrate
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_TWISTED_RUN= conch mail web words
diff --git a/devel/bzr-git/Makefile b/devel/bzr-git/Makefile
index e8c379e3ad0a..8f27918e7b10 100644
--- a/devel/bzr-git/Makefile
+++ b/devel/bzr-git/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: bzr-git
-# Date created: 9 August 2010
-# Whom: Carlo Strub
-#
+# Created by: Carlo Strub
# $FreeBSD$
-#
PORTNAME= bzr-git
PORTVERSION= 0.6.8
@@ -20,7 +16,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= bzr:${PORTSDIR}/devel/bzr
RUN_DEPENDS= bzr:${PORTSDIR}/devel/bzr \
py*-dulwich>=0.8.0:${PORTSDIR}/devel/dulwich \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_PYTHON= 2.5+
diff --git a/devel/eric4/Makefile b/devel/eric4/Makefile
index 607aa3e775b3..ed1e2765b86e 100644
--- a/devel/eric4/Makefile
+++ b/devel/eric4/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
${PYTHON_SITELIBDIR}/PyQt4/QtSvg.so:${PORTSDIR}/graphics/py-qt4-svg \
${PYTHON_SITELIBDIR}/PyQt4/QtWebKit.so:${PORTSDIR}/www/py-qt4-webkit \
${PYTHON_SITELIBDIR}/PyQt4/QtHelp.so:${PORTSDIR}/devel/py-qt4-help \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
USE_GNOME= desktopfileutils
INSTALL_CMD= install.py -c -f eric4config.freebsd
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index b3cf72caa6cc..d6ae6d38e95f 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -105,7 +105,7 @@ PLIST_SUB+= BOOK="@comment "
# testsuite will fail until PR156076 is committed
.if ${PORT_OPTIONS:MTEST}
-TEST_DEPENDS= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
.endif
#.if ${PORT_OPTIONS:MASVN}