aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-11 09:44:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-11 09:44:04 +0000
commit8c85eb5197c4318f566bf8663342393248f64b15 (patch)
treecbb73e7e81137019a2ff965ec0f0ca6305de6904 /devel
parenta89cb8057af6652f6561031a47c3bd1682069050 (diff)
downloadports-8c85eb5197c4318f566bf8663342393248f64b15.tar.gz
ports-8c85eb5197c4318f566bf8663342393248f64b15.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/dparser/Makefile30
-rw-r--r--devel/dparser/distinfo1
-rw-r--r--devel/dparser/pkg-descr11
-rw-r--r--devel/dparser/pkg-plist9
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a6e3e50c82ff..f301dcbcf1b5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -178,6 +178,7 @@
SUBDIR += doctorj
SUBDIR += dotconf
SUBDIR += doxygen
+ SUBDIR += dparser
SUBDIR += e4graph
SUBDIR += ebnf2yacc
SUBDIR += eboxy
diff --git a/devel/dparser/Makefile b/devel/dparser/Makefile
new file mode 100644
index 000000000000..f1da87db6c45
--- /dev/null
+++ b/devel/dparser/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: dparser
+# Date created: Nov 11, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= dparser
+PORTVERSION= 1.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= d-${PORTVERSION}-src
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A simple but powerful tool for parsing
+
+WRKSRC= ${WRKDIR}/d
+USE_GMAKE= yes
+
+MAN1= make_dparser.1
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/dparser/distinfo b/devel/dparser/distinfo
new file mode 100644
index 000000000000..81ece91eefeb
--- /dev/null
+++ b/devel/dparser/distinfo
@@ -0,0 +1 @@
+MD5 (d-1.7-src.tar.gz) = d368a476d4fc18221a903cef91089b16
diff --git a/devel/dparser/pkg-descr b/devel/dparser/pkg-descr
new file mode 100644
index 000000000000..82af534cfce6
--- /dev/null
+++ b/devel/dparser/pkg-descr
@@ -0,0 +1,11 @@
+DParser is a simple but powerful tool for parsing. You can specify the form of
+the text to be parsed using a combination of regular expressions and grammar
+productions. Because of the parsing technique (technically a scannerless GLR
+parser based on the Tomita algorithm) there are no restrictions. The grammar
+can be ambiguous, right or left recursive, have any number of null productions,
+and because there is no seperate tokenizer, can include whitespace in terminals
+and have terminals which are prefixes of other terminals. DParser handles not
+just well formed computer languages and data files, but just about any wacky
+situation that occurs in the real world.
+
+WWW: http://dparser.sourceforge.net/
diff --git a/devel/dparser/pkg-plist b/devel/dparser/pkg-plist
new file mode 100644
index 000000000000..db3c67e82af3
--- /dev/null
+++ b/devel/dparser/pkg-plist
@@ -0,0 +1,9 @@
+bin/make_dparser
+include/dparse.h
+include/dparse_tables.h
+include/dsymtab.h
+lib/libdparse.a
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%