aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-08-01 05:46:53 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-08-01 05:46:53 +0000
commit928f8cb0651c42de0e449ea6206d2bbe15d71a0c (patch)
tree7b0a20b7352dec609a2c00ca00a3e93a253a7062 /devel
parent284ce4efae79e34e4602876c96d0047044bca932 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/eboxy/Makefile45
-rw-r--r--devel/eboxy/distinfo2
-rw-r--r--devel/eboxy/files/patch-eboxy::Makefile.in11
-rw-r--r--devel/eboxy/files/patch-eboxy::basewidgets::memberfunctionproperty.h10
-rw-r--r--devel/eboxy/files/patch-eboxy::basewidgets::membermethodhandler.h11
-rw-r--r--devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp10
-rw-r--r--devel/eboxy/files/patch-eboxy::basewidgets::variant.cpp11
-rw-r--r--devel/eboxy/files/patch-eboxy::conf.cpp10
-rw-r--r--devel/eboxy/files/patch-eboxy::interfacemanager.cpp19
-rw-r--r--devel/eboxy/files/patch-eboxy::processobject.cpp10
-rw-r--r--devel/eboxy/files/patch-eboxy::script_bison.ypp10
-rw-r--r--devel/eboxy/files/patch-pluginmanager.cpp11
-rw-r--r--devel/eboxy/pkg-descr6
-rw-r--r--devel/eboxy/pkg-plist25
15 files changed, 0 insertions, 192 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e06b2c8feabb..e0d223120acd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -330,7 +330,6 @@
SUBDIR += e_dbus
SUBDIR += easygit
SUBDIR += ebnf2yacc
- SUBDIR += eboxy
SUBDIR += ecb
SUBDIR += eclipse-eclemma
SUBDIR += ecore
diff --git a/devel/eboxy/Makefile b/devel/eboxy/Makefile
deleted file mode 100644
index 7530071070e3..000000000000
--- a/devel/eboxy/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: eboxy
-# Date created: Sep 14, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= eboxy
-PORTVERSION= 0.4.1
-PORTREVISION= 9
-CATEGORIES= devel
-MASTER_SITES= SF
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Create simple GUI interfaces for entertainment PC
-
-USE_BISON= build
-USE_BZIP2= yes
-USE_SDL= sdl gui mixer
-USE_GNOME= gnometarget libxml2 lthack
-USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-lirc
-
-MAN1= eboxy.1
-
-CPPFLAGS= `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include \
- -DHAVE_DECL_GETOPT -fPIC
-LDFLAGS= `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64"
-BROKEN= Configure fails on ia64
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-O2 $$CFLAGS|$$CFLAGS|g ; \
- s|-O2 $$CXXFLAGS|$$CXXFLAGS|g' ${WRKSRC}/configure
-
-pre-build:
- @cd ${WRKSRC}/eboxy && ${SH} ./makeparser.sh
-
-.include <bsd.port.post.mk>
diff --git a/devel/eboxy/distinfo b/devel/eboxy/distinfo
deleted file mode 100644
index 4acd383046d5..000000000000
--- a/devel/eboxy/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (eboxy-0.4.1.tar.bz2) = 21bea92659a4afda74fb02238f9f7d70653616fbe8cb03950d1c8fb7d7d53954
-SIZE (eboxy-0.4.1.tar.bz2) = 815967
diff --git a/devel/eboxy/files/patch-eboxy::Makefile.in b/devel/eboxy/files/patch-eboxy::Makefile.in
deleted file mode 100644
index 6a0a34bb2a09..000000000000
--- a/devel/eboxy/files/patch-eboxy::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- eboxy/Makefile.in.orig Thu May 20 16:46:56 2004
-+++ eboxy/Makefile.in Thu May 20 21:24:26 2004
-@@ -239,7 +239,7 @@
- INCLUDES = $(all_includes)
-
- # the library search path.
--eboxy_LDFLAGS = $(all_libraries) -ldl $(XML_LIBS) $(LIRC_LIBS)
-+eboxy_LDFLAGS = $(all_libraries) $(XML_LIBS) $(LIRC_LIBS)
-
- eboxy_CXXFLAGS = $(XML_CFLAGS) $(LIRC_INCLUDE)
-
diff --git a/devel/eboxy/files/patch-eboxy::basewidgets::memberfunctionproperty.h b/devel/eboxy/files/patch-eboxy::basewidgets::memberfunctionproperty.h
deleted file mode 100644
index f6cb6ca614a5..000000000000
--- a/devel/eboxy/files/patch-eboxy::basewidgets::memberfunctionproperty.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- eboxy/basewidgets/memberfunctionproperty.h.orig Sun Aug 15 23:02:26 2004
-+++ eboxy/basewidgets/memberfunctionproperty.h Sun Aug 15 23:02:36 2004
-@@ -19,6 +19,7 @@
- #ifndef INCLUDED__MEMBERFUNCTIONPROPERTY_H
- #define INCLUDED__MEMBERFUNCTIONPROPERTY_H
-
-+using namespace std;
- #include "customproperty.h"
- #include "variant.h"
-
diff --git a/devel/eboxy/files/patch-eboxy::basewidgets::membermethodhandler.h b/devel/eboxy/files/patch-eboxy::basewidgets::membermethodhandler.h
deleted file mode 100644
index 4f1d39f11d51..000000000000
--- a/devel/eboxy/files/patch-eboxy::basewidgets::membermethodhandler.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- eboxy/basewidgets/membermethodhandler.h.orig Sun Aug 15 20:21:31 2004
-+++ eboxy/basewidgets/membermethodhandler.h Sun Aug 15 23:00:54 2004
-@@ -19,6 +19,8 @@
- #ifndef INCLUDED__MEMBERMETHODHANDLER_H
- #define INCLUDED__MEMBERMETHODHANDLER_H
-
-+using namespace std;
-+
- #include "methodhandler.h"
- #include "variant.h"
-
diff --git a/devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp b/devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp
deleted file mode 100644
index 8802cdfc0ff6..000000000000
--- a/devel/eboxy/files/patch-eboxy::basewidgets::stringlist.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- eboxy/basewidgets/stringlist.cpp.orig Thu May 20 16:46:55 2004
-+++ eboxy/basewidgets/stringlist.cpp Thu May 20 20:56:53 2004
-@@ -18,6 +18,7 @@
- #include <cstring>
- #include <iostream>
- #include <vector>
-+#include <string>
-
- #include "stringlist.h"
-
diff --git a/devel/eboxy/files/patch-eboxy::basewidgets::variant.cpp b/devel/eboxy/files/patch-eboxy::basewidgets::variant.cpp
deleted file mode 100644
index 04e770c6d853..000000000000
--- a/devel/eboxy/files/patch-eboxy::basewidgets::variant.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- eboxy/basewidgets/variant.cpp.orig 2007-08-03 16:10:33.000000000 +0200
-+++ eboxy/basewidgets/variant.cpp 2007-08-03 16:10:52.000000000 +0200
-@@ -90,7 +90,7 @@
-
- Variant Variant::operator= (void *value) {
- SetType(VARTYPE_OBJREF);
-- intvalue = (int)value;
-+ intvalue = (intptr_t)value;
- return *this;
- }
-
diff --git a/devel/eboxy/files/patch-eboxy::conf.cpp b/devel/eboxy/files/patch-eboxy::conf.cpp
deleted file mode 100644
index 9fe05ab1ed08..000000000000
--- a/devel/eboxy/files/patch-eboxy::conf.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- eboxy/conf.cpp.orig Thu May 20 16:46:55 2004
-+++ eboxy/conf.cpp Thu May 20 21:23:18 2004
-@@ -19,6 +19,7 @@
- #include "config.h"
- #endif
-
-+#include <cstdio>
- #include <vector>
- #include <iostream>
- #include <fstream>
diff --git a/devel/eboxy/files/patch-eboxy::interfacemanager.cpp b/devel/eboxy/files/patch-eboxy::interfacemanager.cpp
deleted file mode 100644
index b661e3d53d63..000000000000
--- a/devel/eboxy/files/patch-eboxy::interfacemanager.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- eboxy/interfacemanager.cpp.orig Thu May 20 16:46:55 2004
-+++ eboxy/interfacemanager.cpp Thu May 20 21:22:10 2004
-@@ -16,6 +16,7 @@
- ***************************************************************************/
-
- #include <iostream>
-+#include <cstdio>
-
- #include "dlfcn.h"
- #include "main.h"
-@@ -48,7 +49,7 @@
- libhandle = dlopen(libfile, RTLD_LAZY);
- if(libhandle == 0) {
- // Load failed
-- char *errorstr = dlerror();
-+ const char *errorstr = dlerror();
- cerr << "InterfaceManager: Couldn't load interface plugin " << libfile << endl;
- cerr << errorstr << endl;
- return EBERR_DLOPEN_FAILED; // Failed to load library
diff --git a/devel/eboxy/files/patch-eboxy::processobject.cpp b/devel/eboxy/files/patch-eboxy::processobject.cpp
deleted file mode 100644
index e7afb4d2a93d..000000000000
--- a/devel/eboxy/files/patch-eboxy::processobject.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- eboxy/processobject.cpp.orig Thu May 20 16:46:55 2004
-+++ eboxy/processobject.cpp Thu May 20 21:14:22 2004
-@@ -16,6 +16,7 @@
- ***************************************************************************/
-
- #include <iostream>
-+#include <string>
- #include <cstring>
- #include <cstdio>
- #include <cstdlib>
diff --git a/devel/eboxy/files/patch-eboxy::script_bison.ypp b/devel/eboxy/files/patch-eboxy::script_bison.ypp
deleted file mode 100644
index 642081169f0c..000000000000
--- a/devel/eboxy/files/patch-eboxy::script_bison.ypp
+++ /dev/null
@@ -1,10 +0,0 @@
---- eboxy/script_bison.ypp.orig Thu May 20 16:46:55 2004
-+++ eboxy/script_bison.ypp Thu May 20 21:20:13 2004
-@@ -24,6 +24,7 @@
- #include <cstring>
- #include <cmath>
- #include <string>
-+#include <cstdio>
- #include <cstdlib>
- #include <iostream>
- #include <map>
diff --git a/devel/eboxy/files/patch-pluginmanager.cpp b/devel/eboxy/files/patch-pluginmanager.cpp
deleted file mode 100644
index 97c8d8b8eb9c..000000000000
--- a/devel/eboxy/files/patch-pluginmanager.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- eboxy/pluginmanager.cpp.orig Sat Sep 28 20:41:36 2002
-+++ eboxy/pluginmanager.cpp Tue Oct 8 04:19:13 2002
-@@ -79,7 +79,7 @@
- }
- else {
- // Load failed
-- char *errorstr = dlerror();
-+ const char *errorstr = dlerror();
- cerr << "Couldn't load plugin " << libfile << endl;
- cerr << errorstr << endl;
- delete plugin;
diff --git a/devel/eboxy/pkg-descr b/devel/eboxy/pkg-descr
deleted file mode 100644
index c1532c5182a0..000000000000
--- a/devel/eboxy/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-eboxy is an application for building user interfaces for set-top boxes,
-suitable for use on a TV. It reads an XML file describing a simple GUI
-consisting of pages, images, labels and buttons, and creates the GUI on the
-screen.
-
-WWW: http://eboxy.sourceforge.net/
diff --git a/devel/eboxy/pkg-plist b/devel/eboxy/pkg-plist
deleted file mode 100644
index 8c5ff322e03e..000000000000
--- a/devel/eboxy/pkg-plist
+++ /dev/null
@@ -1,25 +0,0 @@
-bin/eboxy
-include/eboxy/eboxyplugin.h
-include/eboxy/pluginconstants.h
-include/eboxy/plugintypes.h
-lib/eboxy/libbasewidgets.a
-lib/eboxy/libbasewidgets.la
-lib/eboxy/libbasewidgets.so
-lib/eboxy/libbasewidgets.so.0
-lib/eboxy/plugins/generic/filebrowser.a
-lib/eboxy/plugins/generic/filebrowser.la
-lib/eboxy/plugins/generic/filebrowser.so
-lib/eboxy/plugins/generic/simplemusic.a
-lib/eboxy/plugins/generic/simplemusic.la
-lib/eboxy/plugins/generic/simplemusic.so
-lib/eboxy/plugins/interface/libsdl_gui.a
-lib/eboxy/plugins/interface/libsdl_gui.la
-lib/eboxy/plugins/interface/libsdl_gui.so
-lib/libeboxyplugin.a
-%%DATADIR%%/eboxy.dtd
-@dirrm %%DATADIR%%
-@dirrm lib/eboxy/plugins/interface
-@dirrm lib/eboxy/plugins/generic
-@dirrm lib/eboxy/plugins
-@dirrm lib/eboxy
-@dirrm include/eboxy