aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-12-21 11:11:43 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-12-21 11:11:43 +0000
commitb8626fb86cd070446548e09a2e486587eff18bf3 (patch)
tree066c63a401aa131aa5f965d55ac922fb336f231f /devel
parent70978ffbabb1db78f97fdb8ae902139d67aa7692 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/omniORB/Makefile7
-rw-r--r--devel/omniORB/distinfo6
-rw-r--r--devel/omniORB/files/patch-configure11
-rw-r--r--devel/omniORB/pkg-descr40
-rw-r--r--devel/omniORB/pkg-plist78
5 files changed, 82 insertions, 60 deletions
diff --git a/devel/omniORB/Makefile b/devel/omniORB/Makefile
index 171712e86e4f..0e9c33ce666d 100644
--- a/devel/omniORB/Makefile
+++ b/devel/omniORB/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= omniORB
-PORTVERSION= 4.0.7
-PORTREVISION= 1
+PORTVERSION= 4.1.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:L}
@@ -21,7 +20,7 @@ GNU_CONFIGURE= yes
USE_PYTHON= yes
USE_OPENSSL= yes
USE_GNOME= pkgconfig
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_FILTER_SHLIBS= yes
MAKEFILE= GNUmakefile
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
@@ -59,7 +58,7 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} COPYING README.FIRST.txt README.unix \
- ReleaseNotes_${PORTVERSION}.txt ${DOCSDIR}
+ ReleaseNotes.txt ${DOCSDIR}
@${TAR} cCf ${WRKSRC}/doc - . | ${TAR} xUCf ${DOCSDIR} -
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/sample.cfg ${EXAMPLESDIR}/omniORB.cfg
diff --git a/devel/omniORB/distinfo b/devel/omniORB/distinfo
index 3f3967e7fd83..6ddf3707c336 100644
--- a/devel/omniORB/distinfo
+++ b/devel/omniORB/distinfo
@@ -1,3 +1,3 @@
-MD5 (omniORB-4.0.7.tar.gz) = 9d478031be34232e988f3d5874396499
-SHA256 (omniORB-4.0.7.tar.gz) = e4c0875794a74ac627b7b74b6098e75c8413bd156856dc434a49c4c112a68af2
-SIZE (omniORB-4.0.7.tar.gz) = 2784040
+MD5 (omniORB-4.1.0.tar.gz) = b52dcb1886ffa2a61e6ed56e462edb76
+SHA256 (omniORB-4.1.0.tar.gz) = 8fd472684cd256067ef76d78a12169f3735ffe4413f70f439099c16a21a4eb82
+SIZE (omniORB-4.1.0.tar.gz) = 3069048
diff --git a/devel/omniORB/files/patch-configure b/devel/omniORB/files/patch-configure
deleted file mode 100644
index 405053be4d27..000000000000
--- a/devel/omniORB/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Thu Apr 14 19:05:43 2005
-+++ configure Thu Jun 9 10:28:02 2005
-@@ -11872,6 +11872,8 @@
- *-*-freebsd3*) plat_name="FreeBSD"; plat_def="__freebsd__"; os_v="3";;
- *-*-freebsd4*) plat_name="FreeBSD"; plat_def="__freebsd__"; os_v="4";;
- *-*-freebsd5*) plat_name="FreeBSD"; plat_def="__freebsd__"; os_v="5";;
-+ *-*-freebsd6*) plat_name="FreeBSD"; plat_def="__freebsd__"; os_v="6";;
-+ *-*-freebsd7*) plat_name="FreeBSD"; plat_def="__freebsd__"; os_v="7";;
- *-*-netbsd*) plat_name="NetBSD"; plat_def="__netbsd__"; os_v="1";;
- *-*-openbsd*) plat_name="OpenBSD"; plat_def="__openbsd__"; os_v="3";;
- *-*-sco*) plat_name="OSR5"; plat_def="__osr5__"; os_v="5";;
diff --git a/devel/omniORB/pkg-descr b/devel/omniORB/pkg-descr
index 9ed8caea353f..c36fbe2a6ec5 100644
--- a/devel/omniORB/pkg-descr
+++ b/devel/omniORB/pkg-descr
@@ -1,24 +1,28 @@
omniORB is a GPL'd Object Request Broker (ORB) which implements
specification 2.6 of the Common Object Request Broker Architecture (CORBA).
-* Technical Highlights
-- C++ language bindings are supported. The mapping conforms to the latest
- revision of the CORBA specification.
-- Support for the Portable Object Adapter (POA)
-- Support for the Interoperable Naming Service (INS)
-- The Internet Inter-ORB Protocol (IIOP 1.2) is used as the native protocol.
-- The omniORB runtime is fully multithreaded.
-- TypeCode and type Any are supported.
-- DynAny is supported.
-- The Dynamic Invocation and Dynamic Skeleton interfaces are supported.
-- A COS Naming Service, omniNames, is provided.
-
-* Work in progress
+Features:
+- C++ and Python language bindings.
+- Support for GIOP and IIOP 1.0, 1.1 and 1.2.
+- Fully multithreaded runtime.
+- TypeCode and type Any.
+- CORBA 2.6 DynAny interfaces.
+- Dynamic Invocation and Dynamic Skeleton interfaces.
+- Complete Naming Service, omniNames.
+- Support for wchar, wstring and code set negotiation.
+- Full long long, long double, fixed point support.
+- PortableServer::Current.
+- Unix domain socket transport.
+- Bidirectional GIOP.
+- Interoperable Secure Socket Layer transport.
+- Flexible thread management.
+- Interceptors.
+- Fully interoperable with other CORBA ORBs.
+- A number of contributed CORBA service implementations.
- Objects by value.
-- Portable Interceptors.
-
-* Missing features
-- omniORB does not has its own Interface Repository. However, the omniifr
- project aims to create one.
+- Abstract interfaces.
+- Local interface.
+- C++ mapping version 1.1.
+- IPv6 support.
WWW: http://omniorb.sourceforge.net/
diff --git a/devel/omniORB/pkg-plist b/devel/omniORB/pkg-plist
index e068ba0c2e1e..d32f61ba9f31 100644
--- a/devel/omniORB/pkg-plist
+++ b/devel/omniORB/pkg-plist
@@ -20,6 +20,7 @@ include/COS/CosTime.hh
include/COS/TimeBase.hh
include/omniORB4/BiDirPolicy.h
include/omniORB4/CORBA.h
+include/omniORB4/CORBA_AbstractBase.h
include/omniORB4/CORBA_Any.h
include/omniORB4/CORBA_Any_vartypes.h
include/omniORB4/CORBA_BOA.h
@@ -30,6 +31,8 @@ include/omniORB4/CORBA_Environment.h
include/omniORB4/CORBA_Exception.h
include/omniORB4/CORBA_ExceptionList.h
include/omniORB4/CORBA_Fixed.h
+include/omniORB4/CORBA_LocalObject.h
+include/omniORB4/CORBA_LocalObject_vartypes.h
include/omniORB4/CORBA_NamedValue.h
include/omniORB4/CORBA_ORB.h
include/omniORB4/CORBA_Object.h
@@ -42,6 +45,8 @@ include/omniORB4/CORBA_String.h
include/omniORB4/CORBA_TypeCode.h
include/omniORB4/CORBA_TypeCode_member.h
include/omniORB4/CORBA_UnknownUserException.h
+include/omniORB4/CORBA_ValueBase.h
+include/omniORB4/CORBA_ValueBase_vartypes.h
include/omniORB4/CORBA_basetypes.h
include/omniORB4/CORBA_primitive_types.h
include/omniORB4/CORBA_static_fns.h
@@ -56,8 +61,12 @@ include/omniORB4/IOP_C.h
include/omniORB4/IOP_S.h
include/omniORB4/Naming.hh
include/omniORB4/acconfig.h
+include/omniORB4/anyStream.h
include/omniORB4/boa.h
include/omniORB4/bootstrap.hh
+include/omniORB4/boxes_defs.hh
+include/omniORB4/boxes_operators.hh
+include/omniORB4/boxes_poa.hh
include/omniORB4/callDescriptor.h
include/omniORB4/callHandle.h
include/omniORB4/cdrStream.h
@@ -75,7 +84,6 @@ include/omniORB4/internal/GIOP_C.h
include/omniORB4/internal/GIOP_S.h
include/omniORB4/internal/SocketCollection.h
include/omniORB4/internal/anonObject.h
-include/omniORB4/internal/anyP.h
include/omniORB4/internal/codeSetUtil.h
include/omniORB4/internal/context.h
include/omniORB4/internal/corbaBoa.h
@@ -92,6 +100,7 @@ include/omniORB4/internal/giopRendezvouser.h
include/omniORB4/internal/giopRope.h
include/omniORB4/internal/giopServer.h
include/omniORB4/internal/giopStrand.h
+include/omniORB4/internal/giopStrandFlags.h
include/omniORB4/internal/giopStream.h
include/omniORB4/internal/giopStreamImpl.h
include/omniORB4/internal/giopWorker.h
@@ -127,6 +136,8 @@ include/omniORB4/local_config.h
include/omniORB4/minorCode.h
include/omniORB4/objTracker.h
include/omniORB4/omniAsyncInvoker.h
+include/omniORB4/omniConnectionData.hh
+include/omniORB4/omniConnectionMgmt.h
include/omniORB4/omniIOR.h
include/omniORB4/omniInterceptors.h
include/omniORB4/omniInternal.h
@@ -138,11 +149,14 @@ include/omniORB4/omniPolicy.h
include/omniORB4/omniServant.h
include/omniORB4/omniServer.h
include/omniORB4/omniTransport.h
+include/omniORB4/omniTypedefs.hh
include/omniORB4/omniURI.h
include/omniORB4/omniutilities.h
include/omniORB4/optionalFeatures.h
include/omniORB4/poa.h
include/omniORB4/poa_defs.h
+include/omniORB4/poa_enums_defs.h
+include/omniORB4/poa_enums_operators.h
include/omniORB4/poa_operators.h
include/omniORB4/poa_poa.h
include/omniORB4/proxyFactory.h
@@ -153,8 +167,8 @@ include/omniORB4/sslConnection.h
include/omniORB4/sslContext.h
include/omniORB4/sslEndpoint.h
include/omniORB4/sslTransportImpl.h
+include/omniORB4/streamOperators.h
include/omniORB4/stringtypes.h
-include/omniORB4/tcDescriptor.h
include/omniORB4/tcpAddress.h
include/omniORB4/tcpConnection.h
include/omniORB4/tcpEndpoint.h
@@ -167,6 +181,10 @@ include/omniORB4/unixConnection.h
include/omniORB4/unixEndpoint.h
include/omniORB4/unixTransportImpl.h
include/omniORB4/userexception.h
+include/omniORB4/valueFactoryManager.h
+include/omniORB4/valueTemplatedecls.h
+include/omniORB4/valueTemplatedefns.h
+include/omniORB4/valueType.h
include/omniORB4/wstringtypes.h
include/omniconfig.h
include/omnithread.h
@@ -178,39 +196,44 @@ include/omnithread/solaris.h
%%STATIC%%lib/libCOS4.a
%%STATIC%%lib/libCOSDynamic4.a
%%STATIC%%lib/libomniCodeSets4.a
+%%STATIC%%lib/libomniConnectionMgmt4.a
%%STATIC%%lib/libomniDynamic4.a
%%STATIC%%lib/libomniORB4.a
-%%STATIC%%lib/libomnisslTP.a
+%%STATIC%%lib/libomnisslTP4.a
%%STATIC%%lib/libomnithread.a
lib/libCOS4.so
-lib/libCOS4.so.0
-lib/libCOS4.so.0.%%SONUM%%
+lib/libCOS4.so.1
+lib/libCOS4.so.1.%%SONUM%%
lib/libCOSDynamic4.so
-lib/libCOSDynamic4.so.0
-lib/libCOSDynamic4.so.0.%%SONUM%%
+lib/libCOSDynamic4.so.1
+lib/libCOSDynamic4.so.1.%%SONUM%%
lib/libomniCodeSets4.so
-lib/libomniCodeSets4.so.0
-lib/libomniCodeSets4.so.0.%%SONUM%%
+lib/libomniCodeSets4.so.1
+lib/libomniCodeSets4.so.1.%%SONUM%%
+lib/libomniConnectionMgmt4.so
+lib/libomniConnectionMgmt4.so.1
+lib/libomniConnectionMgmt4.so.1.%%SONUM%%
lib/libomniDynamic4.so
-lib/libomniDynamic4.so.0
-lib/libomniDynamic4.so.0.%%SONUM%%
+lib/libomniDynamic4.so.1
+lib/libomniDynamic4.so.1.%%SONUM%%
lib/libomniORB4.so
-lib/libomniORB4.so.0
-lib/libomniORB4.so.0.%%SONUM%%
-lib/libomnisslTP.so
-lib/libomnisslTP.so.4
-lib/libomnisslTP.so.4.0
+lib/libomniORB4.so.1
+lib/libomniORB4.so.1.%%SONUM%%
+lib/libomnisslTP4.so
+lib/libomnisslTP4.so.1
+lib/libomnisslTP4.so.1.0
lib/libomnithread.so
lib/libomnithread.so.3
-lib/libomnithread.so.3.2
+lib/libomnithread.so.3.3
libdata/pkgconfig/omniCOS4.pc
libdata/pkgconfig/omniCOSDynamic4.pc
+libdata/pkgconfig/omniConnectionMgmt4.pc
libdata/pkgconfig/omniDynamic4.pc
libdata/pkgconfig/omniORB4.pc
libdata/pkgconfig/omnithread3.pc
%%PYTHON_SITELIBDIR%%/_omniidlmodule.so
-%%PYTHON_SITELIBDIR%%/_omniidlmodule.so.1
-%%PYTHON_SITELIBDIR%%/_omniidlmodule.so.1.0
+%%PYTHON_SITELIBDIR%%/_omniidlmodule.so.4
+%%PYTHON_SITELIBDIR%%/_omniidlmodule.so.4.1
%%PYTHON_SITELIBDIR%%/omniidl/__init__.py
%%PYTHON_SITELIBDIR%%/omniidl/__init__.pyc
%%PYTHON_SITELIBDIR%%/omniidl/idlast.py
@@ -257,6 +280,8 @@ libdata/pkgconfig/omnithread3.pc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/forward.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/marshal.py
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/marshal.pyc
+%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/obv.py
+%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/obv.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/opers.py
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/opers.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/header/poa.py
@@ -277,6 +302,8 @@ libdata/pkgconfig/omnithread3.pc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/impl/main.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/impl/template.py
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/impl/template.pyc
+%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/mapping.py
+%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/mapping.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/output.py
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/output.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/skel/__init__.py
@@ -297,6 +324,8 @@ libdata/pkgconfig/omnithread3.pc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/types.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/util.py
%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/util.pyc
+%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/value.py
+%%PYTHON_SITELIBDIR%%/omniidl_be/cxx/value.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/dump.py
%%PYTHON_SITELIBDIR%%/omniidl_be/dump.pyc
%%PYTHON_SITELIBDIR%%/omniidl_be/example.py
@@ -306,15 +335,14 @@ libdata/pkgconfig/omnithread3.pc
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README.FIRST.txt
%%PORTDOCS%%%%DOCSDIR%%/README.unix
-%%PORTDOCS%%%%DOCSDIR%%/ReleaseNotes_4.0.%%SONUM%%.txt
-%%PORTDOCS%%%%DOCSDIR%%/omniNames.html
-%%PORTDOCS%%%%DOCSDIR%%/omniNames.pdf
-%%PORTDOCS%%%%DOCSDIR%%/omniNames.ps
+%%PORTDOCS%%%%DOCSDIR%%/ReleaseNotes.txt
%%PORTDOCS%%%%DOCSDIR%%/omniORB.pdf
%%PORTDOCS%%%%DOCSDIR%%/omniORB.ps
%%PORTDOCS%%%%DOCSDIR%%/omniORB/contents_motif.gif
%%PORTDOCS%%%%DOCSDIR%%/omniORB/index.html
%%PORTDOCS%%%%DOCSDIR%%/omniORB/next_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB.css
+%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB.html
%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB001.html
%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB002.html
%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB003.html
@@ -328,6 +356,8 @@ libdata/pkgconfig/omnithread3.pc
%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB011.html
%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB012.html
%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB013.html
+%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB014.html
+%%PORTDOCS%%%%DOCSDIR%%/omniORB/omniORB015.html
%%PORTDOCS%%%%DOCSDIR%%/omniORB/previous_motif.gif
%%PORTDOCS%%%%DOCSDIR%%/omniidl.html
%%PORTDOCS%%%%DOCSDIR%%/omniidl.pdf
@@ -340,7 +370,6 @@ libdata/pkgconfig/omnithread3.pc
%%PORTDOCS%%%%DOCSDIR%%/tex/omniNames.tex
%%PORTDOCS%%%%DOCSDIR%%/tex/omniORB.bib
%%PORTDOCS%%%%DOCSDIR%%/tex/omniORB.tex
-%%PORTDOCS%%%%DOCSDIR%%/tex/omniParTcl.tex
%%PORTDOCS%%%%DOCSDIR%%/tex/omniidl.tex
%%PORTDOCS%%%%DOCSDIR%%/tex/omnithread.tex
%%PORTDOCS%%%%DOCSDIR%%/tex/utilities.tex
@@ -407,6 +436,7 @@ libdata/pkgconfig/omnithread3.pc
%%DATADIR%%/idl/COS/TimeBase.idl
%%DATADIR%%/idl/Naming.idl
%%DATADIR%%/idl/bootstrap.idl
+%%DATADIR%%/idl/boxes.idl
%%DATADIR%%/idl/corbaidl.idl
%%DATADIR%%/idl/echo.idl
%%DATADIR%%/idl/ir.idl