aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 22:04:44 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 22:04:44 +0000
commitcd6ed676539d23edf601936e11a84989f19363e5 (patch)
treed14494b07d89b3519c6c3cda6a5387365833c31d /devel
parente7c8f622573e335c3cc42374a6b3e24b5c21fb6c (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/cmake/Makefile11
-rw-r--r--devel/gvfs/Makefile8
-rw-r--r--devel/libtifiles2/Makefile11
3 files changed, 6 insertions, 24 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index ce1241ec2a91..e3753aa2c1b5 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cmake
PORTVERSION= 3.2.3
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= devel
MASTER_SITES= http://www.cmake.org/files/v3.2/
@@ -25,6 +25,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
OPTIONS_DEFINE= DOCS MANPAGES
OPTIONS_DEFAULT=MANPAGES
OPTIONS_SUB= yes
+USES+= libarchive
HAS_CONFIGURE= yes
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
@@ -42,14 +43,6 @@ MANPAGES_CONFIGURE_ON= --sphinx-man
INSTALL_TARGET= install/strip
.endif
-.if !defined(CMAKE_MODULES)
-# CMake >= 3.1.0 needs libarchive3 because it calls
-# archive_entry_copy_sourcepath_w and archive_write_set_format_7zip.
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000009
-LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
-.endif # ${OPSYS} == FreeBSD && ${OSVERSION} < 1000009
-.endif # !defined(CMAKE_MODULES)
-
post-patch:
@(${FIND} ${WRKSRC}/Modules -name "*.cmake" -print0; \
${FIND} ${WRKSRC}/Tests -name "CMakeLists.txt" -print0 ) | \
diff --git a/devel/gvfs/Makefile b/devel/gvfs/Makefile
index dd1c8cb646e2..b3a305dabc1d 100644
--- a/devel/gvfs/Makefile
+++ b/devel/gvfs/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gvfs
PORTVERSION= 1.20.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -20,7 +20,7 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
PORTSCOUT= limitw:1,even
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake libarchive libtool pathfix pkgconfig tar:xz
USE_GNOME= glib20 gnomeprefix intlhack intltool libxslt:build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -69,10 +69,6 @@ AVAHI_CONFIGURE_ENABLE= avahi
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000000
-LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
-.endif
-
.if ${PORT_OPTIONS:MSAMBA}
GLIB_SCHEMAS+= org.gnome.system.smb.gschema.xml
.endif
diff --git a/devel/libtifiles2/Makefile b/devel/libtifiles2/Makefile
index 36379370fd02..81b2f1688d09 100644
--- a/devel/libtifiles2/Makefile
+++ b/devel/libtifiles2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libtifiles2
PORTVERSION= 1.1.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.17
@@ -15,7 +15,7 @@ LIB_DEPENDS= libticonv.so:${PORTSDIR}/converters/libticonv
USE_GNOME= glib20
USE_LDCONFIG= yes
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libarchive libtool pathfix pkgconfig tar:bzip2
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@@ -24,12 +24,5 @@ NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ARCHIVE_CFLAGS=" " ARCHIVE_LIBS="-larchive"
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-post-patch:
- @${REINPLACE_CMD} -e 's/libarchive/glib-2.0,ticonv/' \
- -e '/Requires:/d' ${WRKSRC}/tifiles2.pc.in
.include <bsd.port.mk>