aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2020-05-18 03:16:22 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2020-05-18 03:16:22 +0000
commitde0892ba632b634a598a05ae9ef8e74420bc8dcd (patch)
tree65d74b17fe8a7b203ace65266586eae33b56dfa9 /devel
parentf70054375ab3f0cb1053b5986fcce20207af297d (diff)
downloadports-de0892ba632b634a598a05ae9ef8e74420bc8dcd.tar.gz
ports-de0892ba632b634a598a05ae9ef8e74420bc8dcd.zip
MFH: r535708 devel/py-dateutil: Update to 2.8.1 [1]
- Remove dateutil_test_test__tz patch, upstreamed [1] - Remove unecessary pytest-cov dependency - Add pytest -W exclusion preventing PytestUnknownMarkWarning: Unknown pytest.mark.no_cover error on test invocation. Changelog: https://dateutil.readthedocs.io/en/stable/changelog.html#version-2-8-1-2019-11-03 PR: 246104 Submitted by: dvl [1] Approved by: ports-secteam (blanket: bugfix release)
Notes
Notes: svn path=/branches/2020Q2/; revision=535711
Diffstat (limited to 'devel')
-rw-r--r--devel/py-dateutil/Makefile8
-rw-r--r--devel/py-dateutil/distinfo6
-rw-r--r--devel/py-dateutil/files/patch-setup.cfg33
3 files changed, 6 insertions, 41 deletions
diff --git a/devel/py-dateutil/Makefile b/devel/py-dateutil/Makefile
index dc3f018b9813..4f66ca7c2438 100644
--- a/devel/py-dateutil/Makefile
+++ b/devel/py-dateutil/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dateutil
-PORTVERSION= 2.8.0
+PORTVERSION= 2.8.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +17,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.5:devel/py-six@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.3:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>=2.2.0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}freezegun>0:devel/py-freezegun@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}hypothesis>=3.30:devel/py-hypothesis@${PY_FLAVOR}
@@ -27,11 +26,10 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
-# Test failure: test_tzlocal_offset_equal[GMT-tzoff1] (dateutil 2.8.0)
-# https://github.com/dateutil/dateutil/issues/918
+# -W fixes PytestUnknownMarkWarning: Unknown pytest.mark.no_cover
do-test:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${TEST_ENV} \
${PYTHON_CMD} -m pytest -v -rs -o addopts= \
- -k 'not test_tzlocal_offset_equal[GMT-tzoff1]'
+ -W ignore::pytest.PytestUnknownMarkWarning
.include <bsd.port.mk>
diff --git a/devel/py-dateutil/distinfo b/devel/py-dateutil/distinfo
index 28b5889ff7ab..d8db686ebea7 100644
--- a/devel/py-dateutil/distinfo
+++ b/devel/py-dateutil/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1558933982
-SHA256 (python-dateutil-2.8.0.tar.gz) = c89805f6f4d64db21ed966fda138f8a5ed7a4fdbc1a8ee329ce1b74e3c74da9e
-SIZE (python-dateutil-2.8.0.tar.gz) = 327134
+TIMESTAMP = 1588386929
+SHA256 (python-dateutil-2.8.1.tar.gz) = 73ebfe9dbf22e832286dafa60473e4cd239f8592f699aa5adaf10050e6e1823c
+SIZE (python-dateutil-2.8.1.tar.gz) = 331745
diff --git a/devel/py-dateutil/files/patch-setup.cfg b/devel/py-dateutil/files/patch-setup.cfg
deleted file mode 100644
index 4b20ceec0da7..000000000000
--- a/devel/py-dateutil/files/patch-setup.cfg
+++ /dev/null
@@ -1,33 +0,0 @@
-From 417f44124e34815e98aa7e736978f5763cdb19a7 Mon Sep 17 00:00:00 2001
-From: Paul Ganssle <paul@ganssle.io>
-Date: Fri, 17 May 2019 18:50:09 -0400
-Subject: [PATCH] Register pytest markers
-
-The latest version of pytest has started warning on unregistered
-markers, which the test suite uses fairly extensively, causing the tests
-to fail. This explicitly registers all the markers used in the test
-suite.
-
---- setup.cfg.orig 2019-02-05 14:11:22 UTC
-+++ setup.cfg
-@@ -14,6 +14,20 @@ filterwarnings =
- error
- error::DeprecationWarning
- error:PendingDeprecationWarning
-+markers =
-+ gettz
-+ import_star
-+ isoparser
-+ parserinfo
-+ rrule
-+ rruleset
-+ rrulestr
-+ smoke
-+ tz_resolve_imaginary
-+ tzfile
-+ tzlocal
-+ tzoffset
-+ tzstr
-
- [egg_info]
- tag_build =