aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:55:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:55:43 +0000
commite15628ebf6a1fcfc276cffc40a3201aacba9138a (patch)
tree036c24888ef699a36a0db41d047b3d0e7e3acbc8 /devel
parent68414c534d086cc747fcd0f7b6f77d79a7b9a560 (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Any-Moose-Convert/Makefile3
-rw-r--r--devel/p5-B-Hooks-OP-Annotation/Makefile2
-rw-r--r--devel/p5-Data-Printer/Makefile7
-rw-r--r--devel/p5-DateTime-Format-Oracle/Makefile4
-rw-r--r--devel/p5-Devel-CallChecker/Makefile3
-rw-r--r--devel/p5-Devel-PackagePath/Makefile3
-rw-r--r--devel/p5-File-HomeDir-PathClass/Makefile4
-rw-r--r--devel/p5-Google-ProtocolBuffers/Makefile3
-rw-r--r--devel/p5-IO-Pty-Easy/Makefile2
-rw-r--r--devel/p5-Lexical-Import/Makefile5
-rw-r--r--devel/p5-Module-CheckDeps/Makefile3
-rw-r--r--devel/p5-MooseX-AuthorizedMethods/Makefile3
-rw-r--r--devel/p5-MooseX-MarkAsMethods/Makefile4
-rw-r--r--devel/p5-MouseX-Foreign/Makefile4
-rw-r--r--devel/p5-MouseX-StrictConstructor/Makefile2
-rw-r--r--devel/p5-MouseX-Traits/Makefile3
-rw-r--r--devel/p5-POE-Loop-Tk/Makefile3
-rw-r--r--devel/p5-PerlIO-Layers/Makefile2
-rw-r--r--devel/p5-Sys-Info-Driver-BSD/Makefile5
-rw-r--r--devel/p5-Sys-Info/Makefile4
-rw-r--r--devel/p5-Test-Exception-LessClever/Makefile2
-rw-r--r--devel/p5-Test-Trap/Makefile3
-rw-r--r--devel/p5-Thrift-XS/Makefile6
23 files changed, 27 insertions, 53 deletions
diff --git a/devel/p5-Any-Moose-Convert/Makefile b/devel/p5-Any-Moose-Convert/Makefile
index d35864567e4b..c24abe203811 100644
--- a/devel/p5-Any-Moose-Convert/Makefile
+++ b/devel/p5-Any-Moose-Convert/Makefile
@@ -16,8 +16,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Convert Moose libraries to Mouse ones, or vice versa
BUILD_DEPENDS= p5-PerlIO-Util>=0:${PORTSDIR}/devel/p5-PerlIO-Util
-RUN_DEPENDS= p5-PerlIO-Util>=0:${PORTSDIR}/devel/p5-PerlIO-Util
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Moose>=0.90:${PORTSDIR}/devel/p5-Moose \
p5-Mouse>=0.40:${PORTSDIR}/devel/p5-Mouse
diff --git a/devel/p5-B-Hooks-OP-Annotation/Makefile b/devel/p5-B-Hooks-OP-Annotation/Makefile
index 91aa1af57020..76b7dea540e2 100644
--- a/devel/p5-B-Hooks-OP-Annotation/Makefile
+++ b/devel/p5-B-Hooks-OP-Annotation/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Annotate and delegate hooked OPs
BUILD_DEPENDS= p5-ExtUtils-Depends>=0.304:${PORTSDIR}/devel/p5-ExtUtils-Depends
-RUN_DEPENDS= p5-ExtUtils-Depends>=0.304:${PORTSDIR}/devel/p5-ExtUtils-Depends
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-Data-Printer/Makefile b/devel/p5-Data-Printer/Makefile
index 10fc60824193..1bafd37a6a04 100644
--- a/devel/p5-Data-Printer/Makefile
+++ b/devel/p5-Data-Printer/Makefile
@@ -20,12 +20,7 @@ BUILD_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
p5-Hash-FieldHash>=0:${PORTSDIR}/devel/p5-Hash-FieldHash \
p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
-RUN_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
- p5-File-HomeDir>=0.91:${PORTSDIR}/devel/p5-File-HomeDir \
- p5-Hash-FieldHash>=0:${PORTSDIR}/devel/p5-Hash-FieldHash \
- p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
- p5-Sort-Naturally>=0:${PORTSDIR}/textproc/p5-Sort-Naturally
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-IO-Pty-Easy>=0:${PORTSDIR}/devel/p5-IO-Pty-Easy \
diff --git a/devel/p5-DateTime-Format-Oracle/Makefile b/devel/p5-DateTime-Format-Oracle/Makefile
index 8138e03035d8..fea67a1c636f 100644
--- a/devel/p5-DateTime-Format-Oracle/Makefile
+++ b/devel/p5-DateTime-Format-Oracle/Makefile
@@ -17,9 +17,7 @@ COMMENT= Parse and format Oracle dates and timestamps
BUILD_DEPENDS= p5-Convert-NLS_DATE_FORMAT>=0.03:${PORTSDIR}/converters/p5-Convert-NLS_DATE_FORMAT \
p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-DateTime-Format-Builder>=0:${PORTSDIR}/devel/p5-DateTime-Format-Builder
-RUN_DEPENDS= p5-Convert-NLS_DATE_FORMAT>=0.03:${PORTSDIR}/converters/p5-Convert-NLS_DATE_FORMAT \
- p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
- p5-DateTime-Format-Builder>=0:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-Devel-CallChecker/Makefile b/devel/p5-Devel-CallChecker/Makefile
index 87ab80e0897c..da75b901fb7e 100644
--- a/devel/p5-Devel-CallChecker/Makefile
+++ b/devel/p5-Devel-CallChecker/Makefile
@@ -15,8 +15,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Custom op checking attached to subroutines
BUILD_DEPENDS= p5-DynaLoader-Functions>=0.001:${PORTSDIR}/devel/p5-DynaLoader-Functions
-RUN_DEPENDS= p5-DynaLoader-Functions>=0.001:${PORTSDIR}/devel/p5-DynaLoader-Functions
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
diff --git a/devel/p5-Devel-PackagePath/Makefile b/devel/p5-Devel-PackagePath/Makefile
index fb59ae26fa84..972f22fd0221 100644
--- a/devel/p5-Devel-PackagePath/Makefile
+++ b/devel/p5-Devel-PackagePath/Makefile
@@ -14,8 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Inspect and manipulate a Path based on a Package name
-RUN_DEPENDS= p5-Moose>=0.64:${PORTSDIR}/devel/p5-Moose \
+BUILD_DEPENDS= p5-Moose>=0.64:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-Types-Path-Class>=0.04:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-File-HomeDir-PathClass/Makefile b/devel/p5-File-HomeDir-PathClass/Makefile
index b4c5a2a6ae0c..30792b687d4c 100644
--- a/devel/p5-File-HomeDir-PathClass/Makefile
+++ b/devel/p5-File-HomeDir-PathClass/Makefile
@@ -18,9 +18,7 @@ COMMENT= File::HomeDir returning Path::Class objects
BUILD_DEPENDS= p5-File-HomeDir>=0.93:${PORTSDIR}/devel/p5-File-HomeDir \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
-RUN_DEPENDS= p5-File-HomeDir>=0.93:${PORTSDIR}/devel/p5-File-HomeDir \
- p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
- p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= modbuild
USES= perl5
diff --git a/devel/p5-Google-ProtocolBuffers/Makefile b/devel/p5-Google-ProtocolBuffers/Makefile
index 7e974c4292ab..6186656ae092 100644
--- a/devel/p5-Google-ProtocolBuffers/Makefile
+++ b/devel/p5-Google-ProtocolBuffers/Makefile
@@ -14,9 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Simple interface to Google Protocol Buffers
-RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Math-BigInt>=0:${PORTSDIR}/math/p5-Math-BigInt \
p5-Parse-RecDescent>=1.94:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-IO-Pty-Easy/Makefile b/devel/p5-IO-Pty-Easy/Makefile
index 0dc86b85b7a8..4a8025530a4f 100644
--- a/devel/p5-IO-Pty-Easy/Makefile
+++ b/devel/p5-IO-Pty-Easy/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Easy interface to IO::Pty
BUILD_DEPENDS= p5-IO-Tty>=0:${PORTSDIR}/devel/p5-IO-Tty
-RUN_DEPENDS= p5-IO-Tty>=0:${PORTSDIR}/devel/p5-IO-Tty
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-Lexical-Import/Makefile b/devel/p5-Lexical-Import/Makefile
index 9589875aa24b..7f2f36a198e0 100644
--- a/devel/p5-Lexical-Import/Makefile
+++ b/devel/p5-Lexical-Import/Makefile
@@ -17,10 +17,7 @@ COMMENT= Clean imports from package-exporting modules
BUILD_DEPENDS= p5-Lexical-Var>=0.006:${PORTSDIR}/devel/p5-Lexical-Var \
p5-Module-Runtime>=0.011:${PORTSDIR}/devel/p5-Module-Runtime \
p5-Params-Classify>=0:${PORTSDIR}/devel/p5-Params-Classify
-RUN_DEPENDS= p5-Lexical-Var>=0.006:${PORTSDIR}/devel/p5-Lexical-Var \
- p5-Module-Runtime>=0.011:${PORTSDIR}/devel/p5-Module-Runtime \
- p5-Params-Classify>=0:${PORTSDIR}/devel/p5-Params-Classify
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
diff --git a/devel/p5-Module-CheckDeps/Makefile b/devel/p5-Module-CheckDeps/Makefile
index 67cd2291732e..18148ce2e41d 100644
--- a/devel/p5-Module-CheckDeps/Makefile
+++ b/devel/p5-Module-CheckDeps/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Very simple dependencies checker for Perl code
-RUN_DEPENDS= p5-PPI>=0:${PORTSDIR}/textproc/p5-PPI
+BUILD_DEPENDS= p5-PPI>=0:${PORTSDIR}/textproc/p5-PPI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-MooseX-AuthorizedMethods/Makefile b/devel/p5-MooseX-AuthorizedMethods/Makefile
index 4e8f32bf0bb9..c8a0c40ea6b3 100644
--- a/devel/p5-MooseX-AuthorizedMethods/Makefile
+++ b/devel/p5-MooseX-AuthorizedMethods/Makefile
@@ -19,8 +19,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Moose>=1.21:${PORTSDIR}/devel/p5-Moose \
p5-aliased>=0:${PORTSDIR}/devel/p5-aliased
-RUN_DEPENDS= p5-Moose>=1.21:${PORTSDIR}/devel/p5-Moose \
- p5-aliased>=0:${PORTSDIR}/devel/p5-aliased
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-MooseX-MarkAsMethods/Makefile b/devel/p5-MooseX-MarkAsMethods/Makefile
index b22a57d04c2a..810eb91e9850 100644
--- a/devel/p5-MooseX-MarkAsMethods/Makefile
+++ b/devel/p5-MooseX-MarkAsMethods/Makefile
@@ -17,9 +17,7 @@ COMMENT= Mark overload code symbols as methods
BUILD_DEPENDS= p5-B-Hooks-EndOfScope>=0:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
p5-Moose>=0.94:${PORTSDIR}/devel/p5-Moose \
p5-namespace-autoclean>=0.12:${PORTSDIR}/devel/p5-namespace-autoclean
-RUN_DEPENDS= p5-B-Hooks-EndOfScope>=0:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
- p5-Moose>=0.94:${PORTSDIR}/devel/p5-Moose \
- p5-namespace-autoclean>=0.12:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-MouseX-Foreign/Makefile b/devel/p5-MouseX-Foreign/Makefile
index 6dd3f26e81a5..3534e5e7fddf 100644
--- a/devel/p5-MouseX-Foreign/Makefile
+++ b/devel/p5-MouseX-Foreign/Makefile
@@ -16,9 +16,7 @@ COMMENT= Extends non-Mouse classes as well as Mouse classes
BUILD_DEPENDS= p5-Any-Moose>=0.15:${PORTSDIR}/devel/p5-Any-Moose \
p5-Mouse>=0.77:${PORTSDIR}/devel/p5-Mouse
-RUN_DEPENDS= p5-Any-Moose>=0.15:${PORTSDIR}/devel/p5-Any-Moose \
- p5-Mouse>=0.77:${PORTSDIR}/devel/p5-Mouse
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
diff --git a/devel/p5-MouseX-StrictConstructor/Makefile b/devel/p5-MouseX-StrictConstructor/Makefile
index 48216010400e..81965a7e5061 100644
--- a/devel/p5-MouseX-StrictConstructor/Makefile
+++ b/devel/p5-MouseX-StrictConstructor/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Make your object constructors blow up on unknown attributes
BUILD_DEPENDS= p5-Mouse>=0.62:${PORTSDIR}/devel/p5-Mouse
-RUN_DEPENDS= p5-Mouse>=0.62:${PORTSDIR}/devel/p5-Mouse
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-MouseX-Traits/Makefile b/devel/p5-MouseX-Traits/Makefile
index b621662d76fa..5c8d036e036f 100644
--- a/devel/p5-MouseX-Traits/Makefile
+++ b/devel/p5-MouseX-Traits/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Automatically apply roles at object creation time
-RUN_DEPENDS= p5-Mouse>=0.81:${PORTSDIR}/devel/p5-Mouse
+BUILD_DEPENDS= p5-Mouse>=0.81:${PORTSDIR}/devel/p5-Mouse
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USE_PERL5= configure
diff --git a/devel/p5-POE-Loop-Tk/Makefile b/devel/p5-POE-Loop-Tk/Makefile
index fa3b67eed56a..5a68170478cd 100644
--- a/devel/p5-POE-Loop-Tk/Makefile
+++ b/devel/p5-POE-Loop-Tk/Makefile
@@ -17,8 +17,7 @@ COMMENT= A bridge that allows POE to be driven by Tk
BUILD_DEPENDS= p5-POE>=1.289:${PORTSDIR}/devel/p5-POE \
p5-Tk>=804.028:${PORTSDIR}/x11-toolkits/p5-Tk
-RUN_DEPENDS= p5-POE>=1.289:${PORTSDIR}/devel/p5-POE \
- p5-Tk>=804.028:${PORTSDIR}/x11-toolkits/p5-Tk
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= configure
USES= perl5
diff --git a/devel/p5-PerlIO-Layers/Makefile b/devel/p5-PerlIO-Layers/Makefile
index ffb6b8e88f90..a8c5ad56c7ec 100644
--- a/devel/p5-PerlIO-Layers/Makefile
+++ b/devel/p5-PerlIO-Layers/Makefile
@@ -18,7 +18,7 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
BUILD_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
-RUN_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= modbuild
USES= perl5
diff --git a/devel/p5-Sys-Info-Driver-BSD/Makefile b/devel/p5-Sys-Info-Driver-BSD/Makefile
index eeecc42ec36c..23ec0de5723c 100644
--- a/devel/p5-Sys-Info-Driver-BSD/Makefile
+++ b/devel/p5-Sys-Info-Driver-BSD/Makefile
@@ -18,10 +18,7 @@ COMMENT= BSD driver for Sys::Info
BUILD_DEPENDS= p5-BSD-Sysctl>=0.08:${PORTSDIR}/sysutils/p5-BSD-Sysctl \
p5-Sys-Info-Base>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Base \
p5-Unix-Processors>=0:${PORTSDIR}/sysutils/p5-Unix-Processors
-RUN_DEPENDS= p5-BSD-Sysctl>=0.08:${PORTSDIR}/sysutils/p5-BSD-Sysctl \
- p5-Sys-Info-Base>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Base \
- p5-Unix-Processors>=0:${PORTSDIR}/sysutils/p5-Unix-Processors
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
p5-Test-Sys-Info>=0.20:${PORTSDIR}/devel/p5-Test-Sys-Info
diff --git a/devel/p5-Sys-Info/Makefile b/devel/p5-Sys-Info/Makefile
index eadfed62c685..c84a652e2d3d 100644
--- a/devel/p5-Sys-Info/Makefile
+++ b/devel/p5-Sys-Info/Makefile
@@ -16,9 +16,7 @@ COMMENT= Fetch information from the host system
BUILD_DEPENDS= p5-Sys-Info-Base>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Base \
p5-Sys-Info-Driver-BSD>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Driver-BSD
-RUN_DEPENDS= p5-Sys-Info-Base>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Base \
- p5-Sys-Info-Driver-BSD>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Driver-BSD
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Sys-Info-Driver-BSD>=0.20:${PORTSDIR}/devel/p5-Test-Sys-Info \
p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
diff --git a/devel/p5-Test-Exception-LessClever/Makefile b/devel/p5-Test-Exception-LessClever/Makefile
index 0a8027abd392..b995903614b5 100644
--- a/devel/p5-Test-Exception-LessClever/Makefile
+++ b/devel/p5-Test-Exception-LessClever/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Test::Exception simplified
BUILD_DEPENDS= p5-Mock-Quick>=1.100:${PORTSDIR}/devel/p5-Mock-Quick
-RUN_DEPENDS= p5-Mock-Quick>=1.100:${PORTSDIR}/devel/p5-Mock-Quick
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= modbuild
USES= perl5
diff --git a/devel/p5-Test-Trap/Makefile b/devel/p5-Test-Trap/Makefile
index 67263dbe3a75..8ccf9fa8481b 100644
--- a/devel/p5-Test-Trap/Makefile
+++ b/devel/p5-Test-Trap/Makefile
@@ -16,8 +16,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Trap exit codes, exceptions, output, etc
BUILD_DEPENDS= p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump
-RUN_DEPENDS= p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
USE_PERL5= configure
diff --git a/devel/p5-Thrift-XS/Makefile b/devel/p5-Thrift-XS/Makefile
index 0e0d51fc6afc..74e2585ed004 100644
--- a/devel/p5-Thrift-XS/Makefile
+++ b/devel/p5-Thrift-XS/Makefile
@@ -19,11 +19,7 @@ BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
- p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
- p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Proc-ProcessTable>=0:${PORTSDIR}/devel/p5-Proc-ProcessTable \
p5-Test-BinaryData>=0:${PORTSDIR}/devel/p5-Test-BinaryData \
p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \