aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-06-03 20:23:42 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-06-03 20:23:42 +0000
commiteb83fd870144b777313a3d3e3417e4e3ba90b48c (patch)
tree3cdeaa6817ce4dda6a453e8efa0122c8408bb903 /devel
parent995888be222d92494435d90daf21195910cbc522 (diff)
downloadports-eb83fd870144b777313a3d3e3417e4e3ba90b48c.tar.gz
ports-eb83fd870144b777313a3d3e3417e4e3ba90b48c.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/devhelp/Makefile12
-rw-r--r--devel/devhelp/files/patch-src::dh-base.c10
-rw-r--r--devel/devhelp/pkg-plist7
3 files changed, 17 insertions, 12 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 717d3e1297ab..d0790bff784c 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -7,28 +7,22 @@
PORTNAME= devhelp
PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
DIST_SUBDIR= gnome2
-MAINTAINER?= adamw@FreeBSD.org
+MAINTAINER= rui@ruilopes.com
COMMENT= Developer help browser for GNOME 2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 gnomehack gnomeprefix
-USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomeprefix libgtkhtml
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|@LIBS@|@LIBS@ ${PTHREAD_LIBS}|' \
- ${WRKSRC}/src/Makefile.in
-
.include <bsd.port.mk>
diff --git a/devel/devhelp/files/patch-src::dh-base.c b/devel/devhelp/files/patch-src::dh-base.c
new file mode 100644
index 000000000000..c364d4ff1b99
--- /dev/null
+++ b/devel/devhelp/files/patch-src::dh-base.c
@@ -0,0 +1,10 @@
+--- src/dh-base.c.orig Tue Jun 3 12:21:34 2003
++++ src/dh-base.c Tue Jun 3 12:23:04 2003
+@@ -155,6 +155,7 @@
+
+ /* Insert the books from default gtk-doc install path */
+ base_add_books (base, DATADIR"/gtk-doc/html");
++ base_add_books (base, DATADIR"/../doc"); // FreeBSD default doc path
+ base_add_books (base, "/usr/share/gtk-doc/html");
+ base_add_books (base, DATADIR"/devhelp/books");
+ dir = g_strconcat (g_getenv ("HOME"), "/.devhelp/books", NULL);
diff --git a/devel/devhelp/pkg-plist b/devel/devhelp/pkg-plist
index ec04fea7a5bc..2c8914547500 100644
--- a/devel/devhelp/pkg-plist
+++ b/devel/devhelp/pkg-plist
@@ -1,14 +1,14 @@
bin/devhelp
lib/devhelp/libdevhelp.so
+share/gnome/applications/devhelp.desktop
share/gnome/devhelp/dtd/devhelp-1.dtd
-share/gnome/devhelp/images/book_open.png
share/gnome/devhelp/images/book_closed.png
+share/gnome/devhelp/images/book_open.png
share/gnome/devhelp/images/helpdoc.png
share/gnome/devhelp/ui/window.ui
-share/gnome/pixmaps/devhelp.png
-share/gnome/applications/devhelp.desktop
share/gnome/mime-info/devhelp.keys
share/gnome/mime-info/devhelp.mime
+share/gnome/pixmaps/devhelp.png
share/locale/am/LC_MESSAGES/devhelp.mo
share/locale/az/LC_MESSAGES/devhelp.mo
share/locale/be/LC_MESSAGES/devhelp.mo
@@ -43,3 +43,4 @@ share/locale/zh_TW/LC_MESSAGES/devhelp.mo
@dirrm share/gnome/devhelp/images
@dirrm share/gnome/devhelp/dtd
@dirrm share/gnome/devhelp
+@dirrm lib/devhelp