aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-02-11 11:03:29 +0000
committerWen Heping <wen@FreeBSD.org>2010-02-11 11:03:29 +0000
commit037bb9ed444608beebeb7a0ab84da95f24c44c94 (patch)
treeb5ad38a99d436c8b7a1af03429bf3dca43400079 /devel
parenta639b8cc99cc44dbacddee4717d7148b5f3154f8 (diff)
downloadports-037bb9ed444608beebeb7a0ab84da95f24c44c94.tar.gz
ports-037bb9ed444608beebeb7a0ab84da95f24c44c94.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-VersionControl_Git/Makefile44
-rw-r--r--devel/pear-VersionControl_Git/distinfo3
-rw-r--r--devel/pear-VersionControl_Git/pkg-descr5
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0f383fb52a72..70493cbae520 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2348,6 +2348,7 @@
SUBDIR += pear-Validate_Finance
SUBDIR += pear-Validate_Finance_CreditCard
SUBDIR += pear-Var_Dump
+ SUBDIR += pear-VersionControl_Git
SUBDIR += pear-VersionControl_SVN
SUBDIR += pear-XML_NITF
SUBDIR += pear-XML_Parser
diff --git a/devel/pear-VersionControl_Git/Makefile b/devel/pear-VersionControl_Git/Makefile
new file mode 100644
index 000000000000..5bec1e1b8f81
--- /dev/null
+++ b/devel/pear-VersionControl_Git/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: pear-VersionControl_Git
+# Date created: 11 Feb, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= VersionControl_Git
+PORTVERSION= 0.4.2
+CATEGORIES= devel pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= OO interface to handle Git repository
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+FILES= VersionControl/Git.php \
+ VersionControl/Git/Component.php \
+ VersionControl/Git/Exception.php \
+ VersionControl/Git/Object.php \
+ VersionControl/Git/Object/Blob.php \
+ VersionControl/Git/Object/Commit.php \
+ VersionControl/Git/Object/Tree.php \
+ VersionControl/Git/Util/Command.php \
+ VersionControl/Git/Util/RevListFetcher.php
+
+DOCS= intro.xml tutorial.xml
+_DOCSDIR= doc
+
+TESTS= README \
+ VersionControl_GitTest.php \
+ VersionControl_Git_ComponentTest.php \
+ VersionControl_Git_ObjectTest.php \
+ VersionControl_Git_Object_BlobTest.php \
+ VersionControl_Git_Object_CommitTest.php \
+ VersionControl_Git_Object_TreeTest.php \
+ VersionControl_Git_Util_CommandTest.php \
+ checkFixtures.php
+_TESTSDIR= test
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-VersionControl_Git/distinfo b/devel/pear-VersionControl_Git/distinfo
new file mode 100644
index 000000000000..39177de20652
--- /dev/null
+++ b/devel/pear-VersionControl_Git/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/VersionControl_Git-0.4.2.tgz) = a0485321487da5aae78aa2245e53e709
+SHA256 (PEAR/VersionControl_Git-0.4.2.tgz) = 2f69c19a6f693def5decddfa3a17917d448fed0f827a49f2ee2706762b7ca387
+SIZE (PEAR/VersionControl_Git-0.4.2.tgz) = 13698
diff --git a/devel/pear-VersionControl_Git/pkg-descr b/devel/pear-VersionControl_Git/pkg-descr
new file mode 100644
index 000000000000..254f0a2cc38f
--- /dev/null
+++ b/devel/pear-VersionControl_Git/pkg-descr
@@ -0,0 +1,5 @@
+VersionControl_Git is a library that provides OO interface to
+handle Git repository. You can use Git command via the wrapper
+class. Some features are provided by high-featured interface.
+
+WWW: http://pear.php.net/package/VersionControl_Git