aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2006-06-06 07:27:09 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2006-06-06 07:27:09 +0000
commit066ce7c5ce7151ec5c9c2cc3f62f784acc9f6186 (patch)
tree55f0f496e595f2646a2badf927ba88e98c4eec8b /devel
parente70e8143064ee57b221e8852f803634d206d8ed6 (diff)
downloadports-066ce7c5ce7151ec5c9c2cc3f62f784acc9f6186.tar.gz
ports-066ce7c5ce7151ec5c9c2cc3f62f784acc9f6186.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-OptList/Makefile31
-rw-r--r--devel/p5-Data-OptList/distinfo3
-rw-r--r--devel/p5-Data-OptList/pkg-descr22
-rw-r--r--devel/p5-Data-OptList/pkg-plist5
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d2cf373a1079..5b6fd0ad33ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -851,6 +851,7 @@
SUBDIR += p5-Data-Hexdumper
SUBDIR += p5-Data-Hierarchy
SUBDIR += p5-Data-Lazy
+ SUBDIR += p5-Data-OptList
SUBDIR += p5-Data-Properties
SUBDIR += p5-Data-Random
SUBDIR += p5-Data-Serializer
diff --git a/devel/p5-Data-OptList/Makefile b/devel/p5-Data-OptList/Makefile
new file mode 100644
index 000000000000..08475588e453
--- /dev/null
+++ b/devel/p5-Data-OptList/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-Data-OptList
+# Date created: 6/6/6
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-OptList
+PORTVERSION= 0.100
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Parse and validate simple name/value option pairs
+
+BUILD_DEPENDS= p5-Sub-Install>=0.92:${PORTSDIR}/devel/p5-Sub-Install \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Params-Util>=0.14:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::OptList.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-OptList/distinfo b/devel/p5-Data-OptList/distinfo
new file mode 100644
index 000000000000..a6296937d5bd
--- /dev/null
+++ b/devel/p5-Data-OptList/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-OptList-0.100.tar.gz) = de684b0eab4e49a53584a91a77761412
+SHA256 (Data-OptList-0.100.tar.gz) = b532827ad0aab5d928ab70b413444b940c37da556dd54da329e3ebc19f4a28b7
+SIZE (Data-OptList-0.100.tar.gz) = 13080
diff --git a/devel/p5-Data-OptList/pkg-descr b/devel/p5-Data-OptList/pkg-descr
new file mode 100644
index 000000000000..fe67a2266fd7
--- /dev/null
+++ b/devel/p5-Data-OptList/pkg-descr
@@ -0,0 +1,22 @@
+Hashes are great for storing named data, but if you want more than one entry
+for a name, you have to use a list of pairs. Even then, this is really boring
+to write:
+
+ @values = (
+ foo => undef,
+ bar => undef,
+ baz => undef,
+ xyz => { ... },
+ );
+
+With Data::OptList, you can do this instead:
+
+ Data::OptList::mkopt([
+ qw(foo bar baz),
+ xyz => { ... },
+ ]);
+
+This works by assuming that any defined scalar is a name and any reference
+following a name is its value.
+
+WWW: http://search.cpan.org/dist/Data-OptList/
diff --git a/devel/p5-Data-OptList/pkg-plist b/devel/p5-Data-OptList/pkg-plist
new file mode 100644
index 000000000000..8a0871c55c65
--- /dev/null
+++ b/devel/p5-Data-OptList/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/OptList.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/OptList/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/OptList
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data