aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-10-22 14:56:47 +0000
committerChris Rees <crees@FreeBSD.org>2011-10-22 14:56:47 +0000
commit35a03f063e78880f1db503a5b6ecff114edbbf0f (patch)
tree61e3341bbe05e31726690c3fe624b9bfb1b90eb9 /devel
parent9acba9714643b24d130052dd56f05048178ca382 (diff)
downloadports-35a03f063e78880f1db503a5b6ecff114edbbf0f.tar.gz
ports-35a03f063e78880f1db503a5b6ecff114edbbf0f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/boost-pyste/Makefile61
-rw-r--r--devel/boost-pyste/distinfo2
-rw-r--r--devel/boost-pyste/files/patch-Jamroot11
-rw-r--r--devel/boost-pyste/files/patch-tools_build_v2_engine_src_build.jam11
-rw-r--r--devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam17
-rw-r--r--devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam29
-rw-r--r--devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam11
-rw-r--r--devel/boost-pyste/pkg-descr7
-rw-r--r--devel/boost-pyste/pkg-plist65
10 files changed, 0 insertions, 215 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 30b145b61930..ca115fe4bc80 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -117,7 +117,6 @@
SUBDIR += boost-docs
SUBDIR += boost-jam
SUBDIR += boost-libs
- SUBDIR += boost-pyste
SUBDIR += boost-python-libs
SUBDIR += boost_build
SUBDIR += bouml
diff --git a/devel/boost-pyste/Makefile b/devel/boost-pyste/Makefile
deleted file mode 100644
index 2993cde93eae..000000000000
--- a/devel/boost-pyste/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-# Ports collection makefile for: boost-pyste
-# Date Created: 16 Novemeber 2009
-# Whom: Alexander Churanov <churanov.port.maintainer@gmail.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= boost-pyste
-PORTREVISION= 1
-COMMENT= Boost.Python code generator
-
-CONFLICTS+= boost-python-libs-1.3* boost-python-libs-1.40
-USE_BZIP2= yes
-USE_PYTHON= 2.5+
-
-DEPRECATED= Still requires GCC 3.4 (strictly) and gccxml which is deprecated (and has been broken for a while)
-EXPIRATION_DATE=2011-10-13
-
-OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
- DEBUG "Build debugging symbols" off \
- OPTIMIZED_CFLAGS "Enable -O3 optimization" off
-
-INSTALLS_EGGINFO= yes
-PYDISTUTILS_PKGNAME= Pyste
-PYDISTUTILS_PKGVERSION= 0.9.10
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/boost-all/common.mk"
-.include "${PORTSDIR}/devel/boost-all/compiled.mk"
-
-MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
- PYTHON_VERSION="${PYTHON_VERSION}"\
- PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"\
- PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
-
-RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so.${BOOST_SHARED_LIB_VER}:${PORTSDIR}/devel/boost-python-libs
-
-RUN_DEPENDS+= gccxml:${PORTSDIR}/devel/gccxml
-BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
-
-post-patch: customize-boost-build
-
-post-configure:
-# Configure pyste, the Boost.Python code generator
- @cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
- ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
- config ${PYDISTUTILS_CONFIGUREARGS}
-
-do-build:
-# Build pyste, the Boost.Python code generator
- cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
- ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
- build ${PYDISTUTILS_BUILDARGS}
-
-do-install:
-# Install pyste, the Boost.Python code generator
- cd ${WRKSRC}/libs/python/pyste/install && \
- ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} \
- install ${PYDISTUTILS_INSTALLARGS}
-
-.include <bsd.port.post.mk>
diff --git a/devel/boost-pyste/distinfo b/devel/boost-pyste/distinfo
deleted file mode 100644
index 3301fd825537..000000000000
--- a/devel/boost-pyste/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (boost_1_45_0.tar.bz2) = 55ed3ec51d5687e8224c988e22bef215dacce04e037d9f689569a80c4377a6d5
-SIZE (boost_1_45_0.tar.bz2) = 39330184
diff --git a/devel/boost-pyste/files/patch-Jamroot b/devel/boost-pyste/files/patch-Jamroot
deleted file mode 100644
index 7903f6daf682..000000000000
--- a/devel/boost-pyste/files/patch-Jamroot
+++ /dev/null
@@ -1,11 +0,0 @@
---- Jamroot.orig 2009-09-23 16:35:49.000000000 +0400
-+++ Jamroot 2009-09-23 16:36:49.000000000 +0400
-@@ -384,7 +384,7 @@
- # suffixes either. Pgi compilers can not accept library with version
- # suffix.
- if $(type) = SHARED_LIB &&
-- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
-+ ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix freebsd ) &&
- ! ( [ $(property-set).get <toolset> ] in pgi ) )
- {
- result = $(result).$(BOOST_VERSION) ;
diff --git a/devel/boost-pyste/files/patch-tools_build_v2_engine_src_build.jam b/devel/boost-pyste/files/patch-tools_build_v2_engine_src_build.jam
deleted file mode 100644
index fab5e0bfc2ac..000000000000
--- a/devel/boost-pyste/files/patch-tools_build_v2_engine_src_build.jam
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/build/v2/engine/src/build.jam.orig Tue Jul 29 15:43:31 2008
-+++ tools/build/v2/engine/src/build.jam Tue Nov 11 23:52:09 2008
-@@ -176,7 +176,7 @@
- ## GCC 2.x, 3.x, 4.x
- toolset gcc gcc : "-o " : -D
- : -pedantic -fno-strict-aliasing
-- [ opt --release : [ opt --symbols : -g : -s ] -O3 ]
-+ [ opt --release : [ opt --symbols : -g : -s ] -O3 -fno-strict-aliasing ]
- [ opt --debug : -g -O0 -fno-inline ]
- -I$(--python-include) -I$(--extra-include) -Wno-long-long
- : -L$(--python-lib[1]) -l$(--python-lib[2]) ;
diff --git a/devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam b/devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam
deleted file mode 100644
index cc306b204292..000000000000
--- a/devel/boost-pyste/files/patch-tools_build_v2_tools_common.jam
+++ /dev/null
@@ -1,17 +0,0 @@
---- tools/build/v2/tools/common.jam.orig 2009-09-23 16:39:31.000000000 +0400
-+++ tools/build/v2/tools/common.jam 2009-09-23 16:39:33.000000000 +0400
-@@ -765,14 +765,6 @@
- result += [ join-tag $(f:G=) : [ toolset-tag $(name) : $(type) :
- $(property-set) ] ] ;
-
-- case <threading> :
-- result += [ join-tag $(f:G=) : [ threading-tag $(name) : $(type)
-- : $(property-set) ] ] ;
--
-- case <runtime> :
-- result += [ join-tag $(f:G=) : [ runtime-tag $(name) : $(type) :
-- $(property-set) ] ] ;
--
- case <qt> :
- result += [ join-tag $(f:G=) : [ qt-tag $(name) : $(type) :
- $(property-set) ] ] ;
diff --git a/devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam b/devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam
deleted file mode 100644
index 9daa31f24d9c..000000000000
--- a/devel/boost-pyste/files/patch-tools_build_v2_tools_gcc.jam
+++ /dev/null
@@ -1,29 +0,0 @@
---- tools/build/v2/tools/gcc.jam.orig Thu Oct 16 12:42:03 2008
-+++ tools/build/v2/tools/gcc.jam Tue Nov 11 23:48:37 2008
-@@ -88,7 +88,7 @@
- {
- # Information about the gcc command...
- # The command.
-- local command = [ common.get-invocation-command gcc : g++ : $(command) ] ;
-+ local command = [ common.get-invocation-command gcc : %%CXX%% : $(command) ] ;
- # The root directory of the tool install.
- local root = [ feature.get-values <root> : $(options) ] ;
- # The bin directory where to find the command to execute.
-@@ -292,7 +292,7 @@
-
- # Declare flags and action for compilation.
- toolset.flags gcc.compile OPTIONS <optimization>off : -O0 ;
--toolset.flags gcc.compile OPTIONS <optimization>speed : -O3 ;
-+toolset.flags gcc.compile OPTIONS <optimization>speed : %%CXXFLAGS%% ;
- toolset.flags gcc.compile OPTIONS <optimization>space : -Os ;
-
- toolset.flags gcc.compile OPTIONS <inlining>off : -fno-inline ;
-@@ -811,7 +811,7 @@
- }
- case *bsd :
- {
-- option = -pthread ;
-+ option = %%PTHREAD_LIBS%% %%PTHREAD_CFLAGS%% ;
- # There is no -lrt on BSD.
- }
- case sgi :
diff --git a/devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam b/devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam
deleted file mode 100644
index bf2212b3d520..000000000000
--- a/devel/boost-pyste/files/patch-tools_build_v2_tools_python.jam
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/build/v2/tools/python.jam.orig Thu Oct 16 12:42:03 2008
-+++ tools/build/v2/tools/python.jam Tue Nov 11 23:50:21 2008
-@@ -650,7 +650,7 @@
- case windows : return ;
-
- case hpux : return <library>rt ;
-- case *bsd : return <library>pthread <toolset>gcc:<library>util ;
-+ case *bsd : return <library>%%PTHREAD_LIBS%% <toolset>gcc:<library>util ;
-
- case aix : return <library>pthread <library>dl ;
-
diff --git a/devel/boost-pyste/pkg-descr b/devel/boost-pyste/pkg-descr
deleted file mode 100644
index cb51cc0a993a..000000000000
--- a/devel/boost-pyste/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Pyste is a Boost.Python code generator. The user specifies the classes
-and functions to be exported using a simple interface file, which
-following the Boost.Python's philosophy, is simple Python code. Pyste
-then uses GCCXML to parse all the headers and extract the necessary
-information to automatically generate C++ code.
-
-WWW: http://www.boost.org/
diff --git a/devel/boost-pyste/pkg-plist b/devel/boost-pyste/pkg-plist
deleted file mode 100644
index d2167e059e54..000000000000
--- a/devel/boost-pyste/pkg-plist
+++ /dev/null
@@ -1,65 +0,0 @@
-bin/pyste.py
-%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.py
-%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/ClassExporter.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.py
-%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/CodeExporter.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/CppParser.py
-%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/CppParser.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.py
-%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/EnumExporter.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/Exporter.py
-%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/Exporter.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.py
-%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/FunctionExporter.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.py
-%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/GCCXMLParser.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.py
-%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/HeaderExporter.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.py
-%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/MultipleCodeUnit.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.py
-%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/SingleCodeUnit.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.py
-%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/SmartFile.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.py
-%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/VarExporter.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/__init__.py
-%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/__init__.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/declarations.py
-%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/declarations.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/exporters.py
-%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/exporters.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.py
-%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/exporterutils.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/infos.py
-%%PYTHON_SITELIBDIR%%/Pyste/infos.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/infos.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/policies.py
-%%PYTHON_SITELIBDIR%%/Pyste/policies.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/policies.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/pyste.py
-%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/pyste.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/settings.py
-%%PYTHON_SITELIBDIR%%/Pyste/settings.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/settings.pyo
-%%PYTHON_SITELIBDIR%%/Pyste/utils.py
-%%PYTHON_SITELIBDIR%%/Pyste/utils.pyc
-%%PYTHON_SITELIBDIR%%/Pyste/utils.pyo
-@dirrm %%PYTHON_SITELIBDIR%%/Pyste