aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-11-20 22:53:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-11-20 22:53:09 +0000
commit38eb8c5339e31bce015d6652caf364542965d4d0 (patch)
tree57033736b4eab37d8b46bb4b452f790f37bd0c7a /devel
parent1a3a92532506ba92f7a9670be49752b00ad8a807 (diff)
downloadports-38eb8c5339e31bce015d6652caf364542965d4d0.tar.gz
ports-38eb8c5339e31bce015d6652caf364542965d4d0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/judy/Makefile1
-rw-r--r--devel/kimwitu/Makefile1
-rw-r--r--devel/lbpp/Makefile1
-rw-r--r--devel/libbegemot/Makefile2
-rw-r--r--devel/libcapsinetwork/Makefile1
-rw-r--r--devel/libchipcard-kde/Makefile1
-rw-r--r--devel/libdlna/Makefile1
-rw-r--r--devel/libdnsres/Makefile1
-rw-r--r--devel/liboop/Makefile1
-rw-r--r--devel/libreadline-java/Makefile1
-rw-r--r--devel/libtecla/Makefile1
-rw-r--r--devel/log4cplus/Makefile1
-rw-r--r--devel/log4cxx/Makefile1
-rw-r--r--devel/luajava/Makefile1
-rw-r--r--devel/maketool/Makefile1
-rw-r--r--devel/memcheck/Makefile2
-rw-r--r--devel/monotone-viz/Makefile1
-rw-r--r--devel/ncurses-devel/Makefile1
-rw-r--r--devel/ncurses/Makefile1
-rw-r--r--devel/ngpt/Makefile1
-rw-r--r--devel/ocaml-camlp5/Makefile1
-rw-r--r--devel/ocaml-camomile/Makefile1
-rw-r--r--devel/ocaml-cfg/Makefile1
-rw-r--r--devel/ocaml-equeue/Makefile1
-rw-r--r--devel/ocaml-lacaml/Makefile1
-rw-r--r--devel/ocaml-res/Makefile1
-rw-r--r--devel/ocaml-sem/Makefile1
-rw-r--r--devel/ocaml-sexplib/Makefile1
-rw-r--r--devel/ocaml-xstrp4/Makefile1
-rw-r--r--devel/ode-devel/Makefile1
-rw-r--r--devel/omake/Makefile1
-rw-r--r--devel/p5-Device-USB/Makefile1
-rw-r--r--devel/p5-Gnome2-GConf/Makefile1
-rw-r--r--devel/p5-PAR-Packer/Makefile1
-rw-r--r--devel/p5-usb/Makefile1
-rw-r--r--devel/pdcurses-the/Makefile1
-rw-r--r--devel/pthsem/Makefile2
-rw-r--r--devel/ptypes/Makefile1
38 files changed, 40 insertions, 1 deletions
diff --git a/devel/judy/Makefile b/devel/judy/Makefile
index 002ad17daebf..f71c150b0bd9 100644
--- a/devel/judy/Makefile
+++ b/devel/judy/Makefile
@@ -16,6 +16,7 @@ COMMENT= General purpose dynamic array
GNU_CONFIGURE= yes
USE_GMAKE= YES
USE_LDCONFIG= YES
+MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME:L}-${PORTVERSION}
diff --git a/devel/kimwitu/Makefile b/devel/kimwitu/Makefile
index 9c5c68d7e41c..8928697a339f 100644
--- a/devel/kimwitu/Makefile
+++ b/devel/kimwitu/Makefile
@@ -17,6 +17,7 @@ COMMENT= A tool for processing trees (i.e. terms)
WRKSRC= ${WRKDIR}/${DISTNAME}/src
ALL_TARGET=
+MAKE_JOBS_UNSAFE= yes
MAN1= kc.1
PLIST_FILES= bin/kc
diff --git a/devel/lbpp/Makefile b/devel/lbpp/Makefile
index 48d4196efe01..fa2947acfc28 100644
--- a/devel/lbpp/Makefile
+++ b/devel/lbpp/Makefile
@@ -18,6 +18,7 @@ COMMENT= A front end to GCC from Liberty Basic source code
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomelibs
+MAKE_JOBS_UNSAFE= yes
post-patch:
@${GREP} -lR "malloc.h" ${WRKSRC} | ${XARGS} \
diff --git a/devel/libbegemot/Makefile b/devel/libbegemot/Makefile
index faffaa5fa33c..51eb228051e3 100644
--- a/devel/libbegemot/Makefile
+++ b/devel/libbegemot/Makefile
@@ -19,7 +19,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= automake:19:env autoconf:262:env libltdl:22 libtool:22
USE_LDCONFIG= yes
-
+MAKE_JOBS_UNSAFE= yes
MAN1= cstrc.1 frame.1 getfields.1 intro.1 panic.1 prstat.1 readline.1 \
rpoll.1 strnchr.1 strnlen.1 strsave.1 strtrimsp.1 verb.1 xalloc.1
diff --git a/devel/libcapsinetwork/Makefile b/devel/libcapsinetwork/Makefile
index 39e957e870ab..aaf288d54a88 100644
--- a/devel/libcapsinetwork/Makefile
+++ b/devel/libcapsinetwork/Makefile
@@ -16,5 +16,6 @@ COMMENT= Network library aimed at easy development of C++ server daemons
USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.mk>
diff --git a/devel/libchipcard-kde/Makefile b/devel/libchipcard-kde/Makefile
index 1ac6e9c84dbd..41e3e0cb243c 100644
--- a/devel/libchipcard-kde/Makefile
+++ b/devel/libchipcard-kde/Makefile
@@ -21,6 +21,7 @@ USE_AUTOTOOLS= libtool:22
CONFIGURE_ARGS+= --with-distri=freebsd --with-kde3-prefix=${LOCALBASE}\
--with-applnk-dir=${PREFIX}/share/applnk/Utilities
USE_KDELIBS_VER= 3
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/libdlna/Makefile b/devel/libdlna/Makefile
index 4022ddf098a8..af778f1bd922 100644
--- a/devel/libdlna/Makefile
+++ b/devel/libdlna/Makefile
@@ -22,6 +22,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS+= --prefix="${PREFIX}" --disable-optimize \
--includedir=${LOCALBASE}/include \
diff --git a/devel/libdnsres/Makefile b/devel/libdnsres/Makefile
index bd7c2ecec066..455a00db1de0 100644
--- a/devel/libdnsres/Makefile
+++ b/devel/libdnsres/Makefile
@@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
CONFIGURE_ARGS=--with-libevent=${LOCALBASE}
+MAKE_JOBS_UNSAFE= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
diff --git a/devel/liboop/Makefile b/devel/liboop/Makefile
index 3a14030007df..7f9cedd4459a 100644
--- a/devel/liboop/Makefile
+++ b/devel/liboop/Makefile
@@ -27,6 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-libwww
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
CPPFLAGS= -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
diff --git a/devel/libreadline-java/Makefile b/devel/libreadline-java/Makefile
index 0b253b4aa33e..3d1a52799acd 100644
--- a/devel/libreadline-java/Makefile
+++ b/devel/libreadline-java/Makefile
@@ -33,6 +33,7 @@ USE_GMAKE= yes
USE_JAVA= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKE_JOBS_UNSAFE= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/libreadline-java.jar ${JAVAJARDIR}
diff --git a/devel/libtecla/Makefile b/devel/libtecla/Makefile
index 6efac42cdbe9..eefdbbcef5ec 100644
--- a/devel/libtecla/Makefile
+++ b/devel/libtecla/Makefile
@@ -22,6 +22,7 @@ USE_LDCONFIG= yes
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
REALCURDIR="${.CURDIR}" \
PORTNAME="${PORTNAME}"
+MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/log4cplus/Makefile b/devel/log4cplus/Makefile
index a6c36778bf6a..4c85b72539e7 100644
--- a/devel/log4cplus/Makefile
+++ b/devel/log4cplus/Makefile
@@ -20,6 +20,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+MAKE_JOBS_UNSAFE= yes
.if !defined(NOPORTDOCS)
PORTDOCS= *
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
index edf374182a11..4c8c653a38b3 100644
--- a/devel/log4cxx/Makefile
+++ b/devel/log4cxx/Makefile
@@ -32,6 +32,7 @@ CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_AUTOTOOLS= automake:15 autoconf:262 libtool:22
AUTOMAKE_ARGS= --add-missing
LIBTOOL_VARS= --force --automake
+MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -I${LOCALBASE}/lib
diff --git a/devel/luajava/Makefile b/devel/luajava/Makefile
index dda2494b2e5d..024ec430d9d2 100644
--- a/devel/luajava/Makefile
+++ b/devel/luajava/Makefile
@@ -22,6 +22,7 @@ LUA_COMPS+= compat51
.endif
USE_JAVA= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
ALL_TARGET= run
USE_DOS2UNIX= yes
diff --git a/devel/maketool/Makefile b/devel/maketool/Makefile
index 5ffb38aa81e7..1460ab82ffd7 100644
--- a/devel/maketool/Makefile
+++ b/devel/maketool/Makefile
@@ -24,6 +24,7 @@ PLIST= ${WRKDIR}/pkg-plist
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GNOME= atk glib20 gtk20 pango
+MAKE_JOBS_UNSAFE= yes
post-patch:
${REINPLACE_CMD} -e "s,-Wpointer-arithmetic,," ${WRKSRC}/configure
diff --git a/devel/memcheck/Makefile b/devel/memcheck/Makefile
index 7a399c306172..f845d6412ca2 100644
--- a/devel/memcheck/Makefile
+++ b/devel/memcheck/Makefile
@@ -17,4 +17,6 @@ USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
+
.include <bsd.port.mk>
diff --git a/devel/monotone-viz/Makefile b/devel/monotone-viz/Makefile
index 20ca44d1d252..7ed4dc770ae4 100644
--- a/devel/monotone-viz/Makefile
+++ b/devel/monotone-viz/Makefile
@@ -24,6 +24,7 @@ USE_GMAKE= YES
USE_GNOME= gtk20 libgnomecanvas
ALL_TARGET=
+MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/monotone-viz
diff --git a/devel/ncurses-devel/Makefile b/devel/ncurses-devel/Makefile
index a496313a0033..3df82e7b1a70 100644
--- a/devel/ncurses-devel/Makefile
+++ b/devel/ncurses-devel/Makefile
@@ -50,6 +50,7 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
--without-curses-h --with-termlib --program-prefix= \
--enable-rpath --disable-root-environ \
--with-manpage-format=gzip --srcdir=../
+MAKE_JOBS_UNSAFE= yes
OPTIONS= EXTCOLORS "Enable 256-color support (only for ncursesw)" off
diff --git a/devel/ncurses/Makefile b/devel/ncurses/Makefile
index dc0c832b0e3f..e34f32cacbcd 100644
--- a/devel/ncurses/Makefile
+++ b/devel/ncurses/Makefile
@@ -29,6 +29,7 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
--without-curses-h --with-termlib --program-prefix= \
--enable-rpath --disable-root-environ \
--with-manpage-format=gzip --srcdir=../
+MAKE_JOBS_UNSAFE= yes
OPTIONS= EXTCOLORS "Enable 256-color support (only for ncursesw)" off
diff --git a/devel/ngpt/Makefile b/devel/ngpt/Makefile
index b89cd1821476..efc7a00e118c 100644
--- a/devel/ngpt/Makefile
+++ b/devel/ngpt/Makefile
@@ -21,6 +21,7 @@ CONFIGURE_ARGS= --enable-tests=no --enable-maintainer=no \
--enable-pthread --disable-kernel-patch \
--exec-prefix=${PREFIX} --includedir=${PREFIX}/include
USE_GMAKE= yes
+MAKE_JOBS_UNSAFE= yes
ONLY_FOR_ARCHS= amd64 i386
diff --git a/devel/ocaml-camlp5/Makefile b/devel/ocaml-camlp5/Makefile
index 6f5521ac03d2..0aa86aa5496b 100644
--- a/devel/ocaml-camlp5/Makefile
+++ b/devel/ocaml-camlp5/Makefile
@@ -19,6 +19,7 @@ COMMENT= A preprocessor-pretty-printer of OCaml
USE_OCAML= yes
HAS_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
.if defined(WITH_TRANSITIONAL) || !defined(WITH_STRICT)
CONFIGURE_ARGS= --transitional --prefix ${PREFIX}
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index c6e544a8ebcd..fd0d9c788b0e 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -23,6 +23,7 @@ USE_OCAML_FINDLIB=yes
USE_OCAML_LDCONFIG=yes
USE_OCAML_WASH= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
diff --git a/devel/ocaml-cfg/Makefile b/devel/ocaml-cfg/Makefile
index 194df680a6a0..d86a2e4893bf 100644
--- a/devel/ocaml-cfg/Makefile
+++ b/devel/ocaml-cfg/Makefile
@@ -21,6 +21,7 @@ USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
USE_OCAML_WASH= yes
+MAKE_JOBS_UNSAFE= yes
DOCS= README
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
diff --git a/devel/ocaml-equeue/Makefile b/devel/ocaml-equeue/Makefile
index df88f5c3be92..397470081082 100644
--- a/devel/ocaml-equeue/Makefile
+++ b/devel/ocaml-equeue/Makefile
@@ -28,6 +28,7 @@ MAKE_FLAGS= PACKAGES= # If defined, would be used by ocamlfind
HAS_CONFIGURE= yes
ALL_TARGET= all opt
+MAKE_JOBS_UNSAFE= yes
PKGDEINSTALL= ${PKGINSTALL}
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
index 4e8bfc018933..6f2af79a38d9 100644
--- a/devel/ocaml-lacaml/Makefile
+++ b/devel/ocaml-lacaml/Makefile
@@ -30,6 +30,7 @@ WRKSRC= ${WRKDIR}/lacaml-${DISTNAME}
CFLAGS+= -fPIC
MAKE_ENV+= OCAMLMKLIB_FLAGS="-L${LOCALBASE}/lib"
+MAKE_JOBS_UNSAFE= yes
DOCS= README.txt TODO
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
diff --git a/devel/ocaml-res/Makefile b/devel/ocaml-res/Makefile
index 728447f8aa5d..2f2cff3897e1 100644
--- a/devel/ocaml-res/Makefile
+++ b/devel/ocaml-res/Makefile
@@ -22,6 +22,7 @@ USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
USE_OCAML_WASH= yes
+MAKE_JOBS_UNSAFE= yes
DOCS= README.txt
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
diff --git a/devel/ocaml-sem/Makefile b/devel/ocaml-sem/Makefile
index 5af256684d3e..6304c340f167 100644
--- a/devel/ocaml-sem/Makefile
+++ b/devel/ocaml-sem/Makefile
@@ -22,6 +22,7 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
MAKE_ENV= OCAML_LIB_INSTALL="${PREFIX}/lib/ocaml/site-lib/sem" \
INCDIRS="${LOCALBASE}/include" LIBDIRS="${LOCALBASE}/lib"
+MAKE_JOBS_UNSAFE= yes
.if !defined(WITH_CUSTOM)
MAKE_ENV+= NO_CUSTOM=y
diff --git a/devel/ocaml-sexplib/Makefile b/devel/ocaml-sexplib/Makefile
index 816fca26f7b8..2cc48e0e0d6d 100644
--- a/devel/ocaml-sexplib/Makefile
+++ b/devel/ocaml-sexplib/Makefile
@@ -23,6 +23,7 @@ RUN_DEPENDS= ${SA_DIR}/type-conv/pa_type_conv.cmi:${PORTSDIR}/devel/ocaml-typeco
USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
+MAKE_JOBS_UNSAFE= yes
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
diff --git a/devel/ocaml-xstrp4/Makefile b/devel/ocaml-xstrp4/Makefile
index 0833e74d5ef3..40b5a3231dce 100644
--- a/devel/ocaml-xstrp4/Makefile
+++ b/devel/ocaml-xstrp4/Makefile
@@ -20,6 +20,7 @@ USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
HAS_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
diff --git a/devel/ode-devel/Makefile b/devel/ode-devel/Makefile
index 9756942c28d4..da1908003e9f 100644
--- a/devel/ode-devel/Makefile
+++ b/devel/ode-devel/Makefile
@@ -22,6 +22,7 @@ CONFLICTS= ode-[0-9].*
USE_GL= yes
USE_GMAKE= yes
+MAKE_JOBS_UNSAFE= yes
OPTIONS= OPCODE "Enable code required by TriList (trimesh) class" on
diff --git a/devel/omake/Makefile b/devel/omake/Makefile
index f4d1ca859e05..2da49cb42a8d 100644
--- a/devel/omake/Makefile
+++ b/devel/omake/Makefile
@@ -19,6 +19,7 @@ COMMENT= A flexible build system
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_OCAML= yes
NO_OCAML_RUNDEPENDS=yes
+MAKE_JOBS_UNSAFE= yes
FETCH_CMD?= /usr/bin/fetch -Rr
diff --git a/devel/p5-Device-USB/Makefile b/devel/p5-Device-USB/Makefile
index 295fefef224a..82c7ad3ae037 100644
--- a/devel/p5-Device-USB/Makefile
+++ b/devel/p5-Device-USB/Makefile
@@ -21,6 +21,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline
WRKSRC= ${WRKDIR}/Device-USB-${PORTVERSION}
PERL_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
MAN3= Device::USB.3 \
Device::USB::Bus.3 \
diff --git a/devel/p5-Gnome2-GConf/Makefile b/devel/p5-Gnome2-GConf/Makefile
index d2a767c1d542..235bede09427 100644
--- a/devel/p5-Gnome2-GConf/Makefile
+++ b/devel/p5-Gnome2-GConf/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Glib.pm:${PORTSDIR}/devel/p5-Glib2
PERL_CONFIGURE= 5.8.0+
USE_GNOME= gconf2
+MAKE_JOBS_UNSAFE= yes
MAN3= Gnome2::GConf.3 \
Gnome2::GConf::ChangeSet.3 \
diff --git a/devel/p5-PAR-Packer/Makefile b/devel/p5-PAR-Packer/Makefile
index fc6bfd7ed79e..74a2b293c8f4 100644
--- a/devel/p5-PAR-Packer/Makefile
+++ b/devel/p5-PAR-Packer/Makefile
@@ -28,6 +28,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
CONFLICTS= sketchy-*
PERL_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
MAN1= par.pl.1 parl.1 pp.1 tkpp.1
MAN3= pp.3 \
diff --git a/devel/p5-usb/Makefile b/devel/p5-usb/Makefile
index 295fefef224a..82c7ad3ae037 100644
--- a/devel/p5-usb/Makefile
+++ b/devel/p5-usb/Makefile
@@ -21,6 +21,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline
WRKSRC= ${WRKDIR}/Device-USB-${PORTVERSION}
PERL_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
MAN3= Device::USB.3 \
Device::USB::Bus.3 \
diff --git a/devel/pdcurses-the/Makefile b/devel/pdcurses-the/Makefile
index d056c201e73e..93f3fc8c1ece 100644
--- a/devel/pdcurses-the/Makefile
+++ b/devel/pdcurses-the/Makefile
@@ -20,6 +20,7 @@ CONFLICTS= pdcurses-[0-9]*
USE_LDCONFIG= yes
USE_XORG= x11 xext sm ice xt xaw
GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
OPTIONS= DEBUG "Enable debugging support" off \
LATIN1 "Enable support for Latin1 keys" off \
diff --git a/devel/pthsem/Makefile b/devel/pthsem/Makefile
index 1eb8a0065a17..67b4f38c7514 100644
--- a/devel/pthsem/Makefile
+++ b/devel/pthsem/Makefile
@@ -20,4 +20,6 @@ USE_GMAKE= yes
MAN1= pthsem-config.1
MAN3= pthsem.3
+MAKE_JOBS_UNSAFE= yes
+
.include <bsd.port.mk>
diff --git a/devel/ptypes/Makefile b/devel/ptypes/Makefile
index 4c23e41a8780..7e57f0c962f4 100644
--- a/devel/ptypes/Makefile
+++ b/devel/ptypes/Makefile
@@ -19,6 +19,7 @@ SHLIB_VER= 21
USE_LDCONFIG= yes
PLIST_SUB+= SHLIB_VER=${SHLIB_VER}
PTYPES_CFLAGS= ${CFLAGS}
+MAKE_JOBS_UNSAFE= yes
OPTIONS= DEBUG "Build debug version" off \
OPTIMIZED "Enable -O2 optimization" off