aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-05-01 01:35:34 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-05-01 01:35:34 +0000
commit43e2b818e5e4d3f339c64a4768cfde2139b0f223 (patch)
treedf72b0e8c8145458a759d3f04e3208b4ca2bffea /devel
parentac456c5dd90c819317d52b550ce5ee6267999cd8 (diff)
downloadports-43e2b818e5e4d3f339c64a4768cfde2139b0f223.tar.gz
ports-43e2b818e5e4d3f339c64a4768cfde2139b0f223.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/gconf/Makefile2
-rw-r--r--devel/gconf/files/patch-configure21
-rw-r--r--devel/gconf/files/patch-ltmain.sh28
-rw-r--r--devel/gconf/pkg-plist2
4 files changed, 19 insertions, 34 deletions
diff --git a/devel/gconf/Makefile b/devel/gconf/Makefile
index fad2f9abef6d..bfdc8d203b91 100644
--- a/devel/gconf/Makefile
+++ b/devel/gconf/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOMELIBS= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/devel/gconf/files/patch-configure b/devel/gconf/files/patch-configure
index 1e91b12da41c..8dff658d87e8 100644
--- a/devel/gconf/files/patch-configure
+++ b/devel/gconf/files/patch-configure
@@ -1,7 +1,22 @@
---- configure.orig Mon Feb 11 15:20:43 2002
-+++ configure Mon Feb 11 15:22:24 2002
-@@ -8516,3 +8516,3 @@
+
+$FreeBSD$
+
+--- configure.orig Mon Apr 15 14:19:44 2002
++++ configure Wed May 1 03:03:18 2002
+@@ -6804,6 +6804,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -7945,7 +7946,7 @@
+ BDB_LIBS=
+ BDB_CFLAGS=
-for dblib in db-3.3 db-3.2 db-3.1 db-3; do
+for dblib in db-3.3 db-3.2 db-3.1 db-3 db3; do
as_ac_Lib=`echo "ac_cv_lib_$dblib''_db_env_create" | $as_tr_sh`
+ echo "$as_me:7950: checking for db_env_create in -l$dblib" >&5
+ echo $ECHO_N "checking for db_env_create in -l$dblib... $ECHO_C" >&6
diff --git a/devel/gconf/files/patch-ltmain.sh b/devel/gconf/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/devel/gconf/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/gconf/pkg-plist b/devel/gconf/pkg-plist
index 1bea775ff653..1194779e1795 100644
--- a/devel/gconf/pkg-plist
+++ b/devel/gconf/pkg-plist
@@ -15,9 +15,7 @@ include/gconf/1/gconf/gconf-listeners.h
include/gconf/1/gconf/gconf-schema.h
include/gconf/1/gconf/gconf-value.h
include/gconf/1/gconf/gconf.h
-lib/GConf/1/libgconfbackend-bdb.a
lib/GConf/1/libgconfbackend-bdb.so
-lib/GConf/1/libgconfbackend-xml.a
lib/GConf/1/libgconfbackend-xml.so
lib/libgconf-1.a
lib/libgconf-1.so