aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-04-03 03:48:30 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-04-03 03:48:30 +0000
commit4ae1d0173067c4c60b9b7bf11e99c430eaa1224e (patch)
tree10c937e1729276021f248b0a54ae4af69fdec553 /devel
parent88a41fc9c7afc0e153965abaad696bdbd85dbec3 (diff)
downloadports-4ae1d0173067c4c60b9b7bf11e99c430eaa1224e.tar.gz
ports-4ae1d0173067c4c60b9b7bf11e99c430eaa1224e.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/gettext/Makefile21
-rw-r--r--devel/gettext/files/patch-gettext-tools_Makefile.in2
-rw-r--r--devel/gettext/pkg-plist49
3 files changed, 21 insertions, 51 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index a09fd9c8a9bf..f65630ca1999 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -31,7 +31,8 @@ CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib \
--mandir=${PREFIX}/man
INSTALLS_SHLIB= yes
-OPTIONS= EXAMPLES "install example files" off
+OPTIONS= EXAMPLES "install example files" off \
+ HTMLMAN "install man pages in HTML format" off
PLIST= ${WRKDIR}/plist
PLISTU= ${WRKDIR}/plist-unsorted
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
@@ -74,6 +75,16 @@ post-build:
pre-install:
@${RM} -f ${PLISTU}
@${TOUCH} ${PLISTU}
+.if !defined (NOPORTDOCS)
+.for ii in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 foot toc
+ ${ECHO_CMD} %%DOCSDIR%%/gettext_${ii}.html >> ${PLISTU}
+.endfor
+.endif
+.if defined (WITH_HTMLMAN)
+.for ii in ${MAN1} ${MAN3}
+ ${ECHO_CMD} %%DOCSDIR%%/${ii}.html >> ${PLISTU}
+.endfor
+.endif
.if defined (WITH_EXAMPLES)
cd ${WRKSRC}/gettext-tools && \
${FIND} -s examples -type f | ${GREP} -vw examples/po | \
@@ -93,8 +104,16 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/gettext-tools/misc/${f} ${PREFIX}/share/emacs/site-lisp
.endfor
${MKDIR} ${X11BASE}/share/locale
+ cd ${WRKSRC}/gettext-tools/doc && make install-info-am
+.if !defined (NOPORTDOCS)
+ cd ${WRKSRC}/gettext-tools/doc && make install-data-local
+.endif
.if defined (WITH_EXAMPLES)
cd ${WRKSRC}/gettext-tools/examples && make install
.endif
+.if !defined (WITH_HTMLMAN)
+ cd ${WRKSRC}/gettext-runtime/man && make uninstall-html
+ cd ${WRKSRC}/gettext-tools/man && make uninstall-html
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/gettext/files/patch-gettext-tools_Makefile.in b/devel/gettext/files/patch-gettext-tools_Makefile.in
index 3d51cf752db3..7cbc7bb50d65 100644
--- a/devel/gettext/files/patch-gettext-tools_Makefile.in
+++ b/devel/gettext/files/patch-gettext-tools_Makefile.in
@@ -7,7 +7,7 @@ $FreeBSD$
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../config/m4
-SUBDIRS = doc intl lib libuniname src po projects misc man m4 tests examples
-+SUBDIRS = doc intl lib libuniname src po projects misc man m4
++SUBDIRS = intl lib libuniname src po projects misc man m4
# vms_jackets.h is a header that comes with Compaq's "porting library".
# KEEP_CRTL_SETLOCALE tells it to not override the native locale support.
diff --git a/devel/gettext/pkg-plist b/devel/gettext/pkg-plist
index b312d9a7d0d8..3710568682d5 100644
--- a/devel/gettext/pkg-plist
+++ b/devel/gettext/pkg-plist
@@ -68,42 +68,11 @@ share/aclocal/ulonglong.m4
share/aclocal/wchar_t.m4
share/aclocal/wint_t.m4
share/aclocal/xsize.m4
-%%DOCSDIR%%/autopoint.1.html
-%%DOCSDIR%%/bind_textdomain_codeset.3.html
-%%DOCSDIR%%/bindtextdomain.3.html
-%%DOCSDIR%%/envsubst.1.html
%%DOCSDIR%%/examples/config/gcj.m4
%%DOCSDIR%%/examples/config/javacomp.m4
%%DOCSDIR%%/examples/config/javacomp.sh.in
%%DOCSDIR%%/examples/config/javaexec.m4
%%DOCSDIR%%/examples/config/javaexec.sh.in
-%%DOCSDIR%%/gettext.1.html
-%%DOCSDIR%%/gettext.3.html
-%%DOCSDIR%%/gettext_1.html
-%%DOCSDIR%%/gettext_10.html
-%%DOCSDIR%%/gettext_11.html
-%%DOCSDIR%%/gettext_12.html
-%%DOCSDIR%%/gettext_13.html
-%%DOCSDIR%%/gettext_14.html
-%%DOCSDIR%%/gettext_15.html
-%%DOCSDIR%%/gettext_16.html
-%%DOCSDIR%%/gettext_17.html
-%%DOCSDIR%%/gettext_18.html
-%%DOCSDIR%%/gettext_19.html
-%%DOCSDIR%%/gettext_2.html
-%%DOCSDIR%%/gettext_20.html
-%%DOCSDIR%%/gettext_21.html
-%%DOCSDIR%%/gettext_22.html
-%%DOCSDIR%%/gettext_3.html
-%%DOCSDIR%%/gettext_4.html
-%%DOCSDIR%%/gettext_5.html
-%%DOCSDIR%%/gettext_6.html
-%%DOCSDIR%%/gettext_7.html
-%%DOCSDIR%%/gettext_8.html
-%%DOCSDIR%%/gettext_9.html
-%%DOCSDIR%%/gettext_foot.html
-%%DOCSDIR%%/gettext_toc.html
-%%DOCSDIR%%/gettextize.1.html
%%DOCSDIR%%/javadoc1/AllNames.html
%%DOCSDIR%%/javadoc1/gnu.gettext.GettextResource.html
%%DOCSDIR%%/javadoc1/images/blue-ball-small.gif
@@ -145,24 +114,6 @@ share/aclocal/xsize.m4
%%DOCSDIR%%/javadoc2/packages.html
%%DOCSDIR%%/javadoc2/serialized-form.html
%%DOCSDIR%%/javadoc2/stylesheet.css
-%%DOCSDIR%%/msgattrib.1.html
-%%DOCSDIR%%/msgcat.1.html
-%%DOCSDIR%%/msgcmp.1.html
-%%DOCSDIR%%/msgcomm.1.html
-%%DOCSDIR%%/msgconv.1.html
-%%DOCSDIR%%/msgen.1.html
-%%DOCSDIR%%/msgexec.1.html
-%%DOCSDIR%%/msgfilter.1.html
-%%DOCSDIR%%/msgfmt.1.html
-%%DOCSDIR%%/msggrep.1.html
-%%DOCSDIR%%/msginit.1.html
-%%DOCSDIR%%/msgmerge.1.html
-%%DOCSDIR%%/msgunfmt.1.html
-%%DOCSDIR%%/msguniq.1.html
-%%DOCSDIR%%/ngettext.1.html
-%%DOCSDIR%%/ngettext.3.html
-%%DOCSDIR%%/textdomain.3.html
-%%DOCSDIR%%/xgettext.1.html
share/doc/libasprintf/autosprintf.html
share/emacs/site-lisp/po-compat.el
share/emacs/site-lisp/po-mode.el