aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-15 10:12:08 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-15 10:12:08 +0000
commit581cac9416d38f70a9e5c680d9751230bd43cbc4 (patch)
tree4ec74f3dd744ca8054cce78df35237dd5b189528 /devel
parent2f26d37a5937d9b654ab7ef7fc9f16733f276fce (diff)
downloadports-581cac9416d38f70a9e5c680d9751230bd43cbc4.tar.gz
ports-581cac9416d38f70a9e5c680d9751230bd43cbc4.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/apr2/Makefile2
-rw-r--r--devel/bugzilla44/Makefile2
-rw-r--r--devel/bugzilla50/Makefile2
-rw-r--r--devel/gearmand-devel/Makefile2
-rw-r--r--devel/gearmand/Makefile2
-rw-r--r--devel/matreshka/Makefile2
-rw-r--r--devel/p5-Test-DBIx-Class/Makefile2
-rw-r--r--devel/sonarqube/Makefile2
-rw-r--r--devel/sope2/Makefile2
-rw-r--r--devel/sope3/Makefile2
-rw-r--r--devel/sope4/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 51a377cb6a76..94505e23bad9 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -58,7 +58,7 @@ IPV6_CONFIGURE_ENABLE= ipv6
MYSQL_CFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/mysql -DHAVE_MYSQL_H
MYSQL_CONFIGURE_WITH= mysql=${LOCALBASE}
MYSQL_LIBS= -L${LOCALBASE}/lib/mysql
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
NDBM_CONFIGURE_WITH= ndbm=/usr
PGSQL_CONFIGURE_ENV= ac_cv_path_PGSQL_CONFIG=""
PGSQL_CONFIGURE_WITH= pgsql=${LOCALBASE}
diff --git a/devel/bugzilla44/Makefile b/devel/bugzilla44/Makefile
index 383bc883b48e..e163773901da 100644
--- a/devel/bugzilla44/Makefile
+++ b/devel/bugzilla44/Makefile
@@ -46,7 +46,7 @@ EMPTY_DIRS_LIST=data graphs contrib lib t xt
.include "${.CURDIR}/Makefile.options"
MODPERL_USE= APACHE_RUN=22+
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_RUN_DEPENDS= p5-DBD-mysql>=4.0001:databases/p5-DBD-mysql
PGSQL_USES= pgsql
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=3.4.2:databases/p5-DBD-Pg
diff --git a/devel/bugzilla50/Makefile b/devel/bugzilla50/Makefile
index e5b762e78db4..f9ff9cff866c 100644
--- a/devel/bugzilla50/Makefile
+++ b/devel/bugzilla50/Makefile
@@ -48,7 +48,7 @@ EMPTY_DIRS_LIST=data graphs contrib lib t xt
.include "${.CURDIR}/Makefile.options"
MODPERL_USE= APACHE_RUN=22+
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
MYSQL_RUN_DEPENDS= p5-DBD-mysql>=4.0001:databases/p5-DBD-mysql
PGSQL_USES= pgsql:9.1+
PGSQL_RUN_DEPENDS= p5-DBD-Pg>=3.4.2:databases/p5-DBD-Pg
diff --git a/devel/gearmand-devel/Makefile b/devel/gearmand-devel/Makefile
index ee3f459db0ec..5eb8289944ab 100644
--- a/devel/gearmand-devel/Makefile
+++ b/devel/gearmand-devel/Makefile
@@ -75,7 +75,7 @@ CONFIGURE_ARGS+= --disable-libmemcached
.endif
.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
+USES+= mysql
CONFIGURE_ARGS+= --with-mysql=yes
.else
CONFIGURE_ARGS+= --with-mysql=no
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 9090958f9cfe..4f395be17891 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -74,7 +74,7 @@ CONFIGURE_ARGS+= --disable-libmemcached
.endif
.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
+USES+= mysql
CONFIGURE_ARGS+= --with-mysql=yes
.else
CONFIGURE_ARGS+= --with-mysql=no
diff --git a/devel/matreshka/Makefile b/devel/matreshka/Makefile
index 240a6d29f49e..8dfd29584fea 100644
--- a/devel/matreshka/Makefile
+++ b/devel/matreshka/Makefile
@@ -30,7 +30,7 @@ MYSQL_CONFIGURE_ENABLE= mysql
ORACLE_CONFIGURE_ENABLE= oracle
AMF_CONFIGURE_ENABLE= amf
-MYSQL_USE= MYSQL=yes
+MYSQL_USES= mysql
PGSQL_USES= pgsql
SQLITE3_USES= sqlite
FIREBIRD_USES= firebird
diff --git a/devel/p5-Test-DBIx-Class/Makefile b/devel/p5-Test-DBIx-Class/Makefile
index f8b5404cc071..55eff2a0b6aa 100644
--- a/devel/p5-Test-DBIx-Class/Makefile
+++ b/devel/p5-Test-DBIx-Class/Makefile
@@ -36,7 +36,7 @@ TEST_DEPENDS= p5-MooseX-Types-LoadableClass>=0:devel/p5-MooseX-Types-LoadableCla
p5-Test-Differences>=0:devel/p5-Test-Differences \
p5-Test-mysqld>=0:databases/p5-Test-mysqld
# Also for test:
-#USE_MYSQL+= server
+#USES+= mysql:server
NO_ARCH= yes
USES= perl5
diff --git a/devel/sonarqube/Makefile b/devel/sonarqube/Makefile
index 4e05176d0e31..cde4a4a0ef48 100644
--- a/devel/sonarqube/Makefile
+++ b/devel/sonarqube/Makefile
@@ -54,7 +54,7 @@ PLIST_SUB+= SQ_DB_DIR=${SQ_DB_DIR} \
OPTIONS_RADIO= SQL
OPTIONS_RADIO_SQL= MYSQL PGSQL
-MYSQL_USE= mysql=yes
+MYSQL_USES= mysql
PGSQL_USES= pgsql
post-patch:
diff --git a/devel/sope2/Makefile b/devel/sope2/Makefile
index 772b95e7eb6b..675b6129e2c3 100644
--- a/devel/sope2/Makefile
+++ b/devel/sope2/Makefile
@@ -41,7 +41,7 @@ CONFIGURE_ARGS= --with-gnustep --disable-debug --enable-strip
LDAP_USE= OPENLDAP=client
PGSQL_USES= pgsql
-MYSQL_USE= MYSQL=client
+MYSQL_USES= mysql
MEMCACHED_RUN_DEPENDS= ${LOCALBASE}/bin/memcached:databases/memcached
post-patch:
diff --git a/devel/sope3/Makefile b/devel/sope3/Makefile
index 8550b03fdafa..b0991c1cbb1f 100644
--- a/devel/sope3/Makefile
+++ b/devel/sope3/Makefile
@@ -44,7 +44,7 @@ CONFIGURE_ENV+= CC="${CC}"
LDAP_USE= OPENLDAP=client
PGSQL_USES= pgsql
-MYSQL_USE= MYSQL=client
+MYSQL_USES= mysql
MEMCACHED_RUN_DEPENDS= ${LOCALBASE}/bin/memcached:databases/memcached
post-patch:
diff --git a/devel/sope4/Makefile b/devel/sope4/Makefile
index 79f06ac665df..8ebb9e0e0092 100644
--- a/devel/sope4/Makefile
+++ b/devel/sope4/Makefile
@@ -42,7 +42,7 @@ CONFIGURE_ENV+= CC="${CC}"
LDAP_USE= OPENLDAP=client
PGSQL_USES= pgsql
-MYSQL_USE= MYSQL=client
+MYSQL_USES= mysql
MEMCACHED_RUN_DEPENDS= ${LOCALBASE}/bin/memcached:databases/memcached
post-patch: