aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2012-06-26 10:10:40 +0000
committerDima Panov <fluffy@FreeBSD.org>2012-06-26 10:10:40 +0000
commit59a6890bf5878296c9e0c09e30bdc90aec4fef47 (patch)
tree4cc80d1f25e355f44bc2750b8962ccfd67c8d129 /devel
parent4079c05aed888a48e5c3608c34ce9bb13a6b9cb1 (diff)
downloadports-59a6890bf5878296c9e0c09e30bdc90aec4fef47.tar.gz
ports-59a6890bf5878296c9e0c09e30bdc90aec4fef47.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm/Makefile35
-rw-r--r--devel/llvm/distinfo4
-rw-r--r--devel/llvm/files/patch-utils_llvm-build_llvmbuild_main.py20
-rw-r--r--devel/llvm/pkg-plist68
4 files changed, 93 insertions, 34 deletions
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index d2dc8fd4f4cc..938d1c86c8bc 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= llvm
-PORTVERSION= 3.0
+PORTVERSION= 3.1
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
+LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
-USE_PYTHON_BUILD= yes
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
.endif
.if defined(MAINTAINER_MODE)
@@ -23,17 +24,18 @@ BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
CONFLICTS= llvm-devel-[23]* llvm-etoile-2*
-WRKSRC= ${WRKDIR}/${DISTNAME}.src
-
GNU_CONFIGURE= yes
USE_GCC= 4.2+
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PERL5= yes
+USE_PYTHON_BUILD= yes
MAKE_JOBS_SAFE= yes
+# Suggested tweaks from http://llvm.org/docs/Packaging.html
CONFIGURE_ARGS+= --enable-shared
MAKE_ARGS+= REQUIRES_RTTI=1
+LIBNAME= libLLVM-${DISTVERSION:C/\.r[0-9]*//}.so
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
@@ -43,16 +45,19 @@ CONFIGURE_ARGS+= --enable-optimized
CONFIGURE_ARGS+= --enable-bindings=none
-OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off
+OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off \
+ LTOPLUGIN "Build LTO plugin (requires gold)" off
.if defined(NOPORTDOCS)
CONFIGURE_ARGS+= --disable-docs
.endif
-MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
- llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-diff.1 \
+MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
+ llvm-bcanalyzer.1 llvm-config.1 llvm-cov.1 llvm-diff.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
- llvm-prof.1 llvm-ranlib.1 opt.1 tblgen.1
+ llvm-prof.1 llvm-ranlib.1 llvm-stress.1 opt.1 tblgen.1
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
@@ -74,7 +79,12 @@ CONFIGURE_ARGS+= --enable-assertions
CONFIGURE_ARGS+= --disable-assertions
.endif
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+.ifdef(WITH_LTOPLUGIN)
+BUILD_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
+CONFIGURE_ARGS+= --with-binutils-include=${LOCALBASE}/include
+PLIST_FILES+= lib/LLVMgold.so
+.endif
post-patch:
${REINPLACE_CMD} -e 's|\(PROJ_docsdir.*:=\).*$$|\1${DOCSDIR}|g' \
@@ -85,15 +95,19 @@ post-patch:
.if defined(NOPORTDOCS)
post-build:
@cd ${WRKSRC}/docs/CommandGuide && ${GMAKE} ${MAN1}
+.endif
post-install:
+ ${MV} ${PREFIX}/lib/${LIBNAME} ${PREFIX}/lib/${LIBNAME}.0
+ ${LN} -s ${LIBNAME}.0 ${PREFIX}/lib/${LIBNAME}
+.if defined(NOPORTDOCS)
.for man in ${MAN1}
@${INSTALL_MAN} ${WRKSRC}/docs/CommandGuide/${man} \
${MANPREFIX}/man/man1/
.endfor
.endif
-TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check-local-lit)'
+TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} LD_LIBRARY_PATH=${WRKSRC}/Release/lib ${GMAKE} check-local-lit)'
regression-test: ${BUILD_COOKIE}
if [ `${ID} -u` = 0 ]; then \
${CHOWN} -R nobody ${WRKSRC}/test; \
@@ -110,7 +124,6 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/opt \
lib/BugpointPasses.so \
lib/LLVMHello.so \
- lib/libEnhancedDisassembly.a \
lib/libLTO.* \
lib/libLLVM* \
lib/libprofile_rt.a \
diff --git a/devel/llvm/distinfo b/devel/llvm/distinfo
index 6843ae4a2fa7..8b1fbc2b60e2 100644
--- a/devel/llvm/distinfo
+++ b/devel/llvm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (llvm-3.0.tar.gz) = 519eb11d3499ce99c6ffdb8718651fc91425ed7690eac91c8d6853474f7c0477
-SIZE (llvm-3.0.tar.gz) = 10350539
+SHA256 (llvm-3.1.src.tar.gz) = 1ea05135197b5400c1f88d00ff280d775ce778f8f9ea042e25a1e1e734a4b9ab
+SIZE (llvm-3.1.src.tar.gz) = 11077429
diff --git a/devel/llvm/files/patch-utils_llvm-build_llvmbuild_main.py b/devel/llvm/files/patch-utils_llvm-build_llvmbuild_main.py
new file mode 100644
index 000000000000..1e2de0273d55
--- /dev/null
+++ b/devel/llvm/files/patch-utils_llvm-build_llvmbuild_main.py
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- utils/llvm-build/llvmbuild/main.py.orig
++++ utils/llvm-build/llvmbuild/main.py
+@@ -633,7 +633,13 @@
+
+ # We handle a few special cases of target names here for historical
+ # reasons, as these are the names configure currently comes up with.
+- native_target_name = { 'x86' : 'X86',
++ native_target_name = { 'amd64' : 'X86',
++ 'arm' : 'ARM',
++ 'i386' : 'X86',
++ 'mips' : 'Mips',
++ 'powerpc' : 'PowerPC',
++ 'sparc64' : 'Sparc',
++ 'x86' : 'X86',
+ 'x86_64' : 'X86',
+ 'Unknown' : None }.get(opts.native_target,
+ opts.native_target)
diff --git a/devel/llvm/pkg-plist b/devel/llvm/pkg-plist
index 61f95517ceac..2f71babf1a5c 100644
--- a/devel/llvm/pkg-plist
+++ b/devel/llvm/pkg-plist
@@ -17,8 +17,10 @@ bin/llvm-nm
bin/llvm-objdump
bin/llvm-prof
bin/llvm-ranlib
+bin/llvm-readobj
bin/llvm-rtdyld
bin/llvm-size
+bin/llvm-stress
bin/llvm-stub
bin/llvm-tblgen
bin/macho-dump
@@ -34,9 +36,11 @@ include/llvm-c/Initialization.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm-c/Object.h
include/llvm-c/Target.h
+include/llvm-c/TargetMachine.h
include/llvm-c/Transforms/IPO.h
include/llvm-c/Transforms/PassManagerBuilder.h
include/llvm-c/Transforms/Scalar.h
+include/llvm-c/Transforms/Vectorize.h
include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
@@ -52,6 +56,7 @@ include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
+include/llvm/ADT/Hashing.h
include/llvm/ADT/ImmutableIntervalMap.h
include/llvm/ADT/ImmutableList.h
include/llvm/ADT/ImmutableMap.h
@@ -80,6 +85,7 @@ include/llvm/ADT/SmallSet.h
include/llvm/ADT/SmallString.h
include/llvm/ADT/SmallVector.h
include/llvm/ADT/SparseBitVector.h
+include/llvm/ADT/SparseSet.h
include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
@@ -92,7 +98,8 @@ include/llvm/ADT/Triple.h
include/llvm/ADT/Twine.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/ValueMap.h
-include/llvm/ADT/VectorExtras.h
+include/llvm/ADT/VariadicFunction.h
+include/llvm/ADT/edit_distance.h
include/llvm/ADT/ilist.h
include/llvm/ADT/ilist_node.h
include/llvm/Analysis/AliasAnalysis.h
@@ -169,9 +176,9 @@ include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/Analysis.h
include/llvm/CodeGen/AsmPrinter.h
-include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/DFAPacketizer.h
include/llvm/CodeGen/EdgeBundles.h
include/llvm/CodeGen/FastISel.h
include/llvm/CodeGen/FunctionLoweringInfo.h
@@ -188,6 +195,7 @@ include/llvm/CodeGen/LinkAllAsmWriterComponents.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
include/llvm/CodeGen/LiveIntervalAnalysis.h
+include/llvm/CodeGen/LiveRangeEdit.h
include/llvm/CodeGen/LiveStackAnalysis.h
include/llvm/CodeGen/LiveVariables.h
include/llvm/CodeGen/MachORelocation.h
@@ -204,6 +212,7 @@ include/llvm/CodeGen/MachineFunctionAnalysis.h
include/llvm/CodeGen/MachineFunctionPass.h
include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
+include/llvm/CodeGen/MachineInstrBundle.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLoopInfo.h
include/llvm/CodeGen/MachineLoopRanges.h
@@ -215,7 +224,7 @@ include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/MachineSSAUpdater.h
-include/llvm/CodeGen/ObjectCodeEmitter.h
+include/llvm/CodeGen/MachineScheduler.h
include/llvm/CodeGen/PBQP/Graph.h
include/llvm/CodeGen/PBQP/HeuristicBase.h
include/llvm/CodeGen/PBQP/HeuristicSolver.h
@@ -228,8 +237,10 @@ include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocPBQP.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterScavenging.h
+include/llvm/CodeGen/ResourcePriorityQueue.h
include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/ScheduleDAG.h
+include/llvm/CodeGen/ScheduleDAGInstrs.h
include/llvm/CodeGen/ScheduleHazardRecognizer.h
include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/ScoreboardHazardRecognizer.h
@@ -249,16 +260,17 @@ include/llvm/Config/llvm-config.h
include/llvm/Constant.h
include/llvm/Constants.h
include/llvm/DebugInfo/DIContext.h
-include/llvm/DebugInfoProbe.h
include/llvm/DefaultPasses.h
include/llvm/DerivedTypes.h
include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
+include/llvm/ExecutionEngine/IntelJITEventsWrapper.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
include/llvm/ExecutionEngine/JITEventListener.h
include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/ExecutionEngine/MCJIT.h
+include/llvm/ExecutionEngine/OProfileWrapper.h
include/llvm/ExecutionEngine/RuntimeDyld.h
include/llvm/Function.h
include/llvm/GVMaterializer.h
@@ -276,8 +288,8 @@ include/llvm/Intrinsics.gen
include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
include/llvm/IntrinsicsARM.td
-include/llvm/IntrinsicsAlpha.td
include/llvm/IntrinsicsCellSPU.td
+include/llvm/IntrinsicsHexagon.td
include/llvm/IntrinsicsPTX.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
@@ -336,6 +348,7 @@ include/llvm/MC/MCTargetAsmLexer.h
include/llvm/MC/MCTargetAsmParser.h
include/llvm/MC/MCValue.h
include/llvm/MC/MCWin64EH.h
+include/llvm/MC/MCWinCOFFObjectWriter.h
include/llvm/MC/MachineLocation.h
include/llvm/MC/SectionKind.h
include/llvm/MC/SubtargetFeature.h
@@ -344,6 +357,7 @@ include/llvm/Module.h
include/llvm/Object/Archive.h
include/llvm/Object/Binary.h
include/llvm/Object/COFF.h
+include/llvm/Object/ELF.h
include/llvm/Object/Error.h
include/llvm/Object/MachO.h
include/llvm/Object/MachOFormat.h
@@ -377,6 +391,7 @@ include/llvm/Support/CrashRecoveryContext.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataExtractor.h
include/llvm/Support/DataFlow.h
+include/llvm/Support/DataStream.h
include/llvm/Support/DataTypes.h
include/llvm/Support/Debug.h
include/llvm/Support/DebugLoc.h
@@ -403,6 +418,9 @@ include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
include/llvm/Support/LICENSE.TXT
include/llvm/Support/LeakDetector.h
+include/llvm/Support/Locale.h
+include/llvm/Support/LockFileManager.h
+include/llvm/Support/MDBuilder.h
include/llvm/Support/MachO.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/MathExtras.h
@@ -431,9 +449,11 @@ include/llvm/Support/Regex.h
include/llvm/Support/Registry.h
include/llvm/Support/RegistryParser.h
include/llvm/Support/SMLoc.h
+include/llvm/Support/SaveAndRestore.h
include/llvm/Support/Signals.h
include/llvm/Support/Solaris.h
include/llvm/Support/SourceMgr.h
+include/llvm/Support/StreamableMemoryObject.h
include/llvm/Support/StringPool.h
include/llvm/Support/SwapByteOrder.h
include/llvm/Support/SystemUtils.h
@@ -449,6 +469,7 @@ include/llvm/Support/TypeBuilder.h
include/llvm/Support/Valgrind.h
include/llvm/Support/ValueHandle.h
include/llvm/Support/Win64EH.h
+include/llvm/Support/YAMLParser.h
include/llvm/Support/circular_raw_ostream.h
include/llvm/Support/raw_os_ostream.h
include/llvm/Support/raw_ostream.h
@@ -488,11 +509,12 @@ include/llvm/Transforms/Instrumentation.h
include/llvm/Transforms/Scalar.h
include/llvm/Transforms/Utils/AddrModeMatcher.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
-include/llvm/Transforms/Utils/BasicInliner.h
include/llvm/Transforms/Utils/BuildLibCalls.h
include/llvm/Transforms/Utils/Cloning.h
+include/llvm/Transforms/Utils/CmpInstAnalysis.h
include/llvm/Transforms/Utils/FunctionUtils.h
include/llvm/Transforms/Utils/Local.h
+include/llvm/Transforms/Utils/ModuleUtils.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/SSAUpdater.h
include/llvm/Transforms/Utils/SSAUpdaterImpl.h
@@ -500,6 +522,7 @@ include/llvm/Transforms/Utils/SimplifyIndVar.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
include/llvm/Transforms/Utils/ValueMapper.h
+include/llvm/Transforms/Vectorize.h
include/llvm/Type.h
include/llvm/Use.h
include/llvm/User.h
@@ -507,37 +530,33 @@ include/llvm/Value.h
include/llvm/ValueSymbolTable.h
lib/BugpointPasses.so
lib/LLVMHello.so
-lib/libEnhancedDisassembly.a
lib/libLLVM-%%PORTVERSION%%.so
+lib/libLLVM-%%PORTVERSION%%.so.0
lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
lib/libLLVMARMDesc.a
lib/libLLVMARMDisassembler.a
lib/libLLVMARMInfo.a
-lib/libLLVMAlphaCodeGen.a
-lib/libLLVMAlphaDesc.a
-lib/libLLVMAlphaInfo.a
lib/libLLVMAnalysis.a
lib/libLLVMArchive.a
lib/libLLVMAsmParser.a
lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
-lib/libLLVMBlackfinCodeGen.a
-lib/libLLVMBlackfinDesc.a
-lib/libLLVMBlackfinInfo.a
-lib/libLLVMCBackend.a
-lib/libLLVMCBackendInfo.a
lib/libLLVMCellSPUCodeGen.a
lib/libLLVMCellSPUDesc.a
lib/libLLVMCellSPUInfo.a
lib/libLLVMCodeGen.a
lib/libLLVMCore.a
-lib/libLLVMCppBackend.a
+lib/libLLVMCppBackendCodeGen.a
lib/libLLVMCppBackendInfo.a
lib/libLLVMDebugInfo.a
lib/libLLVMExecutionEngine.a
+lib/libLLVMHexagonAsmPrinter.a
+lib/libLLVMHexagonCodeGen.a
+lib/libLLVMHexagonDesc.a
+lib/libLLVMHexagonInfo.a
lib/libLLVMInstCombine.a
lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
@@ -557,9 +576,11 @@ lib/libLLVMMSP430AsmPrinter.a
lib/libLLVMMSP430CodeGen.a
lib/libLLVMMSP430Desc.a
lib/libLLVMMSP430Info.a
+lib/libLLVMMipsAsmParser.a
lib/libLLVMMipsAsmPrinter.a
lib/libLLVMMipsCodeGen.a
lib/libLLVMMipsDesc.a
+lib/libLLVMMipsDisassembler.a
lib/libLLVMMipsInfo.a
lib/libLLVMObject.a
lib/libLLVMPTXAsmPrinter.a
@@ -577,12 +598,10 @@ lib/libLLVMSparcCodeGen.a
lib/libLLVMSparcDesc.a
lib/libLLVMSparcInfo.a
lib/libLLVMSupport.a
-lib/libLLVMSystemZCodeGen.a
-lib/libLLVMSystemZDesc.a
-lib/libLLVMSystemZInfo.a
lib/libLLVMTableGen.a
lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
+lib/libLLVMVectorize.a
lib/libLLVMX86AsmParser.a
lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
@@ -605,7 +624,6 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/BitCodeFormat.html
%%PORTDOCS%%%%DOCSDIR%%/html/BranchWeightMetadata.html
%%PORTDOCS%%%%DOCSDIR%%/html/Bugpoint.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CFEBuildInstrs.html
%%PORTDOCS%%%%DOCSDIR%%/html/CMake.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodeGenerator.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodingStandards.html
@@ -618,7 +636,9 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-as.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-build.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-config.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-cov.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-diff.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
@@ -627,6 +647,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-stress.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/manpage.css
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/opt.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/tblgen.html
@@ -643,8 +664,10 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStarted.html
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.html
%%PORTDOCS%%%%DOCSDIR%%/html/GoldPlugin.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToAddABuilder.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToReleaseLLVM.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToSubmitABug.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LLVMBuild.html
%%PORTDOCS%%%%DOCSDIR%%/html/LangRef.html
%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.html
%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.html
@@ -658,8 +681,8 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/SourceLevelDebugging.html
%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.html
%%PORTDOCS%%%%DOCSDIR%%/html/TableGenFundamentals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/TestSuiteMakefileGuide.html
%%PORTDOCS%%%%DOCSDIR%%/html/TestingGuide.html
-%%PORTDOCS%%%%DOCSDIR%%/html/UsingLibraries.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMBackend.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMPass.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
@@ -696,7 +719,9 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ar.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-as.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
+%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-build.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-config.ps
+%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-cov.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-diff.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-dis.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-extract.ps
@@ -705,6 +730,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-nm.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-prof.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ranlib.ps
+%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-stress.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/opt.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/tblgen.ps
@dirrm include/llvm/Transforms/Utils