aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-07-22 16:27:32 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-07-22 16:27:32 +0000
commit617c27f1d801eff128a8368c48ae9a1c9f666a9b (patch)
treea2a64d9960c6159a2699f7f1f660ddd2c0e55cfe /devel
parent7896d32d45f968e6b190717858d5ef1b001c19d2 (diff)
downloadports-617c27f1d801eff128a8368c48ae9a1c9f666a9b.tar.gz
ports-617c27f1d801eff128a8368c48ae9a1c9f666a9b.zip
MFH: r542660 r542869
devel/nasm: Update to 2.15.03 Update devel/nasm to 2.15.03 Add a patch to fix nasm's ELF_OSABI field when emitting object files [1] Changelog: https://nasm.us/doc/nasmdocc.html PR: 245069 [1] Submitted by: dim [1] Reported by: unitrunker gmail com [1] devel/nasm: Update to 2.15.03 Update devel/nasm to 2.15.03 Changelog: https://nasm.us/doc/nasmdocc.html Approved by: ports-secteam (joenum)
Notes
Notes: svn path=/branches/2020Q3/; revision=542873
Diffstat (limited to 'devel')
-rw-r--r--devel/nasm/Makefile2
-rw-r--r--devel/nasm/distinfo10
-rw-r--r--devel/nasm/files/patch-output_outelf.c11
3 files changed, 17 insertions, 6 deletions
diff --git a/devel/nasm/Makefile b/devel/nasm/Makefile
index d168198a402f..58c130da3c9a 100644
--- a/devel/nasm/Makefile
+++ b/devel/nasm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nasm
-PORTVERSION= 2.14.02
+PORTVERSION= 2.15.03
PORTEPOCH= 1
CATEGORIES= devel lang
MASTER_SITES= https://www.nasm.us/pub/nasm/releasebuilds/${PORTVERSION}/ \
diff --git a/devel/nasm/distinfo b/devel/nasm/distinfo
index d4562e661b66..05b423ee1fea 100644
--- a/devel/nasm/distinfo
+++ b/devel/nasm/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1546207834
-SHA256 (nasm-2.14.02.tar.xz) = e24ade3e928f7253aa8c14aa44726d1edf3f98643f87c9d72ec1df44b26be8f5
-SIZE (nasm-2.14.02.tar.xz) = 827620
-SHA256 (nasm-2.14.02-xdoc.tar.xz) = 5bc115e176521066f2c0678e784103817cb5767f317fdeae2ebf9416f8e893a5
-SIZE (nasm-2.14.02-xdoc.tar.xz) = 742792
+TIMESTAMP = 1595320310
+SHA256 (nasm-2.15.03.tar.xz) = c0c39a305f08ccf0c5c6edba4294dd2851b3925b6d9642dd1efd62f72829822f
+SIZE (nasm-2.15.03.tar.xz) = 984060
+SHA256 (nasm-2.15.03-xdoc.tar.xz) = b146a1983fad94690286d01b80024b80b87dff373bc6d7c8c60d65732669cd77
+SIZE (nasm-2.15.03-xdoc.tar.xz) = 816872
diff --git a/devel/nasm/files/patch-output_outelf.c b/devel/nasm/files/patch-output_outelf.c
new file mode 100644
index 000000000000..1a5d697b6a6a
--- /dev/null
+++ b/devel/nasm/files/patch-output_outelf.c
@@ -0,0 +1,11 @@
+--- output/outelf.c.orig 2020-07-02 04:44:07 UTC
++++ output/outelf.c
+@@ -248,7 +248,7 @@ static int32_t elf_gotpc_sect, elf_gotoff_sect;
+ static int32_t elf_got_sect, elf_plt_sect;
+ static int32_t elf_sym_sect, elf_gottpoff_sect, elf_tlsie_sect;
+
+-uint8_t elf_osabi = 0; /* Default OSABI = 0 (System V or Linux) */
++uint8_t elf_osabi = 9; /* Default OSABI = 9 (FreeBSD) */
+ uint8_t elf_abiver = 0; /* Current ABI version */
+
+ /* Known sections with nonstandard defaults. -n means n*pointer size. */