aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-17 13:19:01 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-17 13:19:01 +0000
commit76e9fbb7fc1c715d5269422ca95955a478be0310 (patch)
tree72701c54c92eba320ea9e10a852f4fb0ba28f9fb /devel
parentaea9b11b834ba5c599034e2bb9894b4fa1303edc (diff)
downloadports-76e9fbb7fc1c715d5269422ca95955a478be0310.tar.gz
ports-76e9fbb7fc1c715d5269422ca95955a478be0310.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Object-InsideOut/Makefile32
-rw-r--r--devel/p5-Object-InsideOut/distinfo3
-rw-r--r--devel/p5-Object-InsideOut/pkg-descr11
-rw-r--r--devel/p5-Object-InsideOut/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cddfd5c3fb7f..0506c8fca031 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1042,6 +1042,7 @@
SUBDIR += p5-OOTools
SUBDIR += p5-ORBit
SUBDIR += p5-Object-Accessor
+ SUBDIR += p5-Object-InsideOut
SUBDIR += p5-Object-MultiType
SUBDIR += p5-Object-Realize-Later
SUBDIR += p5-Object-Signature
diff --git a/devel/p5-Object-InsideOut/Makefile b/devel/p5-Object-InsideOut/Makefile
new file mode 100644
index 000000000000..421703557f38
--- /dev/null
+++ b/devel/p5-Object-InsideOut/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: devel/p5-Object-InsideOut
+# Date created: 15 January 2006
+# Whom: Geraud Continsouzas <geraud@gcu.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Object-InsideOut
+PORTVERSION= 1.31
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Object
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= geraud@gcu.info
+COMMENT= Object::InsideOut - Comprehensive inside-out object support module
+
+BUILD_DEPENDS= p5-Exception-Class>=1.22:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-Test-Simple>=0.50:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Object::InsideOut.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Object-InsideOut/distinfo b/devel/p5-Object-InsideOut/distinfo
new file mode 100644
index 000000000000..c9bc44e71904
--- /dev/null
+++ b/devel/p5-Object-InsideOut/distinfo
@@ -0,0 +1,3 @@
+MD5 (Object-InsideOut-1.31.tar.gz) = c49988f4c6140399a828344f97e63ca6
+SHA256 (Object-InsideOut-1.31.tar.gz) = e57cc680b87074ee07be5bfddc38239741530d0193ab1127c701df1efae1ea6c
+SIZE (Object-InsideOut-1.31.tar.gz) = 56085
diff --git a/devel/p5-Object-InsideOut/pkg-descr b/devel/p5-Object-InsideOut/pkg-descr
new file mode 100644
index 000000000000..7081c450d105
--- /dev/null
+++ b/devel/p5-Object-InsideOut/pkg-descr
@@ -0,0 +1,11 @@
+Object::InsideOut provides comprehensive support for implementing classes
+using the inside-out object model.
+
+This module implements inside-out objects as anonymous scalar references that
+are blessed into a class with the scalar containing the ID for the object
+(usually a sequence number). For Perl 5.8.3 and later, the scalar reference is
+set as readonly to prevent accidental modifications to the ID. Object data
+(i.e., fields) are stored within the class's package in either arrays indexed
+by the object's ID, or hashes keyed to the object's ID.
+
+WWW: http://search.cpan.org/dist/Object-InsideOut/
diff --git a/devel/p5-Object-InsideOut/pkg-plist b/devel/p5-Object-InsideOut/pkg-plist
new file mode 100644
index 000000000000..27c312935acf
--- /dev/null
+++ b/devel/p5-Object-InsideOut/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/InsideOut/.packlist
+%%SITE_PERL%%/Object/InsideOut.pm
+%%SITE_PERL%%/Object/InsideOut/Results.pm
+%%SITE_PERL%%/Object/InsideOut/Util.pm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/InsideOut 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Object 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Object/InsideOut 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Object 2>/dev/null || true