aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-07 08:32:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-07 08:32:09 +0000
commit831a4ed8b838c42ce435996179158443a696394b (patch)
tree4a1c1f59b7e5d9af6b28dbaed79aa48e642b5ef7 /devel
parent7006cc81dcca32627f4cb3e57c5491aa9c43315b (diff)
downloadports-831a4ed8b838c42ce435996179158443a696394b.tar.gz
ports-831a4ed8b838c42ce435996179158443a696394b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/itext/Makefile32
-rw-r--r--devel/itext/distinfo2
-rw-r--r--devel/itext/pkg-descr9
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3833dea3af95..543cb91d0e19 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -333,6 +333,7 @@
SUBDIR += initutil
SUBDIR += invitation_to_ruby
SUBDIR += ipython
+ SUBDIR += itext
SUBDIR += ixlib
SUBDIR += jakelib2
SUBDIR += jam
diff --git a/devel/itext/Makefile b/devel/itext/Makefile
new file mode 100644
index 000000000000..ec0449c672c7
--- /dev/null
+++ b/devel/itext/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: itext
+# Date created: Apr 2, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= itext
+PORTVERSION= 1.02b
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .jar
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Java-PDF Library
+
+USE_JAVA= 1.2+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+
+PLIST_FILES= ${JAVAJARDIR:S,^${PREFIX}/,,}/${PORTNAME}.jar
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${DISTFILES} ${JAVAJARDIR}/${PORTNAME}.jar
+
+.include <bsd.port.mk>
diff --git a/devel/itext/distinfo b/devel/itext/distinfo
new file mode 100644
index 000000000000..776c738b18b6
--- /dev/null
+++ b/devel/itext/distinfo
@@ -0,0 +1,2 @@
+MD5 (itext-1.02b.jar) = fa434e705a0385bbaec4d55c45a8606b
+SIZE (itext-1.02b.jar) = 766153
diff --git a/devel/itext/pkg-descr b/devel/itext/pkg-descr
new file mode 100644
index 000000000000..ead87ae31be6
--- /dev/null
+++ b/devel/itext/pkg-descr
@@ -0,0 +1,9 @@
+iText is a library that allows you to generate PDF files on the fly.
+
+The iText classes are very useful for people who need to generate read-only,
+platform independent documents containing text, lists, tables and images.
+The library is especially useful in combination with Java(TM) technology-based
+Servlets: The look and feel of HTML is browser dependent; with iText and PDF
+you can control exactly how your servlet's output will look.
+
+WWW: http://www.lowagie.com/iText/