aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-06 12:44:21 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-06 12:44:21 +0000
commit89e9641a419a5dfa13c8e65308721a08b12f5de9 (patch)
treecb91f7cf64fd028ba1d7668f9fb4e20339f4e262 /devel
parentc2d4004c759bf31e2f151fed2eb514b6a8bbda4d (diff)
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Format-Strptime/Makefile28
-rw-r--r--devel/p5-DateTime-Format-Strptime/distinfo1
-rw-r--r--devel/p5-DateTime-Format-Strptime/pkg-descr6
-rw-r--r--devel/p5-DateTime-Format-Strptime/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b01eb7a562db..8ed7b0e88125 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -555,6 +555,7 @@
SUBDIR += p5-DateTime-Event-Recurrence
SUBDIR += p5-DateTime-Event-Sunrise
SUBDIR += p5-DateTime-Format-Baby
+ SUBDIR += p5-DateTime-Format-Strptime
SUBDIR += p5-DateTime-LeapSecond
SUBDIR += p5-DateTime-Precise
SUBDIR += p5-DateTime-Set
diff --git a/devel/p5-DateTime-Format-Strptime/Makefile b/devel/p5-DateTime-Format-Strptime/Makefile
new file mode 100644
index 000000000000..4bce5dea6def
--- /dev/null
+++ b/devel/p5-DateTime-Format-Strptime/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-DateTime-Format-Strptime
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-Strptime
+PORTVERSION= 1.0302
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Parse and format strp and strf time patterns
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/02//}
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::Strptime.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-Strptime/distinfo b/devel/p5-DateTime-Format-Strptime/distinfo
new file mode 100644
index 000000000000..2fceab886f53
--- /dev/null
+++ b/devel/p5-DateTime-Format-Strptime/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-Strptime-1.0302.tar.gz) = 7ebd0bc7de54e10be967e29b04e0edf0
diff --git a/devel/p5-DateTime-Format-Strptime/pkg-descr b/devel/p5-DateTime-Format-Strptime/pkg-descr
new file mode 100644
index 000000000000..be3d4c614413
--- /dev/null
+++ b/devel/p5-DateTime-Format-Strptime/pkg-descr
@@ -0,0 +1,6 @@
+This module implements most of strptime(3), the POSIX function that is the
+reverse of strftime(3), for DateTime. While strftime takes a DateTime and a
+pattern and returns a string, strptime takes a string and a pattern and returns
+the DateTime object associated.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-Strptime/pkg-plist b/devel/p5-DateTime-Format-Strptime/pkg-plist
new file mode 100644
index 000000000000..f2670cfe44aa
--- /dev/null
+++ b/devel/p5-DateTime-Format-Strptime/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Format/Strptime.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Strptime/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Strptime
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true