aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-09 12:18:16 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-09 12:18:16 +0000
commit99e97b4601a73b660565a1ee9e2867b30de9858d (patch)
tree84afcccbf20a676c13be40bd1456300248927517 /devel
parentfb1833c45f0efd9bd735c5f882c7e022735489b5 (diff)
downloadports-99e97b4601a73b660565a1ee9e2867b30de9858d.tar.gz
ports-99e97b4601a73b660565a1ee9e2867b30de9858d.zip
MFH: r544563
devel/py-grpcio: fix build on powerpc(64) Some mingling with headers is required to build abseil properly. BoringSSL doesn't support powerpc and powerpc64 at all, only powerpc64le (ppc64le) is supported, so use system OpenSSL. BoringSSL is used because ALPN support is required, but it was implemented back in OpenSSL 1.0.2, which even stable/11 branch has. There's no need to use external SSL library at all. Bump PORTREVISION because of package change. PR: 248550 Approved by: vanilla (maintainer) Approved by: portmgr (fix build blanket)
Notes
Notes: svn path=/branches/2020Q3/; revision=544564
Diffstat (limited to 'devel')
-rw-r--r--devel/py-grpcio/Makefile7
-rw-r--r--devel/py-grpcio/files/patch-third__party_abseil-cpp_absl_base_internal_unscaledcycleclock.cc14
2 files changed, 17 insertions, 4 deletions
diff --git a/devel/py-grpcio/Makefile b/devel/py-grpcio/Makefile
index 0f03e22cfd17..48e491f65f99 100644
--- a/devel/py-grpcio/Makefile
+++ b/devel/py-grpcio/Makefile
@@ -3,6 +3,7 @@
PORTNAME= grpcio
PORTVERSION= 1.30.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,11 +21,9 @@ LIB_DEPENDS= libcares.so:dns/c-ares
USES= compiler:c++11-lib localbase:ldflags python:3.5+
USE_PYTHON= autoplist distutils
-MAKE_ENV+= GRPC_PYTHON_BUILD_SYSTEM_ZLIB=true \
+MAKE_ENV+= GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=true \
+ GRPC_PYTHON_BUILD_SYSTEM_ZLIB=true \
GRPC_PYTHON_BUILD_SYSTEM_CARES=true
-CFLAGS+= -Ithird_party/boringssl/include
-CFLAGS_powerpc64= -maltivec -mvsx
-CFLAGS_powerpc= -maltivec
LDFLAGS+= -lcares
post-install:
diff --git a/devel/py-grpcio/files/patch-third__party_abseil-cpp_absl_base_internal_unscaledcycleclock.cc b/devel/py-grpcio/files/patch-third__party_abseil-cpp_absl_base_internal_unscaledcycleclock.cc
new file mode 100644
index 000000000000..5d806419494c
--- /dev/null
+++ b/devel/py-grpcio/files/patch-third__party_abseil-cpp_absl_base_internal_unscaledcycleclock.cc
@@ -0,0 +1,14 @@
+--- third_party/abseil-cpp/absl/base/internal/unscaledcycleclock.cc.orig 2020-08-08 21:50:49 UTC
++++ third_party/abseil-cpp/absl/base/internal/unscaledcycleclock.cc
+@@ -24,8 +24,10 @@
+ #ifdef __GLIBC__
+ #include <sys/platform/ppc.h>
+ #elif defined(__FreeBSD__)
+-#include <sys/sysctl.h>
++#include "absl/base/call_once.h"
+ #include <sys/types.h>
++#include <sys/sysctl.h>
++#include <threads.h>
+ #endif
+ #endif
+