aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-08-30 13:55:36 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-08-30 13:55:36 +0000
commita2d0d7a6ca4f1d16db2f06c85a8560b7829905c2 (patch)
tree3d890f2b0f74b3915fcf7c33944d34ba745102be /devel
parent6ea6abb085306130d950b9095ea4e99a3190cb3c (diff)
downloadports-a2d0d7a6ca4f1d16db2f06c85a8560b7829905c2.tar.gz
ports-a2d0d7a6ca4f1d16db2f06c85a8560b7829905c2.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/popt/Makefile21
-rw-r--r--devel/popt/distinfo6
-rw-r--r--devel/popt/files/patch-Makefile.in26
-rw-r--r--devel/popt/files/patch-configure8
-rw-r--r--devel/popt/files/patch-popt.36
-rw-r--r--devel/popt/files/patch-popt.c4
-rw-r--r--devel/popt/pkg-plist5
7 files changed, 39 insertions, 37 deletions
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
index 01f9ae3544a5..6e8c549c955b 100644
--- a/devel/popt/Makefile
+++ b/devel/popt/Makefile
@@ -6,22 +6,21 @@
#
PORTNAME= popt
-PORTVERSION= 1.14
-PORTREVISION= 1
+PORTVERSION= 1.16
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.sunfreeware.com/pub/freeware/SOURCES/
-MASTER_SITE_SUBDIR= rpm-4.1.x
+MASTER_SITES= http://rpm5.org/files/popt/
MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= A getopt(3) like library with a number of enhancements, from Redhat
-GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--program-prefix=""
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-
+GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:22
+USE_GNOME= gnomehack
+USE_ICONV= yes
USE_LDCONFIG= yes
MAN3= popt.3
@@ -30,15 +29,9 @@ MAN3= popt.3
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
-# gettext 0.13 or higher
-USE_GETTEXT= [^0-5]
+CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
.endif
-pre-configure:
-# remove check for xgettext - popt do not use it anyway
- @${REINPLACE_CMD} -e \
- 's:if test ! -f ../rpm.c:if test "1" != "1":' \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/popt/distinfo b/devel/popt/distinfo
index 910b9b7467e2..13a7e8e461ef 100644
--- a/devel/popt/distinfo
+++ b/devel/popt/distinfo
@@ -1,3 +1,3 @@
-MD5 (popt-1.14.tar.gz) = 4f90a07316eb825604dd10ae4f9f3f04
-SHA256 (popt-1.14.tar.gz) = 175be17571e9af3ad622531b494a0738ae632c60c8c6329273778b2b6fbbad74
-SIZE (popt-1.14.tar.gz) = 695557
+MD5 (popt-1.16.tar.gz) = 3743beefa3dd6247a73f8f7a32c14c33
+SHA256 (popt-1.16.tar.gz) = e728ed296fe9f069a0e005003c3d6b2dde3d9cad453422a10d6558616d304cc8
+SIZE (popt-1.16.tar.gz) = 702769
diff --git a/devel/popt/files/patch-Makefile.in b/devel/popt/files/patch-Makefile.in
index 6f0839ebec83..8be125d04c92 100644
--- a/devel/popt/files/patch-Makefile.in
+++ b/devel/popt/files/patch-Makefile.in
@@ -1,15 +1,15 @@
---- Makefile.in.old 2009-05-07 15:17:31.000000000 -0500
-+++ Makefile.in 2009-05-07 15:21:28.000000000 -0500
-@@ -70,7 +70,7 @@
- "$(DESTDIR)$(includedir)"
- usrlibLTLIBRARIES_INSTALL = $(INSTALL)
+--- Makefile.in.orig 2010-05-05 04:55:59.000000000 +0800
++++ Makefile.in 2010-06-16 00:29:47.000000000 +0800
+@@ -92,7 +92,7 @@
+ am__installdirs = "$(DESTDIR)$(usrlibdir)" "$(DESTDIR)$(man3dir)" \
+ "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(includedir)"
LTLIBRARIES = $(usrlib_LTLIBRARIES)
-libpopt_la_LIBADD =
+libpopt_la_LIBADD = $(LTLIBINTL)
am_libpopt_la_OBJECTS = popt.lo poptparse.lo poptconfig.lo popthelp.lo \
poptint.lo
libpopt_la_OBJECTS = $(am_libpopt_la_OBJECTS)
-@@ -287,13 +287,13 @@
+@@ -349,16 +349,16 @@
noinst_HEADERS = poptint.h system.h
test1_SOURCES = test1.c
test1_LDFLAGS =
@@ -19,10 +19,14 @@
test2_LDFLAGS =
-test2_LDADD = $(usrlib_LTLIBRARIES)
+test2_LDADD = $(usrlib_LTLIBRARIES) $(LTLIBICONV)
- test3_SOURCES = test3.c
- test3_LDFLAGS =
--test3_LDADD = $(usrlib_LTLIBRARIES)
-+test3_LDADD = $(usrlib_LTLIBRARIES) $(LTLIBICONV)
+ #test3_SOURCES = test3.c
+ #test3_LDFLAGS =
+-#test3_LDADD = $(usrlib_LTLIBRARIES)
++#test3_LDADD = $(usrlib_LTLIBRARIES) $(LTLIBICONV)
+ tdict_SOURCES = tdict.c
+ tdict_LDFLAGS =
+-tdict_LDADD = $(usrlib_LTLIBRARIES)
++tdict_LDADD = $(usrlib_LTLIBRARIES) $(LTLIBICONV)
noinst_SCRIPTS = testit.sh
TESTS_ENVIRONMENT = \
- test1="./test1"
+ test1="$(top_builddir)/test1"
diff --git a/devel/popt/files/patch-configure b/devel/popt/files/patch-configure
index 5cc555e3fef5..f0a779f9984e 100644
--- a/devel/popt/files/patch-configure
+++ b/devel/popt/files/patch-configure
@@ -1,9 +1,9 @@
---- configure.old 2009-05-07 15:24:09.000000000 -0500
-+++ configure 2009-05-07 15:31:26.000000000 -0500
-@@ -19487,6 +19487,7 @@
+--- configure.orig 2010-05-05 04:55:59.000000000 +0800
++++ configure 2010-06-16 00:37:52.000000000 +0800
+@@ -8450,6 +8450,7 @@
# This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+ LIBTOOL_DEPS="$ltmain"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
diff --git a/devel/popt/files/patch-popt.3 b/devel/popt/files/patch-popt.3
index 828f551f5412..6ac75f555b79 100644
--- a/devel/popt/files/patch-popt.3
+++ b/devel/popt/files/patch-popt.3
@@ -1,5 +1,5 @@
---- popt.3.old 2009-05-07 15:35:15.000000000 -0500
-+++ popt.3 2009-05-07 15:36:09.000000000 -0500
+--- popt.3.orig 2009-07-26 02:52:36.000000000 +0800
++++ popt.3 2010-06-16 00:39:09.000000000 +0800
@@ -24,7 +24,7 @@
.sp
.BI "const char ** poptGetArgs(poptContext " con );
@@ -9,7 +9,7 @@
.sp
.BI "const char * poptBadOption(poptContext " con ", int " flags );
.sp
-@@ -497,7 +497,7 @@
+@@ -498,7 +498,7 @@
good error messages.
.HP
.nf
diff --git a/devel/popt/files/patch-popt.c b/devel/popt/files/patch-popt.c
index b1a05d654e24..bb9ee3319f6e 100644
--- a/devel/popt/files/patch-popt.c
+++ b/devel/popt/files/patch-popt.c
@@ -1,5 +1,5 @@
---- popt.c.old 2009-05-07 15:44:42.000000000 -0500
-+++ popt.c 2009-05-07 15:47:12.000000000 -0500
+--- popt.c.orig 2010-01-19 08:39:10.000000000 +0800
++++ popt.c 2010-06-16 00:38:47.000000000 +0800
@@ -22,6 +22,9 @@
#include <float.h>
#endif
diff --git a/devel/popt/pkg-plist b/devel/popt/pkg-plist
index 0dc70c63c8b4..06a874d12286 100644
--- a/devel/popt/pkg-plist
+++ b/devel/popt/pkg-plist
@@ -1,21 +1,26 @@
+@comment $FreeBSD$
include/popt.h
lib/libpopt.a
lib/libpopt.la
lib/libpopt.so
lib/libpopt.so.0
+libdata/pkgconfig/popt.pc
%%NLS%%share/locale/cs/LC_MESSAGES/popt.mo
%%NLS%%share/locale/da/LC_MESSAGES/popt.mo
%%NLS%%share/locale/de/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/popt.mo
%%NLS%%share/locale/es/LC_MESSAGES/popt.mo
%%NLS%%share/locale/fi/LC_MESSAGES/popt.mo
%%NLS%%share/locale/fr/LC_MESSAGES/popt.mo
%%NLS%%share/locale/ga/LC_MESSAGES/popt.mo
%%NLS%%share/locale/gl/LC_MESSAGES/popt.mo
%%NLS%%share/locale/hu/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/id/LC_MESSAGES/popt.mo
%%NLS%%share/locale/is/LC_MESSAGES/popt.mo
%%NLS%%share/locale/it/LC_MESSAGES/popt.mo
%%NLS%%share/locale/ja/LC_MESSAGES/popt.mo
%%NLS%%share/locale/ko/LC_MESSAGES/popt.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/popt.mo
%%NLS%%share/locale/nb/LC_MESSAGES/popt.mo
%%NLS%%share/locale/nl/LC_MESSAGES/popt.mo
%%NLS%%share/locale/pl/LC_MESSAGES/popt.mo