aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-11-08 12:44:48 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-11-08 12:44:48 +0000
commitae65a93800ccf8652f3179c2a2df2ec51dad2f39 (patch)
tree7c98691ebe43e5a18651d3734bbf30bd0bfd57ea /devel
parent11ce632b31faf378d16bb8c4be4ab4444ecc859a (diff)
downloadports-ae65a93800ccf8652f3179c2a2df2ec51dad2f39.tar.gz
ports-ae65a93800ccf8652f3179c2a2df2ec51dad2f39.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-validictory/Makefile23
-rw-r--r--devel/py-validictory/distinfo2
-rw-r--r--devel/py-validictory/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 696cc354eb0a..2076decd5dcf 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4003,6 +4003,7 @@
SUBDIR += py-usb
SUBDIR += py-user_agents
SUBDIR += py-utils
+ SUBDIR += py-validictory
SUBDIR += py-venusian
SUBDIR += py-versiontools
SUBDIR += py-virtualenv
diff --git a/devel/py-validictory/Makefile b/devel/py-validictory/Makefile
new file mode 100644
index 000000000000..9009a1610fa8
--- /dev/null
+++ b/devel/py-validictory/Makefile
@@ -0,0 +1,23 @@
+# Created by: Thomas Zander <riggs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= validictory
+PORTVERSION= 0.9.3
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= General purpose Python data validator
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USE_GITHUB= yes
+GH_ACCOUNT= sunlightlabs
+GH_COMMIT= 584d90b
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-validictory/distinfo b/devel/py-validictory/distinfo
new file mode 100644
index 000000000000..a08c935f0928
--- /dev/null
+++ b/devel/py-validictory/distinfo
@@ -0,0 +1,2 @@
+SHA256 (validictory-0.9.3.tar.gz) = 64a92d5c0d8fcff3990466538a730387f7d6ed8205f83613fd4797b9efdcdb5c
+SIZE (validictory-0.9.3.tar.gz) = 25834
diff --git a/devel/py-validictory/pkg-descr b/devel/py-validictory/pkg-descr
new file mode 100644
index 000000000000..2fa314982e8b
--- /dev/null
+++ b/devel/py-validictory/pkg-descr
@@ -0,0 +1,6 @@
+Validictory is a general purpose Python data validator.
+
+It works with Python 2.6+ and Python 3.2+ and uses a Schema format
+based on JSON Schema Proposal (http://json-schema.org).
+
+WWW: http://github.com/sunlightlabs/validictory