aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-09-28 20:02:16 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-09-28 20:02:16 +0000
commitc51216b7af31cd0ad8e1c1bc68ce3f629d338ff8 (patch)
treee64160cc4e7487eda75a6e8b99f70be3de2342af /devel
parent0414f2190d8fb222f154ef5d1166f6e6d647f08b (diff)
downloadports-c51216b7af31cd0ad8e1c1bc68ce3f629d338ff8.tar.gz
ports-c51216b7af31cd0ad8e1c1bc68ce3f629d338ff8.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pathlib2/Makefile27
-rw-r--r--devel/py-pathlib2/distinfo3
-rw-r--r--devel/py-pathlib2/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6982431b11b6..c2c3e6da829a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4302,6 +4302,7 @@
SUBDIR += py-parsedatetime
SUBDIR += py-path.py
SUBDIR += py-pathlib
+ SUBDIR += py-pathlib2
SUBDIR += py-pathtools
SUBDIR += py-paver
SUBDIR += py-pbr
diff --git a/devel/py-pathlib2/Makefile b/devel/py-pathlib2/Makefile
new file mode 100644
index 000000000000..ac6f8e26e212
--- /dev/null
+++ b/devel/py-pathlib2/Makefile
@@ -0,0 +1,27 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pathlib2
+PORTVERSION= 2.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Object-oriented filesystem paths
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && \
+ ${PYTHON_CMD} test_pathlib2.py && \
+ ${PYTHON_CMD} test_pathlib2_with_py2_unicode_literals.py)
+
+.include <bsd.port.mk>
diff --git a/devel/py-pathlib2/distinfo b/devel/py-pathlib2/distinfo
new file mode 100644
index 000000000000..a0b9adf5f03f
--- /dev/null
+++ b/devel/py-pathlib2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475082260
+SHA256 (pathlib2-2.1.0.tar.gz) = deb3a960c1d55868dfbcac98432358b92ba89d95029cddd4040db1f27405055c
+SIZE (pathlib2-2.1.0.tar.gz) = 30390
diff --git a/devel/py-pathlib2/pkg-descr b/devel/py-pathlib2/pkg-descr
new file mode 100644
index 000000000000..a47bedffa560
--- /dev/null
+++ b/devel/py-pathlib2/pkg-descr
@@ -0,0 +1,5 @@
+Backport of standard pathlib module which tracks the standard library module,
+so all the newest features of the standard pathlib can be used also on older
+Python versions.
+
+WWW: https://pypi.python.org/pypi/pathlib2/