aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-12-10 10:08:57 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-12-10 10:08:57 +0000
commitcb1d98e3ffae9f00ba2b5370c7cd0753203fe597 (patch)
treec73eae5c922fbbb5b15e8d6bb47cc260d688590a /devel
parentd5388cfb12e6ba1a313c72b59cb78736a8d4b700 (diff)
downloadports-cb1d98e3ffae9f00ba2b5370c7cd0753203fe597.tar.gz
ports-cb1d98e3ffae9f00ba2b5370c7cd0753203fe597.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Default/Makefile25
-rw-r--r--devel/p5-Class-Default/distinfo1
-rw-r--r--devel/p5-Class-Default/pkg-comment1
-rw-r--r--devel/p5-Class-Default/pkg-descr15
-rw-r--r--devel/p5-Class-Default/pkg-plist5
6 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 97dfa6164fb0..86293504265c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -425,6 +425,7 @@
SUBDIR += p5-Class-Contract
SUBDIR += p5-Class-Data-Inheritable
SUBDIR += p5-Class-Date
+ SUBDIR += p5-Class-Default
SUBDIR += p5-Class-Delegation
SUBDIR += p5-Class-Factory
SUBDIR += p5-Class-Factory-Util
diff --git a/devel/p5-Class-Default/Makefile b/devel/p5-Class-Default/Makefile
new file mode 100644
index 000000000000..79c4e41dcf12
--- /dev/null
+++ b/devel/p5-Class-Default/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Class-Default
+# Date created: 10 December 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Default
+PORTVERSION= 0.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Class::Default.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Default/distinfo b/devel/p5-Class-Default/distinfo
new file mode 100644
index 000000000000..30e4682adb6f
--- /dev/null
+++ b/devel/p5-Class-Default/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Default-0.2.tar.gz) = c961e930444087c9d65877ed2e962ad5
diff --git a/devel/p5-Class-Default/pkg-comment b/devel/p5-Class-Default/pkg-comment
new file mode 100644
index 000000000000..8a5feb175120
--- /dev/null
+++ b/devel/p5-Class-Default/pkg-comment
@@ -0,0 +1 @@
+Static calls apply to a default instantiation
diff --git a/devel/p5-Class-Default/pkg-descr b/devel/p5-Class-Default/pkg-descr
new file mode 100644
index 000000000000..4176de2f72e9
--- /dev/null
+++ b/devel/p5-Class-Default/pkg-descr
@@ -0,0 +1,15 @@
+Class::Default provides a mechanism to allow your class to take static
+method calls and apply it to a default instantiation of an object. It
+provides a flexibility to an API that allows it to be used more
+confortably in different situations.
+
+This technique appears to be especially usefull when writing modules
+that you want to be used in either a single use or a persistant
+environment. In a CGI like environment, you want the simplicity of a
+static interface. You can call Class-method> directly, without having
+to pass an instantiation around constantly.
+
+WWW: http://search.cpan.org/search?dist=Class-Default
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-Class-Default/pkg-plist b/devel/p5-Class-Default/pkg-plist
new file mode 100644
index 000000000000..c744ee0f56b9
--- /dev/null
+++ b/devel/p5-Class-Default/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Default/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Class/Default.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Default
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Class 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true