aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-23 12:38:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-23 12:38:35 +0000
commitcd59bab94fb279a1d2a9e5d13a0909860d211c37 (patch)
tree57986fc881b61121d0e9df6cfdd378b6dc0c18f8 /devel
parent3bd73c95869e8617bfe5bb8a5d912c2fbeea2d56 (diff)
downloadports-cd59bab94fb279a1d2a9e5d13a0909860d211c37.tar.gz
ports-cd59bab94fb279a1d2a9e5d13a0909860d211c37.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rebar/Makefile30
-rw-r--r--devel/rebar/distinfo2
-rw-r--r--devel/rebar/pkg-descr11
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index de16f339d70f..eb723da695d2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3607,6 +3607,7 @@
SUBDIR += re2
SUBDIR += re2c
SUBDIR += readline
+ SUBDIR += rebar
SUBDIR += regexx
SUBDIR += regexxer
SUBDIR += remake
diff --git a/devel/rebar/Makefile b/devel/rebar/Makefile
new file mode 100644
index 000000000000..8686e347c8dd
--- /dev/null
+++ b/devel/rebar/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: rebar
+# Date created: 2012-06-09
+# Whom: koobs <koobs.freebsd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rebar
+PORTVERSION= 2.0.0
+CATEGORIES= devel
+MASTER_SITES= http://github.com/basho/${PORTNAME}/tarball/${GITVERSION}/
+DISTNAME= basho-${PORTNAME}-${GITVERSION}
+
+MAINTAINER= koobs.freebsd@gmail.com
+COMMENT= A build-tool for Erlang that follows OTP principles
+
+LICENSE= AL2
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/escript:${PORTSDIR}/lang/erlang
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PLIST_FILES= bin/${PORTNAME}
+
+GITVERSION= 1c98f6c
+FETCH_ARGS= -Fpr
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/devel/rebar/distinfo b/devel/rebar/distinfo
new file mode 100644
index 000000000000..936b7f0e4a5a
--- /dev/null
+++ b/devel/rebar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (basho-rebar-1c98f6c.tar.gz) = 237561ee22e221924edbe7364b556151d1be89a3c661a1d8983c7b99384ea978
+SIZE (basho-rebar-1c98f6c.tar.gz) = 120821
diff --git a/devel/rebar/pkg-descr b/devel/rebar/pkg-descr
new file mode 100644
index 000000000000..4b9808741cd7
--- /dev/null
+++ b/devel/rebar/pkg-descr
@@ -0,0 +1,11 @@
+rebar is an Erlang build tool that makes it easy to compile and test Erlang
+applications, port drivers and releases.
+
+rebar is a self-contained Erlang script, so it's easy to distribute or even
+embed directly in a project. Where possible, rebar uses standard Erlang/OTP
+conventions for project structures, thus minimizing the amount of build
+configuration work. rebar also provides dependency management, enabling
+application writers to easily re-use common libraries from a variety of
+locations (git, hg, etc).
+
+WWW: https://github.com/basho/rebar