aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2002-07-10 12:33:03 +0000
committerJames E. Housley <jeh@FreeBSD.org>2002-07-10 12:33:03 +0000
commitf66ce50173c11078aa119e6041063e534477800f (patch)
treeeeee1bfb29c220f5e5c9752bb7b8b18f9024122d /devel
parent3a5a5061367cf2085fa839fec2bc35965b70e17a (diff)
downloadports-f66ce50173c11078aa119e6041063e534477800f.tar.gz
ports-f66ce50173c11078aa119e6041063e534477800f.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/i386-rtems-chill/Makefile11
-rw-r--r--devel/i386-rtems-g77/Makefile10
-rw-r--r--devel/i386-rtems-gcc/Makefile10
-rw-r--r--devel/i386-rtems-gcj/Makefile10
-rw-r--r--devel/i386-rtems-objc/Makefile10
-rw-r--r--devel/rtems-gcc/Makefile22
-rw-r--r--devel/rtems-gcc/distinfo1
-rw-r--r--devel/rtems-gcc/pkg-comment1
-rw-r--r--devel/rtems-gcc/pkg-descr7
-rw-r--r--devel/rtems-gcc/pkg-plist1
11 files changed, 31 insertions, 53 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5cac0faa0eb8..e35bf5ca3eea 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -633,7 +633,6 @@
SUBDIR += rlwrap
SUBDIR += robodoc
SUBDIR += rpc2
- SUBDIR += rtems-gcc
SUBDIR += rtplib
SUBDIR += ruby-amstd
SUBDIR += ruby-aspectr
diff --git a/devel/i386-rtems-chill/Makefile b/devel/i386-rtems-chill/Makefile
index f35c08b6564b..27a5e5219459 100644
--- a/devel/i386-rtems-chill/Makefile
+++ b/devel/i386-rtems-chill/Makefile
@@ -9,9 +9,13 @@ PORTNAME= chill
PORTVERSION= 2.95.3
PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= newlib gcc/releases/${CHILLNAME}
-DISTFILES= ${NEWLIBNAME}.tar.gz ${CHILLNAME}.tar.gz
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
+ ${MASTER_SITE_SOURCEWARE:S/$/:gcc/}
+MASTER_SITE_SUBDIR= newlib \
+ gcc/releases/${CHILLNAME}/:gcc
+DISTFILES= ${NEWLIBNAME}.tar.gz \
+ ${CHILLNAME}.tar.gz:gcc
+
PATCHFILES= ${CHILLNAME}-rtems-20010622a.diff \
${NEWLIBNAME}-rtems-20010622.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
@@ -26,7 +30,6 @@ NEWLIBNAME= newlib-1.9.0
MASTERDIR= ${.CURDIR}/../i386-rtems-chill
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-FETCH_DEPENDS= /nonexistent:${PORTSDIR}/devel/rtems-gcc:extract
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index dc8b32510296..b8e4cf366606 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -9,9 +9,12 @@ PORTNAME= g77
PORTVERSION= 2.95.3
PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= newlib gcc/releases/${G77NAME}
-DISTFILES= ${NEWLIBNAME}.tar.gz ${G77NAME}.tar.gz
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
+ ${MASTER_SITE_SOURCEWARE:S/$/:gcc/}
+MASTER_SITE_SUBDIR= newlib \
+ gcc/releases/${G77NAME}/:gcc
+DISTFILES= ${NEWLIBNAME}.tar.gz \
+ ${G77NAME}.tar.gz:gcc
PATCHFILES= ${G77NAME}-rtems-20010622a.diff \
${NEWLIBNAME}-rtems-20010622.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
@@ -26,7 +29,6 @@ NEWLIBNAME= newlib-1.9.0
MASTERDIR= ${.CURDIR}/../i386-rtems-g77
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-FETCH_DEPENDS= /nonexistent:${PORTSDIR}/devel/rtems-gcc:extract
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
diff --git a/devel/i386-rtems-gcc/Makefile b/devel/i386-rtems-gcc/Makefile
index 74b6c326b6e2..6027dff4d008 100644
--- a/devel/i386-rtems-gcc/Makefile
+++ b/devel/i386-rtems-gcc/Makefile
@@ -9,9 +9,12 @@ PORTNAME= gcc
PORTVERSION= 2.95.3
PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= newlib gcc/releases/${GCCNAME}
-DISTFILES= ${NEWLIBNAME}.tar.gz ${GCCNAME}.tar.gz
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
+ ${MASTER_SITE_SOURCEWARE:S/$/:gcc/}
+MASTER_SITE_SUBDIR= newlib \
+ gcc/releases/${GCCNAME}/:gcc
+DISTFILES= ${NEWLIBNAME}.tar.gz \
+ ${GCCNAME}.tar.gz:gcc
PATCHFILES= ${GCCNAME}-rtems-20010622a.diff \
${NEWLIBNAME}-rtems-20010622.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
@@ -26,7 +29,6 @@ NEWLIBNAME= newlib-1.9.0
MASTERDIR= ${.CURDIR}/../i386-rtems-gcc
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-FETCH_DEPENDS= /nonexistent:${PORTSDIR}/devel/rtems-gcc:extract
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-as:${PORTSDIR}/devel/${LCLTARGET}-binutils \
${LCLTARGET}-ld:${PORTSDIR}/devel/${LCLTARGET}-binutils
diff --git a/devel/i386-rtems-gcj/Makefile b/devel/i386-rtems-gcj/Makefile
index 3efae046a7f5..48891ccf1a38 100644
--- a/devel/i386-rtems-gcj/Makefile
+++ b/devel/i386-rtems-gcj/Makefile
@@ -9,9 +9,12 @@ PORTNAME= gcj
PORTVERSION= 2.95.3
PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= newlib gcc/releases/${JAVANAME}
-DISTFILES= ${NEWLIBNAME}.tar.gz ${JAVANAME}.tar.gz
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
+ ${MASTER_SITE_SOURCEWARE:S/$/:gcc/}
+MASTER_SITE_SUBDIR= newlib \
+ gcc/releases/${JAVANAME}/:gcc
+DISTFILES= ${NEWLIBNAME}.tar.gz \
+ ${JAVANAME}.tar.gz:gcc
PATCHFILES= ${JAVANAME}-rtems-20010622a.diff \
${NEWLIBNAME}-rtems-20010622.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
@@ -26,7 +29,6 @@ NEWLIBNAME= newlib-1.9.0
MASTERDIR= ${.CURDIR}/../i386-rtems-gcj
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-FETCH_DEPENDS= /nonexistent:${PORTSDIR}/devel/rtems-gcc:extract
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
diff --git a/devel/i386-rtems-objc/Makefile b/devel/i386-rtems-objc/Makefile
index f5efeb16fb0e..1d8a7fd5c90a 100644
--- a/devel/i386-rtems-objc/Makefile
+++ b/devel/i386-rtems-objc/Makefile
@@ -9,9 +9,12 @@ PORTNAME= objc
PORTVERSION= 2.95.3
PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= newlib gcc/releases/${OBJCNAME}
-DISTFILES= ${NEWLIBNAME}.tar.gz ${OBJCNAME}.tar.gz
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE} \
+ ${MASTER_SITE_SOURCEWARE:S/$/:gcc/}
+MASTER_SITE_SUBDIR= newlib \
+ gcc/releases/${OBJCNAME}/:gcc
+DISTFILES= ${NEWLIBNAME}.tar.gz \
+ ${OBJCNAME}.tar.gz:gcc
PATCHFILES= ${OBJCNAME}-rtems-20010622a.diff \
${NEWLIBNAME}-rtems-20010622.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
@@ -26,7 +29,6 @@ NEWLIBNAME= newlib-1.9.0
MASTERDIR= ${.CURDIR}/../i386-rtems-objc
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-FETCH_DEPENDS= /nonexistent:${PORTSDIR}/devel/rtems-gcc:extract
BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
diff --git a/devel/rtems-gcc/Makefile b/devel/rtems-gcc/Makefile
deleted file mode 100644
index 840e68d549e9..000000000000
--- a/devel/rtems-gcc/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# New ports collection makefile for: i386-rtems-gcc
-# Date created: 9 June 2000
-# Whom: James Housley <jim@thehousleys.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gcc
-PORTVERSION= 2.95.3
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
-MASTER_SITE_SUBDIR= gcc/releases/${PORTNAME}-${PORTVERSION}
-EXTRACT_ONLY= # Empty
-
-MAINTAINER= jeh@FreeBSD.org
-
-PKGNAMEPREFIX= rtems-
-
-NO_BUILD= YES
-NO_INSTALL= YES
-
-.include <bsd.port.mk>
diff --git a/devel/rtems-gcc/distinfo b/devel/rtems-gcc/distinfo
deleted file mode 100644
index b6d394f9b8c3..000000000000
--- a/devel/rtems-gcc/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (gcc-2.95.3.tar.gz) = f3ad4f32c2296fad758ed051b5ac8e28
diff --git a/devel/rtems-gcc/pkg-comment b/devel/rtems-gcc/pkg-comment
deleted file mode 100644
index 8029d3a029c8..000000000000
--- a/devel/rtems-gcc/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A phantom port to fetch the gcc tarball for the RTEMS ports
diff --git a/devel/rtems-gcc/pkg-descr b/devel/rtems-gcc/pkg-descr
deleted file mode 100644
index 519598cf719b..000000000000
--- a/devel/rtems-gcc/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-This is a phantom port to fetch the gcc tarball used by the
-*-rtems-gcc, *-rtems-gcj, *-rtems-g77 and *-rtems-objc ports.
-
-WWW: http://www.oarcorp.com/
-
-- Jim
-jim@thehousleys.net
diff --git a/devel/rtems-gcc/pkg-plist b/devel/rtems-gcc/pkg-plist
deleted file mode 100644
index 549a621fec0c..000000000000
--- a/devel/rtems-gcc/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@comment this plist intentionally left empty