aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-18 17:03:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-18 17:03:51 +0000
commitf8f2a527742b20dc8670b43a0acd9de1cf896c68 (patch)
tree565109239ce0a8c879cfff9ccdeeef6eb67bdcf7 /devel
parent753d4b87e189f4ad0fe3c320297568fb539b846f (diff)
downloadports-f8f2a527742b20dc8670b43a0acd9de1cf896c68.tar.gz
ports-f8f2a527742b20dc8670b43a0acd9de1cf896c68.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gjstest/Makefile41
-rw-r--r--devel/gjstest/distinfo2
-rw-r--r--devel/gjstest/files/patch-base-stl_decl.h11
-rw-r--r--devel/gjstest/pkg-descr21
-rw-r--r--devel/gjstest/pkg-plist36
6 files changed, 112 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 26c6b0bd904c..d2c33e974184 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -480,6 +480,7 @@
SUBDIR += gitg
SUBDIR += gitolite
SUBDIR += gittrac
+ SUBDIR += gjstest
SUBDIR += glade2
SUBDIR += glade3
SUBDIR += glademm
diff --git a/devel/gjstest/Makefile b/devel/gjstest/Makefile
new file mode 100644
index 000000000000..fbe5f5970b1b
--- /dev/null
+++ b/devel/gjstest/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gjstest
+# Date created: 2011-10-04
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gjstest
+PORTVERSION= 1.0.6
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Lightweight JS unit testing using the V8 engine
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+LIB_DEPENDS= gflags:${PORTSDIR}/devel/gflags \
+ glog:${PORTSDIR}/devel/glog \
+ protobuf:${PORTSDIR}/devel/protobuf \
+ re2:${PORTSDIR}/devel/re2 \
+ v8:${PORTSDIR}/lang/v8 \
+ xml2:${PORTSDIR}/textproc/libxml2
+
+ALL_TARGET= default
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
+CXXFLAGS+= -L${LOCALBASE}/lib
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+PROJECTHOST= google-js-test
+
+post-patch:
+ @${REINPLACE_CMD} -e '/export PREFIX = / s|/usr/local|${PREFIX}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|CLOCK_PROCESS_CPUTIME_ID|CLOCK_PROF|' \
+ ${WRKSRC}/base/timer.cc
+ @${REINPLACE_CMD} -e '1 s|/bin/bash|${LOCALBASE}/bin/bash|' \
+ ${WRKSRC}/gjstest/internal/cpp/generate_builtin_paths.sh \
+ ${WRKSRC}/scripts/*.sh
+
+.include <bsd.port.mk>
diff --git a/devel/gjstest/distinfo b/devel/gjstest/distinfo
new file mode 100644
index 000000000000..fb5bff220aee
--- /dev/null
+++ b/devel/gjstest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gjstest-1.0.6.tar.bz2) = 87ab6db2cf289e71b287437d32e7664f69c187a0727978d2e1c8a2cde5af276c
+SIZE (gjstest-1.0.6.tar.bz2) = 162447
diff --git a/devel/gjstest/files/patch-base-stl_decl.h b/devel/gjstest/files/patch-base-stl_decl.h
new file mode 100644
index 000000000000..f1c794db4ea0
--- /dev/null
+++ b/devel/gjstest/files/patch-base-stl_decl.h
@@ -0,0 +1,11 @@
+--- base/stl_decl.h.orig 2011-09-29 08:11:48.000000000 +0800
++++ base/stl_decl.h 2011-10-04 21:10:17.695777868 +0800
+@@ -25,7 +25,7 @@
+ #elif defined(__APPLE__) /* gcc with a twist */
+ #include "base/stl_decl_osx.h"
+
+-#elif defined(__linux__)
++#elif defined(__linux__) || defined(__FreeBSD__)
+ #include "base/stl_decl_linux.h"
+
+ #else
diff --git a/devel/gjstest/pkg-descr b/devel/gjstest/pkg-descr
new file mode 100644
index 000000000000..d43c6069053b
--- /dev/null
+++ b/devel/gjstest/pkg-descr
@@ -0,0 +1,21 @@
+Google JS Test is a fast javascript unit testing framework that runs on the V8
+engine, without needing to launch a full browser.
+
+Features include:
+- Extremely fast test startup and execution time, without having to run a
+ browser.
+- Clean, readable output in the case of both passing and failing tests.
+- A browser-based test driver that can simply be refreshed whenever JS is
+ changed.
+- Style and semantics that resemble Google Test for C++.
+- A built-in mocking framework that requires minimal boilerplate code (e.g. no
+ $tearDown or $verifyAll) with style and semantics based on the Google C++
+ Mocking Framework.
+
+The trade-off is that since tests are run in V8 without a browser, there is no
+DOM available. You can still use Google JS Test for tests of DOM-manipulating
+code however; see "Is it for me?" [1] for more details.
+
+[1] http://code.google.com/p/google-js-test/wiki/IsItForMe
+
+WWW: http://code.google.com/p/google-js-test/
diff --git a/devel/gjstest/pkg-plist b/devel/gjstest/pkg-plist
new file mode 100644
index 000000000000..d5f9f25f55df
--- /dev/null
+++ b/devel/gjstest/pkg-plist
@@ -0,0 +1,36 @@
+bin/gjstest
+%%DATADIR%%/internal/js/browser/browser.css
+%%DATADIR%%/internal/js/browser/html_builder.js
+%%DATADIR%%/internal/js/browser/run_tests.js
+%%DATADIR%%/internal/js/call_expectation.js
+%%DATADIR%%/internal/js/error_utils.js
+%%DATADIR%%/internal/js/expect_that.js
+%%DATADIR%%/internal/js/mock_function.js
+%%DATADIR%%/internal/js/mock_instance.js
+%%DATADIR%%/internal/js/namespace.js
+%%DATADIR%%/internal/js/run_test.js
+%%DATADIR%%/internal/js/stack_frame.js
+%%DATADIR%%/internal/js/stack_utils.js
+%%DATADIR%%/internal/js/test_environment.js
+%%DATADIR%%/internal/js/use_global_namespace.js
+%%DATADIR%%/public/actions.js
+%%DATADIR%%/public/assertions.js
+%%DATADIR%%/public/logging.js
+%%DATADIR%%/public/matcher_types.js
+%%DATADIR%%/public/matchers/array_matchers.js
+%%DATADIR%%/public/matchers/boolean_matchers.js
+%%DATADIR%%/public/matchers/combining_matchers.js
+%%DATADIR%%/public/matchers/equality_matchers.js
+%%DATADIR%%/public/matchers/function_matchers.js
+%%DATADIR%%/public/matchers/missing_arg_matchers.js
+%%DATADIR%%/public/matchers/number_matchers.js
+%%DATADIR%%/public/matchers/string_matchers.js
+%%DATADIR%%/public/mocking.js
+%%DATADIR%%/public/register.js
+%%DATADIR%%/public/stringify.js
+@dirrm %%DATADIR%%/public/matchers
+@dirrm %%DATADIR%%/public
+@dirrm %%DATADIR%%/internal/js/browser
+@dirrm %%DATADIR%%/internal/js
+@dirrm %%DATADIR%%/internal
+@dirrm %%DATADIR%%