aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-12-01 15:26:40 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-12-01 15:26:40 +0000
commit07fc197e275513d481a5a184aedebaa4f8166bba (patch)
tree152a6c6111d8ba2bb100513691b97104ddc1773b /devel
parent882d71ed3ee0a4f29139b5ddf27341f0f52190b3 (diff)
downloadports-07fc197e275513d481a5a184aedebaa4f8166bba.tar.gz
ports-07fc197e275513d481a5a184aedebaa4f8166bba.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/rubygem-launchy/Makefile23
-rw-r--r--devel/rubygem-launchy/distinfo3
-rw-r--r--devel/rubygem-launchy/pkg-descr9
3 files changed, 35 insertions, 0 deletions
diff --git a/devel/rubygem-launchy/Makefile b/devel/rubygem-launchy/Makefile
new file mode 100644
index 000000000000..1b0a8d1222e1
--- /dev/null
+++ b/devel/rubygem-launchy/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: gem-launchy
+# Date created: 06 Nov 2009
+# Whom: Ryan Steinmetz (<rpsfa@rit.edu>)
+#
+# $FreeBSD$
+
+PORTNAME= launchy
+PORTVERSION= 0.3.3
+CATEGORIES= devel rubygems
+MASTER_SITES= RF/copiousfreetime
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= A helper class for launching cross-platform applications
+
+RUN_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
+ rubygem-configuration>=1.1.0:${PORTSDIR}/devel/rubygem-configuration
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES+= bin/launchy
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-launchy/distinfo b/devel/rubygem-launchy/distinfo
new file mode 100644
index 000000000000..a38bf4b8b8c8
--- /dev/null
+++ b/devel/rubygem-launchy/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/launchy-0.3.3.gem) = 467abcff90841c06faae6941f0a66910
+SHA256 (rubygem/launchy-0.3.3.gem) = 64dfba1a020107a0fda1a5cd14c08ed8d635cfb4fc745c1df12f68edc5357f5d
+SIZE (rubygem/launchy-0.3.3.gem) = 15872
diff --git a/devel/rubygem-launchy/pkg-descr b/devel/rubygem-launchy/pkg-descr
new file mode 100644
index 000000000000..e40428d022e0
--- /dev/null
+++ b/devel/rubygem-launchy/pkg-descr
@@ -0,0 +1,9 @@
+Launchy is helper class for launching cross-platform
+applications in a fire and forget manner. There are
+application concepts (browser, email client, etc)
+that are common across all platforms, and they may
+be launched differently on each platform. Launchy
+is here to make a common approach to launching
+external application from within ruby programs.
+
+WWW: http://rubyforge.org/projects/copiousfreetime/