aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2006-12-27 22:40:12 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2006-12-27 22:40:12 +0000
commit294027405bc231e667e248c3ac6468b2287a68e0 (patch)
tree8dede7ce2e09a6d08730fe3822323f49722b8cd6 /devel
parent2d28a4e100c7b99b086bf006eb5ca930740a014b (diff)
downloadports-294027405bc231e667e248c3ac6468b2287a68e0.tar.gz
ports-294027405bc231e667e248c3ac6468b2287a68e0.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/devhelp/Makefile8
-rw-r--r--devel/devhelp/files/patch-configure41
-rw-r--r--devel/devhelp/files/patch-configure.in13
-rw-r--r--devel/devhelp/files/patch-src_dh-base.c (renamed from devel/devhelp/files/patch-src::dh-base.c)0
4 files changed, 59 insertions, 3 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 46839bcbda2a..08ee7cf9ac13 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= devhelp
PORTVERSION= 0.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES?= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C,^([[:digit:]]+\.[[:digit:]]+).*,\1,}
@@ -24,8 +24,10 @@ MOZILLA= mozilla
.if !defined(WITH_MOZILLA)
MOZILLA= mozilla
.else
-.if ${WITH_MOZILLA}=="firefox"
+.if ${WITH_MOZILLA} == "firefox"
MOZILLA= firefox
+.elif ${WITH_MOZILLA} == "seamonkey"
+MOZILLA= seamonkey
.endif
.endif
@@ -52,7 +54,7 @@ pre-everything::
@${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} " firefox seamonkey "
@${ECHO_MSG} ""
.include <bsd.port.post.mk>
diff --git a/devel/devhelp/files/patch-configure b/devel/devhelp/files/patch-configure
new file mode 100644
index 000000000000..d0f4d380dcfb
--- /dev/null
+++ b/devel/devhelp/files/patch-configure
@@ -0,0 +1,41 @@
+--- configure.orig Wed Dec 27 12:37:13 2006
++++ configure Wed Dec 27 12:41:54 2006
+@@ -1047,9 +1047,9 @@
+ include additional configurations [automatic]
+ --with-gconf-source=sourceaddress Config database for installing schema files.
+ --with-gconf-schema-file-dir=dir Directory for installing schema files.
+- --with-mozilla[=mozilla|firefox|thunderbird]
+- Whether to use mozilla, firefox or thunderbird
+- gtkmozembed (default: mozilla)
++ --with-mozilla[=mozilla|firefox|seamonkey|thunderbird]
++ Whether to use mozilla, firefox, seamonkey
++ or thunderbird gtkmozembed (default: mozilla)
+ --with-zlib=DIR use libz in DIR
+
+ Some influential environment variables:
+@@ -20253,6 +20253,8 @@
+ MOZILLA=mozilla
+ elif pkg-config --exists firefox-gtkmozembed; then
+ MOZILLA=firefox
++ elif pkg-config --exists seamonkey-gtkmozembed; then
++ MOZILLA=seamonkey
+ elif pkg-config --exists thunderbird-gtkmozembed; then
+ MOZILLA=thunderbird
+ else
+@@ -20260,7 +20262,7 @@
+ echo "$as_me: error: no mozilla installation found" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+-elif test "x$with_mozilla" != "xmozilla" -a "x$with_mozilla" != "xfirefox" -a "x$with_mozilla" != "xthunderbird"; then
++elif test "x$with_mozilla" != "xmozilla" -a "x$with_mozilla" != "xfirefox" -a "x$with_mozilla" != "xseamonkey" -a "x$with_mozilla" != "xthunderbird"; then
+ { { echo "$as_me:$LINENO: error: unknown mozilla name ($MOZILLA)" >&5
+ echo "$as_me: error: unknown mozilla name ($MOZILLA)" >&2;}
+ { (exit 1); exit 1; }; }
+@@ -20274,6 +20276,7 @@
+ case "$MOZILLA" in
+ mozilla) min_version=1.7 flavour=mozilla ;;
+ firefox) min_version=0.10 flavour=toolkit ;;
++seamonkey) min_version=1.0 flavour=toolkit ;;
+ thunderbird) min_version=0.8 flavour=toolkit ;;
+ esac
+
diff --git a/devel/devhelp/files/patch-configure.in b/devel/devhelp/files/patch-configure.in
new file mode 100644
index 000000000000..25d3d73f4c5d
--- /dev/null
+++ b/devel/devhelp/files/patch-configure.in
@@ -0,0 +1,13 @@
+--- configure.in.orig Wed Dec 27 12:40:09 2006
++++ configure.in Wed Dec 27 12:42:54 2006
+@@ -44,8 +44,8 @@
+
+ MOZILLA=
+ AC_ARG_WITH([mozilla],
+- AC_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|thunderbird@:>@],
+- [Whether to use mozilla, firefox or thunderbird gtkmozembed (default: mozilla)]),
++ AC_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|seamonkey|thunderbird@:>@],
++ [Whether to use mozilla, firefox, seamonkey or thunderbird gtkmozembed (default: mozilla)]),
+ [MOZILLA="$withval"])
+
+ dnl try to autodetect: if mozilla exists, use it, else try firefox, then thunderbird
diff --git a/devel/devhelp/files/patch-src::dh-base.c b/devel/devhelp/files/patch-src_dh-base.c
index 8e174831a535..8e174831a535 100644
--- a/devel/devhelp/files/patch-src::dh-base.c
+++ b/devel/devhelp/files/patch-src_dh-base.c