aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-30 10:25:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-30 10:25:34 +0000
commit2df76eb0a73bb59d817aa60758a5f10e3e544c3b (patch)
tree07e10c49034b87755dafb03956ad93c5363e0bb7 /devel
parent1c97f613254a72e0ae97ea8d817ebe38096d6949 (diff)
downloadports-2df76eb0a73bb59d817aa60758a5f10e3e544c3b.tar.gz
ports-2df76eb0a73bb59d817aa60758a5f10e3e544c3b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/libslang/files/patch-configure8
-rw-r--r--devel/linuxthreads/Makefile7
2 files changed, 4 insertions, 11 deletions
diff --git a/devel/libslang/files/patch-configure b/devel/libslang/files/patch-configure
index 854673fd5a0a..eec2e732377e 100644
--- a/devel/libslang/files/patch-configure
+++ b/devel/libslang/files/patch-configure
@@ -1,6 +1,6 @@
--- configure.orig Sun Jan 26 07:31:27 2003
+++ configure Fri Feb 21 17:21:25 2003
-@@ -2034,6 +2034,18 @@
+@@ -2034,6 +2034,14 @@
ELFLIB_MAJOR="lib\$(THIS_LIB).\$(ELF_MAJOR_VERSION).dylib"
ELFLIB_MAJOR_MINOR="lib\$(THIS_LIB).\$(ELF_MAJOR_VERSION).\$(ELF_MINOR_VERSION).dylib"
;;
@@ -8,11 +8,7 @@
+ ELFLIB_MAJOR_MINOR="\$(ELFLIB).\$(ELF_MAJOR_VERSION)"
+ ELF_CC="\$(CC)"
+ ELF_CFLAGS="\$(CFLAGS) -fPIC"
-+ if [ $PORTOBJFORMAT = elf ]; then
-+ ELF_LINK="\$(CC) -shared -Wl,-soname,\$(ELFLIB_MAJOR)"
-+ else
-+ ELF_LINK="ld -Bshareable -x"
-+ fi
++ ELF_LINK="\$(CC) -shared -Wl,-soname,\$(ELFLIB_MAJOR)"
+ ELF_LINK_CMD="\$(ELF_LINK)"
+ ELF_DEP_LIBS="\$(DL_LIB) -lm"
+ ;;
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index 437fc6479ec7..8e5a52ee19b7 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -25,9 +25,6 @@ USE_PERL5_BUILD=true
# This port only works on i386 right now.
ONLY_FOR_ARCHS= i386
-.if ${OSVERSION} < 400015
-BROKEN="Requires FreeBSD 4.0 or newer"
-.endif
.if ${OSVERSION} >= 500035
USING_GCC3=true
MAKE_ENV+= USING_GCC3=true
@@ -223,8 +220,8 @@ pre-su-install:
.endif
post-install:
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m /usr/lib
+ ${LDCONFIG} -m ${PREFIX}/lib
+ ${LDCONFIG} -m /usr/lib
${CAT} ${PKGMESSAGE}
# @sh ${PKGINSTALL} ${PKGNAME} POST-INSTALL