aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-11-10 10:09:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-11-10 10:09:48 +0000
commit35326f1a9714f76f3671b263a47134133258ec1b (patch)
treeec00e643384652d97e7643f40c6342bff01bff0b /devel
parent532b7359be003bf854d62cb7aaccdee30cc43d18 (diff)
downloadports-35326f1a9714f76f3671b263a47134133258ec1b.tar.gz
ports-35326f1a9714f76f3671b263a47134133258ec1b.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/dcmtk/Makefile4
-rw-r--r--devel/gdcm/Makefile4
-rw-r--r--devel/grpc/Makefile4
-rw-r--r--devel/hadoop/Makefile4
-rw-r--r--devel/hadoop2/Makefile4
-rw-r--r--devel/libopkele/Makefile4
-rw-r--r--devel/mongo-cxx-driver/Makefile4
-rw-r--r--devel/omniORB/Makefile4
-rw-r--r--devel/poco-ssl/Makefile4
-rw-r--r--devel/ptlib/Makefile4
-rw-r--r--devel/staf/Makefile4
-rw-r--r--devel/thrift-cpp/Makefile4
-rw-r--r--devel/tla/Makefile4
13 files changed, 26 insertions, 26 deletions
diff --git a/devel/dcmtk/Makefile b/devel/dcmtk/Makefile
index cf66633d10d0..bf69b9360315 100644
--- a/devel/dcmtk/Makefile
+++ b/devel/dcmtk/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= ftp://dicom.offis.de/pub/dicom/offis/software/${PORTNAME}/${PORTNA
MAINTAINER= ports@FreeBSD.org
COMMENT= Toolkit to work with DICOM objects
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= use of undeclared identifier 'TLS1_TXT_RSA_EXPORT1024_WITH_DES_CBC_SHA'
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= use of undeclared identifier 'TLS1_TXT_RSA_EXPORT1024_WITH_DES_CBC_SHA'
LIB_DEPENDS= libtiff.so:graphics/tiff \
libpng.so:graphics/png
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index 44d974aa66e9..4bdd82c98fc6 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -12,8 +12,8 @@ COMMENT= Grassroots DICOM library
LICENSE= BSD3CLAUSE
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= variable has incomplete type 'X509_STORE_CTX' (aka 'x509_store_ctx_st')
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= variable has incomplete type 'X509_STORE_CTX' (aka 'x509_store_ctx_st')
LIB_DEPENDS= libopenjpeg.so:graphics/openjpeg15 \
libexpat.so:textproc/expat2
diff --git a/devel/grpc/Makefile b/devel/grpc/Makefile
index 07776eef129e..7ea2cc5d0b39 100644
--- a/devel/grpc/Makefile
+++ b/devel/grpc/Makefile
@@ -14,8 +14,8 @@ COMMENT= HTTP/2-based RPC framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= use of undeclared identifier 'SSL_get0_next_proto_negotiated'
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= use of undeclared identifier 'SSL_get0_next_proto_negotiated'
BUILD_DEPENDS= go:lang/go \
yasm:devel/yasm
diff --git a/devel/hadoop/Makefile b/devel/hadoop/Makefile
index 7b0781567126..42df4b1e0222 100644
--- a/devel/hadoop/Makefile
+++ b/devel/hadoop/Makefile
@@ -15,8 +15,8 @@ COMMENT= Apache Map/Reduce framework
LICENSE= APACHE20
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= variable has incomplete type 'HMAC_CTX' (aka 'hmac_ctx_st')
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= variable has incomplete type 'HMAC_CTX' (aka 'hmac_ctx_st')
BUILD_DEPENDS= gmake:devel/gmake \
gsed:textproc/gsed
diff --git a/devel/hadoop2/Makefile b/devel/hadoop2/Makefile
index d55d86c3e9ce..99553d983a34 100644
--- a/devel/hadoop2/Makefile
+++ b/devel/hadoop2/Makefile
@@ -24,8 +24,8 @@ COMMENT= Apache Map/Reduce framework
LICENSE= APACHE20
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= incomplete definition of type 'struct evp_cipher_ctx_st'
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= incomplete definition of type 'struct evp_cipher_ctx_st'
BUILD_DEPENDS= ${LOCALBASE}/share/java/maven3/bin/mvn:devel/maven3 \
cmake:devel/cmake \
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
index 0a9d9d09aa22..18bd270fb326 100644
--- a/devel/libopkele/Makefile
+++ b/devel/libopkele/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libtidy.so:www/tidy-lib \
libxslt.so:textproc/libxslt
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= member access into incomplete type 'DH' (aka 'dh_st')
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= member access into incomplete type 'DH' (aka 'dh_st')
USES= gmake libtool localbase:ldflags pathfix \
pkgconfig ssl
diff --git a/devel/mongo-cxx-driver/Makefile b/devel/mongo-cxx-driver/Makefile
index f905e1c7fdfe..3121eff273e6 100644
--- a/devel/mongo-cxx-driver/Makefile
+++ b/devel/mongo-cxx-driver/Makefile
@@ -13,8 +13,8 @@ COMMENT= MongoDB Legacy C++ Driver
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/APACHE-2.0.txt
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= use of undeclared identifier 'BIO_s_file_internal'
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= use of undeclared identifier 'BIO_s_file_internal'
LIB_DEPENDS= libboost_system.so:devel/boost-libs
diff --git a/devel/omniORB/Makefile b/devel/omniORB/Makefile
index 4be8f7ca10b2..1d311823242b 100644
--- a/devel/omniORB/Makefile
+++ b/devel/omniORB/Makefile
@@ -11,8 +11,8 @@ COMMENT= Robust high performance CORBA ORB for C++ and Python
LICENSE= GPLv2
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= member access into incomplete type 'DH' (aka 'dh_st')
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= member access into incomplete type 'DH' (aka 'dh_st')
CONFLICTS= omniORB41-4.1.*
PLIST_SUB+= SONUM=2
diff --git a/devel/poco-ssl/Makefile b/devel/poco-ssl/Makefile
index 284e03e2701f..dd57d39dec65 100644
--- a/devel/poco-ssl/Makefile
+++ b/devel/poco-ssl/Makefile
@@ -16,8 +16,8 @@ COMMENT= C++ libraries with a network/internet focus (full version)
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= field has incomplete type 'EVP_CIPHER_CTX' (aka 'evp_cipher_ctx_st')
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= field has incomplete type 'EVP_CIPHER_CTX' (aka 'evp_cipher_ctx_st')
CONFLICTS= poco-[0-9]*
diff --git a/devel/ptlib/Makefile b/devel/ptlib/Makefile
index dfb803bea908..b145c06e099d 100644
--- a/devel/ptlib/Makefile
+++ b/devel/ptlib/Makefile
@@ -12,8 +12,8 @@ COMMENT= Cross platform C++ library, used by OPAL
LICENSE= MPL10
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= use of undeclared identifier 'BIO_s_file_internal'
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= use of undeclared identifier 'BIO_s_file_internal'
LIB_DEPENDS= libexpat.so:textproc/expat2
diff --git a/devel/staf/Makefile b/devel/staf/Makefile
index c967328be7ce..cd9b417d3e64 100644
--- a/devel/staf/Makefile
+++ b/devel/staf/Makefile
@@ -13,8 +13,8 @@ COMMENT= Software Testing Automation Framework
LICENSE= EPL
LICENSE_FILE= ${WRKSRC}/LICENSE.htm
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= variable has incomplete type 'EVP_MD_CTX' (aka 'evp_md_ctx_st')
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= variable has incomplete type 'EVP_MD_CTX' (aka 'evp_md_ctx_st')
WRKSRC= ${WRKDIR}/src
WRKSRC_SUBDIR= ${PORTNAME}
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 701ea8262817..b85d59ca6e19 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
DISTINFO_FILE= ${.CURDIR}/../thrift/distinfo
BROKEN_powerpc64= fails to compile: undefined reference to std::__throw_out_of_range_fmt
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= 'configure: error: "Error: libcrypto required."'
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= 'configure: error: "Error: libcrypto required."'
USES= autoreconf pkgconfig gmake compiler:c++11-lang \
libtool pathfix ssl
diff --git a/devel/tla/Makefile b/devel/tla/Makefile
index 14fe03fda2a4..d35f03dcfd9c 100644
--- a/devel/tla/Makefile
+++ b/devel/tla/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= GNU/gnu-arch \
MAINTAINER= ports@FreeBSD.org
COMMENT= Original arch source control management CLI written in C
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= incomplete definition of type 'struct X509_name_entry_st'
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= incomplete definition of type 'struct X509_name_entry_st'
BUILD_DEPENDS= gpatch:devel/patch \
gdiff:textproc/diffutils \