aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-07-26 19:59:24 +0000
committerLars Thegler <lth@FreeBSD.org>2004-07-26 19:59:24 +0000
commit3665ede0f5f8109cb86f54f3489f62429d779816 (patch)
treeefc1ef4c111626f00a5091446533b790bb52739d /devel
parentd02eddb9e7efbfbf057b5815f2a20f69ad61467b (diff)
downloadports-3665ede0f5f8109cb86f54f3489f62429d779816.tar.gz
ports-3665ede0f5f8109cb86f54f3489f62429d779816.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Module-Pluggable/Makefile27
-rw-r--r--devel/p5-Module-Pluggable/distinfo2
-rw-r--r--devel/p5-Module-Pluggable/pkg-descr11
-rw-r--r--devel/p5-Module-Pluggable/pkg-plist2
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b723bc7cd380..cac842cac57a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -847,6 +847,7 @@
SUBDIR += p5-Module-CoreList
SUBDIR += p5-Module-Info
SUBDIR += p5-Module-Info-File
+ SUBDIR += p5-Module-Pluggable
SUBDIR += p5-Module-Reload
SUBDIR += p5-Module-ScanDeps
SUBDIR += p5-Module-Versions-Report
diff --git a/devel/p5-Module-Pluggable/Makefile b/devel/p5-Module-Pluggable/Makefile
new file mode 100644
index 000000000000..a9199dc74f0a
--- /dev/null
+++ b/devel/p5-Module-Pluggable/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Module-Pluggable
+# Date created: 2004-07-26
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Pluggable
+PORTVERSION= 1.9
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Automatically give your module the ability to have plugins
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
+ ${SITE_PERL}/File/Spec/Functions.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Module::Pluggable.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Pluggable/distinfo b/devel/p5-Module-Pluggable/distinfo
new file mode 100644
index 000000000000..7fdbae0f5df2
--- /dev/null
+++ b/devel/p5-Module-Pluggable/distinfo
@@ -0,0 +1,2 @@
+MD5 (Module-Pluggable-1.9.tar.gz) = 73a4cba7973a4586e7741f854210292c
+SIZE (Module-Pluggable-1.9.tar.gz) = 6950
diff --git a/devel/p5-Module-Pluggable/pkg-descr b/devel/p5-Module-Pluggable/pkg-descr
new file mode 100644
index 000000000000..30a64d677ed1
--- /dev/null
+++ b/devel/p5-Module-Pluggable/pkg-descr
@@ -0,0 +1,11 @@
+Provides a simple but, hopefully, extensible way of having 'plugins'
+for your module. Obviously this isn't going to be the be all and
+end all of solutions but it works for me.
+
+Essentially all it does is export a method into your namespace that
+looks through a search path for .pm files and turn those into class
+names.
+
+Optionally it instantiates those classes for you.
+
+WWW: http://search.cpan.org/dist/Module-Pluggable/
diff --git a/devel/p5-Module-Pluggable/pkg-plist b/devel/p5-Module-Pluggable/pkg-plist
new file mode 100644
index 000000000000..1754a5d67f86
--- /dev/null
+++ b/devel/p5-Module-Pluggable/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Module/Pluggable.pm
+@unexec rmdir %D/%%SITE_PERL%%/Module 2>/dev/null || true