aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-06-16 14:10:35 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-06-16 14:10:35 +0000
commit50ca6b816699ba8c35c57689baf0e3ba42caa479 (patch)
treed0bd545862a5669d43638af15c78a04e64d86c64 /devel
parentbcfc8ae95c2f5e72031f13f6dc7226bdbfcb3a2e (diff)
downloadports-50ca6b816699ba8c35c57689baf0e3ba42caa479.tar.gz
ports-50ca6b816699ba8c35c57689baf0e3ba42caa479.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/kyua-testers/Makefile40
-rw-r--r--devel/kyua-testers/distinfo2
-rw-r--r--devel/kyua-testers/pkg-descr12
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 56a99063a9e6..4ba1c445f9f6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -914,6 +914,7 @@
SUBDIR += kprof
SUBDIR += kscope
SUBDIR += kyra
+ SUBDIR += kyua-testers
SUBDIR += lasi
SUBDIR += lcov
SUBDIR += leaktracer
diff --git a/devel/kyua-testers/Makefile b/devel/kyua-testers/Makefile
new file mode 100644
index 000000000000..1562cbbab3cc
--- /dev/null
+++ b/devel/kyua-testers/Makefile
@@ -0,0 +1,40 @@
+# Created by: Alan Somers <asomers@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= kyua-testers
+PORTVERSION= 0.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PROJECTHOST= kyua
+
+MAINTAINER= asomers@freebsd.org
+COMMENT= Kyua (automated testing framework) - Testers
+
+LICENSE= BSD
+
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+CONFIGURE_ARGS+= --docdir=${DOCSDIR}
+# TODO: install the tests, once FreeBSD has a system for ports to install tests
+CONFIGURE_ARGS+= --without-atf
+
+PLIST_FILES= libdata/pkgconfig/kyua-testers.pc libexec/kyua-atf-tester
+PLIST_FILES+= libexec/kyua-plain-tester
+.if ! ${PORT_OPTIONS:MDOCS}
+MAKE_FLAGS+= doc_DATA=
+.endif
+
+PORTDOCS= AUTHORS COPYING NEWS README
+MAN1= kyua-atf-tester.1 kyua-plain-tester.1 kyua-tester.1
+MAN5= kyua-tester-list.5 kyua-tester-result.5
+MAN7= kyua-atf-interface.7 kyua-plain-interface.7
+
+post-patch: .SILENT
+ @${REINPLACE_CMD} -e 's|@pkgconfigdir@|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/kyua-testers/distinfo b/devel/kyua-testers/distinfo
new file mode 100644
index 000000000000..218bf5b94ed2
--- /dev/null
+++ b/devel/kyua-testers/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kyua-testers-0.1.tar.gz) = 08f30eef2c967c5451f858ed63c0c4647899d634fcb32dc5fe5fbdb3e0170e49
+SIZE (kyua-testers-0.1.tar.gz) = 165554
diff --git a/devel/kyua-testers/pkg-descr b/devel/kyua-testers/pkg-descr
new file mode 100644
index 000000000000..08b16bb30b8d
--- /dev/null
+++ b/devel/kyua-testers/pkg-descr
@@ -0,0 +1,12 @@
+Kyua (pronounced Q.A.) is a testing framework for both developers and
+users. Kyua is different from most other testing frameworks in that it
+puts the end user experience before anything else. There are multiple
+reasons for users to run the tests themselves, and Kyua ensures that
+they can do so in the most convenient way.
+
+This module, kyua-testers, provides scriptable interfaces to interact
+with test programs of various kinds. The interface of such testers
+allows the caller to execute a single test case of a single test program
+in a controlled and homogeneous manner.
+
+WWW: https://code.google.com/p/kyua/