aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-14 20:08:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-08-14 20:08:48 +0000
commit5c3c527ab16c7ac4c8fd435982e8774af8e118de (patch)
tree30a90821c05ed22068ca33e43abac607ee7463f1 /devel
parentb758ddf0f30a827ec345f72bd4843643127788a9 (diff)
downloadports-5c3c527ab16c7ac4c8fd435982e8774af8e118de.tar.gz
ports-5c3c527ab16c7ac4c8fd435982e8774af8e118de.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-ChangeNotify/Makefile30
-rw-r--r--devel/p5-File-ChangeNotify/distinfo3
-rw-r--r--devel/p5-File-ChangeNotify/pkg-descr9
-rw-r--r--devel/p5-File-ChangeNotify/pkg-plist12
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 958f1ab3d72a..3af969752450 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1384,6 +1384,7 @@
SUBDIR += p5-File-Binary
SUBDIR += p5-File-Cache
SUBDIR += p5-File-Cat
+ SUBDIR += p5-File-ChangeNotify
SUBDIR += p5-File-Copy-Recursive
SUBDIR += p5-File-CreationTime
SUBDIR += p5-File-DesktopEntry
diff --git a/devel/p5-File-ChangeNotify/Makefile b/devel/p5-File-ChangeNotify/Makefile
new file mode 100644
index 000000000000..ae7b9fd0db64
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-File-ChangeNotify
+# Date created: Fri 14 Aug 2009
+# Whom: Alexey V. Degtyarev
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-ChangeNotify
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Watch for changes to files
+
+RUN_DEPENDS= p5-Class-MOP>=0:${PORTSDIR}/devel/p5-Class-MOP \
+ p5-MooseX-SemiAffordanceAccessor>=0:${PORTSDIR}/devel/p5-MooseX-SemiAffordanceAccessor \
+ p5-MooseX-Params-Validate>=0:${PORTSDIR}/devel/p5-MooseX-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+MAN3= File::ChangeNotify.3 \
+ File::ChangeNotify::Event.3 \
+ File::ChangeNotify::Watcher.3 \
+ File::ChangeNotify::Watcher::Inotify.3 \
+ File::ChangeNotify::Watcher::Default.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-ChangeNotify/distinfo b/devel/p5-File-ChangeNotify/distinfo
new file mode 100644
index 000000000000..ee2717ac2945
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-ChangeNotify-0.07.tar.gz) = 1459d99d91420d14d75bb5d000aa3aa2
+SHA256 (File-ChangeNotify-0.07.tar.gz) = 9e4243b955e5d079d83761b45401e4793348016b9a09625f282682187bf67462
+SIZE (File-ChangeNotify-0.07.tar.gz) = 10440
diff --git a/devel/p5-File-ChangeNotify/pkg-descr b/devel/p5-File-ChangeNotify/pkg-descr
new file mode 100644
index 000000000000..a9d255e548aa
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/pkg-descr
@@ -0,0 +1,9 @@
+This module provides an API for creating a File::ChangeNotify::Watcher subclass
+that will work on your platform.
+
+A File::ChangeNotify::Watcher class monitors a directory for changes made to
+any file. You can provide a regular expression to filter out files you are not
+interested in. It handles the addition of new subdirectories by adding them to
+the watch list.
+
+WWW: http://search.cpan.org/dist/File-ChangeNotify/
diff --git a/devel/p5-File-ChangeNotify/pkg-plist b/devel/p5-File-ChangeNotify/pkg-plist
new file mode 100644
index 000000000000..7a83b775f847
--- /dev/null
+++ b/devel/p5-File-ChangeNotify/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/File/ChangeNotify.pm
+%%SITE_PERL%%/File/ChangeNotify/Event.pm
+%%SITE_PERL%%/File/ChangeNotify/Watcher.pm
+%%SITE_PERL%%/File/ChangeNotify/Watcher/Default.pm
+%%SITE_PERL%%/File/ChangeNotify/Watcher/Inotify.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ChangeNotify/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ChangeNotify
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/File/ChangeNotify/Watcher
+@dirrmtry %%SITE_PERL%%/File/ChangeNotify
+@dirrmtry %%SITE_PERL%%/File