aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-10-25 03:20:53 +0000
committerSteve Wills <swills@FreeBSD.org>2013-10-25 03:20:53 +0000
commit647a8e677eac95b75c02e4a213171882c49a5962 (patch)
tree93adc9ccea10fbf1432e7915c87e50bafdfdaecc /devel
parent1e266985afc75061af6ad60ee5ffd7d3f77552e6 (diff)
downloadports-647a8e677eac95b75c02e4a213171882c49a5962.tar.gz
ports-647a8e677eac95b75c02e4a213171882c49a5962.zip
Notes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-gitlab_git/Makefile21
-rw-r--r--devel/rubygem-gitlab_git/distinfo2
-rw-r--r--devel/rubygem-gitlab_git/files/patch-gemspec11
-rw-r--r--devel/rubygem-gitlab_git/pkg-descr3
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 237f1e150dc5..95aa4b7738fc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4104,6 +4104,7 @@
SUBDIR += rubygem-git
SUBDIR += rubygem-github_api
SUBDIR += rubygem-gitlab-pygments.rb
+ SUBDIR += rubygem-gitlab_git
SUBDIR += rubygem-gitlab_meta
SUBDIR += rubygem-glib2
SUBDIR += rubygem-gobject-introspection
diff --git a/devel/rubygem-gitlab_git/Makefile b/devel/rubygem-gitlab_git/Makefile
new file mode 100644
index 000000000000..6d8df8b625bf
--- /dev/null
+++ b/devel/rubygem-gitlab_git/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= gitlab_git
+PORTVERSION= 2.3.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= GitLab wrapper around git objects
+
+RUN_DEPENDS= rubygem-activesupport>=3.2.13:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-github-linguist>=2.3.4:${PORTSDIR}/textproc/rubygem-github-linguist \
+ rubygem-gitlab-grit>=2.6.0:${PORTSDIR}/textproc/rubygem-gitlab-grit
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-gitlab_git/distinfo b/devel/rubygem-gitlab_git/distinfo
new file mode 100644
index 000000000000..6068468676c7
--- /dev/null
+++ b/devel/rubygem-gitlab_git/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/gitlab_git-2.3.1.gem) = 6cd141adef019cfaaeb3fbb249c0346ed243a4f72fb23a8d81cdf295e54f7079
+SIZE (rubygem/gitlab_git-2.3.1.gem) = 11264
diff --git a/devel/rubygem-gitlab_git/files/patch-gemspec b/devel/rubygem-gitlab_git/files/patch-gemspec
new file mode 100644
index 000000000000..b3811279cfef
--- /dev/null
+++ b/devel/rubygem-gitlab_git/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- gitlab_git-2.3.1.gemspec.orig 2013-10-25 03:12:52.869870855 +0000
++++ gitlab_git-2.3.1.gemspec 2013-10-25 03:15:02.203861402 +0000
+@@ -16,7 +16,7 @@
+ requirements:
+ - - ~>
+ - !ruby/object:Gem::Version
+- version: 2.3.4
++ version: 2.9.4
+ type: :runtime
+ prerelease: false
+ version_requirements: !ruby/object:Gem::Requirement
diff --git a/devel/rubygem-gitlab_git/pkg-descr b/devel/rubygem-gitlab_git/pkg-descr
new file mode 100644
index 000000000000..69a2cae12fd8
--- /dev/null
+++ b/devel/rubygem-gitlab_git/pkg-descr
@@ -0,0 +1,3 @@
+GitLab wrapper around git objects
+
+WWW: http://rubygems.org/gems/gitlab_git